qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
welele
Baby Hen
Posts: 11
Joined: Sat Mar 31, 2018 15:01

qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

Post by welele » Wed Mar 04, 2020 10:59

Since the upgrade to qt-5.14.1 familly, I have issue with compilation over qtwebkit.

I have qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 installed with equo, from sabayonlinux.org.

A "emerge zeal" (which depend on qtwebit) fail with :

-- Installing in the same prefix as Qt, adopting their path scheme.
CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package):
Found package configuration file:

/usr/lib64/cmake/Qt5WebKit/Qt5WebKitConfig.cmake

but it set Qt5WebKit_FOUND to FALSE so package "Qt5WebKit" is considered to
be NOT FOUND. Reason given by package:

Qt5WebKit could not be found because dependency is required to have exact
version 5.12.x.

Call Stack (most recent call first):
src/libs/core/CMakeLists.txt:12 (find_package)


-- Configuring incomplete, errors occurred!

I suspect it's caused by compilation of the dev-qt/qtwebkit-5.212.0_pre20190629 package over qt-5.12, but i lack of xp in this area...

welele
Baby Hen
Posts: 11
Joined: Sat Mar 31, 2018 15:01

Re: qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

Post by welele » Thu Mar 26, 2020 16:46

dev-qt/qtwebkit-5.212.0_pre20190629 in repo still bogus (linked with old qt).
A "emerge dev-qt/qtwebkit-5.212.0_pre20190629" solve my previous issue (emerging zeal). But the package in repo still bogus and need to be recompiled over new version of qt.

joost
Sagely Hen
Posts: 2775
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

Post by joost » Thu Mar 26, 2020 17:27

I will recompile it, just ran into it myself on build chroot:

Code: Select all

CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package):
  Found package configuration file:

    /usr/lib64/cmake/Qt5WebKit/Qt5WebKitConfig.cmake

  but it set Qt5WebKit_FOUND to FALSE so package "Qt5WebKit" is considered to
  be NOT FOUND.  Reason given by package:

  Qt5WebKit could not be found because dependency is required to have exact
  version 5.12.x.

Call Stack (most recent call first):
  CMakeLists.txt:47 (find_package)


-- Configuring incomplete, errors occurred!
See also "/var/tmp/portage/kde-apps/rocs-19.12.3/work/rocs-19.12.3_build/CMakeFiles/CMakeOutput.log".
Thanks for reporting.
My blog | Mastodon | Please support Sabayon: Become a Patron

welele
Baby Hen
Posts: 11
Joined: Sat Mar 31, 2018 15:01

Re: qt-5.14.1-r1 and dev-qt/qtwebkit-5.212.0_pre20190629 issue

Post by welele » Fri Mar 27, 2020 8:27

You're welcome.
Thank you for fixing it ;)

Post Reply