Update/Upgrade Failure [Solved]

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
VolvoBirkenstock
Advanced Hen
Posts: 205
Joined: Sun Mar 31, 2013 5:34

Update/Upgrade Failure [Solved]

Post by VolvoBirkenstock » Sun Dec 09, 2018 2:10

Hello, Sabayon Gurus.

I just attempted to update/upgrade my desktop and laptop. As I do every weekend, I performed the following using sabayon-weekly:

Code: Select all

su
equo update
equo upgrade --multifetch=10
I performed a LFC on my laptop last weekend using a very recent DAILY KDE image. On my laptop, this upgrade command resulted in at least 111 packages being downloaded. Upgrade ran to completion. I consider that a success, but I have not tested the laptop's performance yet.

On my desktop, this update/upgrade process resulted in only 5 packages being downloaded. The following comment is written to stdout near the end of the upgrade process:

Code: Select all

`  @@ There are more updates to install, reloading Entropy.
`  @@ Calculating System Updates: 
`  @@ Calculating dependencies...
"  @@ Dependencies not found:
"    # Not found: >=sys-apps/sysvinit-2.87-r3
I note that there is no sys-apps/sysvinit on my desktop. I also note that it is not offered through Rigo. Can you provide me with explicit instructions on how to proceed? Or should I consider performing a very time-consuming LFC on my desktop as soon as possible?

Thank you very much in advance.
Last edited by VolvoBirkenstock on Sun Dec 09, 2018 23:30, edited 1 time in total.

User avatar
sabayonino
Sagely Hen
Posts: 3290
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Update/Upgrade Failure

Post by sabayonino » Sun Dec 09, 2018 17:06

sysvinit was dropped many years ago when Sabayon switched to systemd

Code: Select all

# equo i entropy --relaxed --ask

Code: Select all

# equo u --nodeps --ask
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

VolvoBirkenstock
Advanced Hen
Posts: 205
Joined: Sun Mar 31, 2013 5:34

Re: Update/Upgrade Failure

Post by VolvoBirkenstock » Sun Dec 09, 2018 23:28

Thank you yet again, sabayonino.
As per your instructions, I executed

Code: Select all

# su
# equo install entropy --relaxed --ask
# equo upgrade --nodeps --ask
and this solved the problem.
This raises the questions of
1. "Why was this necessary?"
2. "Why wasn't the usual manipulation of 'equo undate' and 'equo upgrade' sufficient?"
If I understood this, I might advance beyond my lower-level of "Sabayonism". <smile>

Marking this thread as "Solved", but I would greatly appreciate the additional understanding you might be able to provide to me.

Thank you very, very much.

User avatar
sabayonino
Sagely Hen
Posts: 3290
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Update/Upgrade Failure [Solved]

Post by sabayonino » Mon Dec 10, 2018 0:50

binutils/entropy/gcc/portage and few other packages should (aka must) be update early 'cause they're very important system packages

I don't why sysvinit package appears ... --nodeps is a workaround to fix the block
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

VolvoBirkenstock
Advanced Hen
Posts: 205
Joined: Sun Mar 31, 2013 5:34

Re: Update/Upgrade Failure [Solved]

Post by VolvoBirkenstock » Mon Dec 10, 2018 4:08

Thank you, sabayonino.

So every once in a while I should force installation and upgrade of entropy with relaxed dependency constraints to ensure that binutils, entropy, gcc and portage are updated, and the use of nodeps is a method used to get around a block.

Thank you very much yet again!!!

Post Reply