entropy require glibc, portage, entropy update

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :)

Moderator: Moderators

Post Reply
aliquis
Baby Hen
Posts: 5
Joined: Mon Jan 15, 2018 18:43

entropy require glibc, portage, entropy update

Post by aliquis » Tue Sep 25, 2018 13:04

hello I have installed sabayon 18.05 minimal on my laptop and everything goes well only I need broadcom-sta driver. The problem is entropy ask me to update glibc, entropy and portage (critical packages) and whit these other 319 packages. I don't want upgrade the system because break occur. I can't install any package whithout entropy force this upgrade. How can I safely install newer version of glibc,portage and entropy whithout system damage or how can I avoid this upgrade? Thanks

User avatar
sabayonino
Sagely Hen
Posts: 3290
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: entropy require glibc, portage, entropy update

Post by sabayonino » Tue Sep 25, 2018 13:31

check what you're going to install running :

Code: Select all

# equo i entropy equo --relaxed --pretend 
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

aliquis
Baby Hen
Posts: 5
Joined: Mon Jan 15, 2018 18:43

Re: entropy require glibc, portage, entropy update

Post by aliquis » Tue Sep 25, 2018 15:09

the output of equo i entropy equo --relaxed --pretend is to update 301 packages ( all installed packages)
This append with all package I want to install

User avatar
sabayonino
Sagely Hen
Posts: 3290
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: entropy require glibc, portage, entropy update

Post by sabayonino » Tue Sep 25, 2018 19:32

Do this at your risk or ignore !

Make a current entropy database backup

Code: Select all

# equo rescue backup
Install glibc and portage packages

Code: Select all

# equo i glibc portage --nodeps --ask
Install equo/entropy packages only

Code: Select all

# equo i equo entropy --nodeps --ask
Install whatever you want. (append --ask or --pretend option on your comamnd)

If the things go wrong you can try to restore your entropy backup

Code: Select all

# equo rescue restore
(choose your backup)

Make sure : do not update the database 'cause your old database will be overwritten. (do not run 'equo update')

Upgrade your system

Code: Select all

# equo upgrade --ask
If you don't have any internet connection , run

Code: Select all

# nmtui
to enable your net

Good Luck !
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

Stupot
Sagely Hen
Posts: 1680
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: entropy require glibc, portage, entropy update

Post by Stupot » Tue Sep 25, 2018 19:34

Upgrading glibc requires that all packages compiled against it are updated, there's no way around it. Your safest bet is to simply let it upgrade.

joost
Sagely Hen
Posts: 2718
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands
Contact:

Re: entropy require glibc, portage, entropy update

Post by joost » Tue Sep 25, 2018 21:21

Indeed, do not workaround glibc.
Image
My blog | Twitter | Please support Sabayon: Image

Post Reply