Careful! Bug in Nvidia Drivers 390.48

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Post Reply
Tedel
Growing Hen
Posts: 111
Joined: Sun Mar 10, 2013 5:32
Location: Peru
Contact:

Careful! Bug in Nvidia Drivers 390.48

Post by Tedel » Thu Jul 05, 2018 16:13

Hi,

I upgraded today to kernel 4.17 (which cames along with Nvidia drivers 390.48 and other 2 options) but I got a blank screen and a flickering cursor that never let me log in to console.

After searching for a while, I found this thread on Gentoo forums, which appears to be very related. While our fellow distro masters take a look at the issue, a friendly warning: stick to Nvidia Drivers 390.42. :)

msdobrescu
Old Dear Hen
Posts: 626
Joined: Sun Aug 21, 2011 8:48

Re: Careful! Bug in Nvidia Drivers 390.48

Post by msdobrescu » Thu Jul 05, 2018 19:59

Hi, has hit me too. I have downgraded to 4.16, but I can't make it work.
Please advice.

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Careful! Bug in Nvidia Drivers 390.48

Post by sabayonino » Thu Jul 05, 2018 20:19

Thanks for reporting

please report to https://bugs.sabayon.org/ also and provide some extra infos (hardware and VGA)
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

msdobrescu
Old Dear Hen
Posts: 626
Joined: Sun Aug 21, 2011 8:48

Re: Careful! Bug in Nvidia Drivers 390.48

Post by msdobrescu » Thu Jul 05, 2018 20:44

Well, I have, but I can't make it work with the old kernel/nvidia drivers. This is outstanding.

msdobrescu
Old Dear Hen
Posts: 626
Joined: Sun Aug 21, 2011 8:48

Re: Careful! Bug in Nvidia Drivers 390.48

Post by msdobrescu » Thu Jul 05, 2018 21:32

Where could I check for the difference between these packages, 390.42 and 390.48?

msdobrescu
Old Dear Hen
Posts: 626
Joined: Sun Aug 21, 2011 8:48

Re: Careful! Bug in Nvidia Drivers 390.48

Post by msdobrescu » Thu Jul 05, 2018 22:10

The behavior of both kernels ends in that flickering prompt now. Is there any possibility to have the cause in the /etc/init.d/nvidia_smi file change between the nvidia userspace versions?

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Careful! Bug in Nvidia Drivers 390.48

Post by sabayonino » Thu Jul 05, 2018 22:24

/etc/init.d/ directory is part of OpenRC that is no longe mantained.

which nvidia-userspace version do you have installed ?
something like

Code: Select all

$ equo s -qv --installed nvidia-{userspace,drivers}
x11-drivers/nvidia-userspace-396.24
x11-drivers/nvidia-drivers-396.24#4.16.0-sabayon
or

Code: Select all

$ equo q installed -qv nvidia-{userspace,drivers}
x11-drivers/nvidia-userspace-396.24
x11-drivers/nvidia-drivers-396.24#4.16.0-sabayon
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

msdobrescu
Old Dear Hen
Posts: 626
Joined: Sun Aug 21, 2011 8:48

Re: Careful! Bug in Nvidia Drivers 390.48

Post by msdobrescu » Fri Jul 06, 2018 6:26

I have a 560Ti card, this needs some masking to work, so I use a version less than 396. I've cleaned up the system and managed to install 390.42 and works.
A surprise - is this normal? - is that installing nvidia-drivers did not pull the according nvidia-userspace version. Also, uninstalling nvidia-drivers did not uninstall the corresponding nvidia-userspace version.
Asking to install nvidia-drivers, without specifying a version, like 4.16, pulled the latest kernel and nvidia-drivers again, i.e. 4.17.

I know init.d should not be used anymore, but that part being changed makes me think if something inside did the same for systemd too, that breaks the whole thing after installing 4.16 only again. That until I remove the 4.17 nvidia-userspace.

Tedel
Growing Hen
Posts: 111
Joined: Sun Mar 10, 2013 5:32
Location: Peru
Contact:

Re: Careful! Bug in Nvidia Drivers 390.48

Post by Tedel » Fri Jul 06, 2018 15:37

msdobrescu wrote:
Thu Jul 05, 2018 19:59
Hi, has hit me too. I have downgraded to 4.16, but I can't make it work.
Please advice.
I am booting kernel 4.14 and Nvidia drivers 390.42. Those should still be in sabayon-weekly repository.

As for what is happening, version 390.48 of the driver looks for a routine that is not in use (swiotlb_map_sg_attrs). As it doesn't find it, it fails. There is already a patch, so I guess it is just a matter of waiting until we get a new driver version or the patch is distributed in Gentoo.

source: https://devtalk.nvidia.com/default/topi ... _sg_attrs-

Post Reply