how to verify integrity of installed packages or fixed a broken system

If you are new to Linux or new to Sabayon Linux and just not sure where to post, here ya go. Post without fear of being told to RTFM :-)

Moderator: Moderators

Post Reply
kevinfish
Young Hen
Posts: 27
Joined: Sat Mar 05, 2011 3:12

how to verify integrity of installed packages or fixed a broken system

Post by kevinfish » Wed Jun 27, 2018 20:17

I'm developing some software for the browser and right in the middle of it it won't work for chrome, chromium, nor firefox. I've gone back to earlier versions and they don't work either. Here's the messages I'm getting in the JS console of chrome:

Code: Select all

Uncaught TypeError: Failed to execute 'appendChild' on 'Node': parameter 1 is not of type 'Node'.
    at HTMLDivElement.HTMLElement.appendChild (<anonymous>:329:46)
    at HTMLDivElement.Element.hoplon$core$ICustomElement$_append_child_BANG_$arity$2 (:7000/index.html.out/hoplon/core.js:1393)
    at hoplon$core$_append_child_BANG_ (:7000/index.html.out/hoplon/core.js:556)
    at hoplon$core$append_child_BANG_ (:7000/index.html.out/hoplon/core.js:729)
    at hoplon.ui.elems.Elem.hoplon$core$ICustomElement$_append_child_BANG_$arity$2 (:7000/index.html.out/hoplon/ui/elems.js:123)
    at hoplon$core$_append_child_BANG_ (:7000/index.html.out/hoplon/core.js:556)
    at hoplon$core$append_child_BANG_ (:7000/index.html.out/hoplon/core.js:729)
    at hoplon$core$add_children_BANG_ (:7000/index.html.out/hoplon/core.js:1154)
    at hoplon.ui.elems.box_with (:7000/index.html.out/hoplon/ui/elems.js:235)
    at hoplon.ui.pointable (:7000/index.html.out/hoplon/ui.js:811)
websocket.js:283 WebSocket connection to 'ws://localhost:41519/' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED
goog.net.WebSocket.open @ websocket.js:283
:7000/index.html.out/adzerk/boot_reload/client.js:127 Reload websocket error: goog.net.WebSocket.ErrorEvent
(anonymous) @ :7000/index.html.out/adzerk/boot_reload/client.js:127
:7000/index.html.out/adzerk/boot_reload/client.js:121 Reload websocket connection closed.
:7000/[%22MagistralC%20Bold%22]:1 Failed to load resource: the server responded with a status of 404 (Not Found)
localhost/:329 Uncaught TypeError: Failed to execute 'appendChild' on 'Node': parameter 1 is not of type 'Node'.
    at HTMLDivElement.HTMLElement.appendChild (<anonymous>:329:46)
    at HTMLDivElement.Element.hoplon$core$ICustomElement$_append_child_BANG_$arity$2 (:7000/index.html.out/hoplon/core.js:1393)
    at hoplon$core$_append_child_BANG_ (:7000/index.html.out/hoplon/core.js:556)
    at hoplon$core$append_child_BANG_ (:7000/index.html.out/hoplon/core.js:729)
    at hoplon.ui.elems.Elem.hoplon$core$ICustomElement$_append_child_BANG_$arity$2 (:7000/index.html.out/hoplon/ui/elems.js:123)
    at hoplon$core$_append_child_BANG_ (:7000/index.html.out/hoplon/core.js:556)
    at hoplon$core$append_child_BANG_ (:7000/index.html.out/hoplon/core.js:729)
    at hoplon$core$add_children_BANG_ (:7000/index.html.out/hoplon/core.js:1154)
    at hoplon.ui.elems.box_with (:7000/index.html.out/hoplon/ui/elems.js:235)
    at hoplon.ui.pointable (:7000/index.html.out/hoplon/ui.js:811)
(index):1 The resource http://localhost:7000/magistralc-bold.otf was preloaded using link preload but not used within a few seconds from the window's load event. Please make sure it has an appropriate `as` value and it is preloaded intentionally.
It still works in electron but there are other reasons why there are problems developing there.

Its looking to me like there must be some kind of system corruption that has crept in.

Is there a process I can use to have sabayon run thru all the packages and make sure all their contents and the files they generated are still pristine?

TIA,
-Kevin

Stupot
Sagely Hen
Posts: 1663
Joined: Wed Feb 14, 2007 3:44
Location: St. Louis, MO, USA

Re: how to verify integrity of installed packages or fixed a broken system

Post by Stupot » Thu Jun 28, 2018 4:47

I'm not gonna lie, it doesn't look like system corruption to me. Maybe some sort of configuration change.

This line in particular:

Code: Select all

websocket.js:283 WebSocket connection to 'ws://localhost:41519/' failed: Error in connection establishment: net::ERR_CONNECTION_REFUSED
goog.net.WebSocket.open @ websocket.js:283(Not Found)
Makes it looks like maybe you've changed ports in one place, but not another, or changed a resource path and didn't update all the references. Or maybe somehow you've enabled a firewall that you didn't previously didn't have enabled.

When you say you went back to earlier versions, I assume you mean earlier versions of your website/webapp, correct?

I'd maybe look up some networking tools like netstat to see if they can help shed some light on your port situation.

Post Reply