Mancato riconoscimento connessione wireless

Se sei un utente alle prime armi con Linux o Sabayon, questo è il posto che fa per te :)

Moderator: Moderators

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Mancato riconoscimento connessione wireless

Post by ermandrea » Fri Dec 23, 2016 10:59

Buongiorno a tutti,
ho eseguito una nuova installazione di Sabayon GNOME su di un portatile, ma non riconosce la scheda wifi:

Code: Select all

08:00.0 Network controller: Intel Corporation Wireless 3160 (rev 83)
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Mancato riconoscimento connessione wireless

Post by ermandrea » Mon Dec 26, 2016 12:56

Dando

Code: Select all

$ dmesg -HT
mi dà questi errori:

Code: Select all

[lun dic 26 12:12:57 2016] Initializing HPQ6001 module
[lun dic 26 12:12:57 2016] input: HP Wireless hotkeys as /devices/virtual/input/input6
[lun dic 26 12:12:58 2016] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[lun dic 26 12:12:58 2016] hp_accel: laptop model unknown, using default axes configuration
[lun dic 26 12:12:58 2016] lis3lv02d: unknown sensor type 0x0
[lun dic 26 12:12:58 2016] hp_accel: probe of HPQ6007:00 failed with error -22

Code: Select all

[lun dic 26 12:12:59 2016] Intel(R) Wireless WiFi driver for Linux
[lun dic 26 12:12:59 2016] Copyright(c) 2003- 2015 Intel Corporation
[lun dic 26 12:12:59 2016] iwlwifi 0000:08:00.0: Direct firmware load for iwlwifi-3160-17.ucode failed with error -2
[lun dic 26 12:12:59 2016] iwlwifi 0000:08:00.0: loaded firmware version 16.242414.0 op_mode iwlmvm
[lun dic 26 12:12:59 2016] iwlwifi 0000:08:00.0: Detected Intel(R) Dual Band Wireless AC 3160, REV=0x164
[lun dic 26 12:12:59 2016] iwlwifi 0000:08:00.0: L1 Enabled - LTR Enabled
[lun dic 26 12:12:59 2016] iwlwifi 0000:08:00.0: L1 Enabled - LTR Enabled
[lun dic 26 12:12:59 2016] usbcore: registered new interface driver btusb
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Mancato riconoscimento connessione wireless

Post by ermandrea » Mon Dec 26, 2016 13:00

Cercando avevo trovato anche questo: https://forums.gentoo.org/viewtopic-t-1001638.html
Mi date una mano a capire come poter risolvere il problema? Grazie mille
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
sabayonino
Sagely Hen
Posts: 3339
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Mancato riconoscimento connessione wireless

Post by sabayonino » Tue Dec 27, 2016 13:19

l'output elencato non sono errori

la tua scheda wireless è riconosciuta. forse però non è attivata

nm-applet è installato ? , hai l'cona nella barra superiore ?

hai modo id connetterti via cavo ?

puoi postare :

Code: Select all

# ifconfig

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Mancato riconoscimento connessione wireless

Post by ermandrea » Tue Dec 27, 2016 15:58

Avvolte se insisto dopo un pò ci stà che si connetta in wifi... Avvolte passano ore. Quando non è connesso non c'è l'icona in alto della connessione

Code: Select all

# ifconfig
enp7s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 30:8d:99:1c:ec:66  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Local Loopback)
        RX packets 44168  bytes 3709920 (3.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 44168  bytes 3709920 (3.5 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp8s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.129  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::f4f4:e71d:b7b3:90a2  prefixlen 64  scopeid 0x20<link>
        ether e4:f8:9c:48:75:6a  txqueuelen 1000  (Ethernet)
        RX packets 3534  bytes 3672643 (3.5 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 2781  bytes 579472 (565.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
sabayonino
Sagely Hen
Posts: 3339
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Mancato riconoscimento connessione wireless

Post by sabayonino » Tue Dec 27, 2016 19:16

sembra che il wifi vada in poweroff

mi ricorda un vecchio problema di qualche anno fa

che risolsi installando acpi ed abilitandolo

Code: Select all

# equo i acpid

Code: Select all

# systemctl enable acpid && reboot
testare please :mrgreen:

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Mancato riconoscimento connessione wireless

Post by ermandrea » Wed Dec 28, 2016 14:14

testato ma niente, non ha sortito effetti :(
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8186
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Mancato riconoscimento connessione wireless

Post by Fitzcarraldo » Thu Dec 29, 2016 0:08

ermandrea wrote:

Code: Select all

lun dic 26 12:12:59 2016] iwlwifi 0000:08:00.0: Direct firmware load for iwlwifi-3160-17.ucode failed with error -2
Scarica il file dal seguente link e copiarlo nella directory /lib/firmware/ (Probabilmente questo non risolverà il problema, ma almeno vi darà l'ultima versione del driver):

http://git.kernel.org/cgit/linux/kernel ... 0-17.ucode

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Mancato riconoscimento connessione wireless

Post by ermandrea » Thu Dec 29, 2016 13:58

Grazie, basta aggiungerlo giusto?
Comunque non ho risolto il problema e non sò come fare... Senza wifi sul portatile è mortificante... Non capisco cosa possa essere...
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

User avatar
ermandrea
Growing Hen
Posts: 101
Joined: Thu Dec 11, 2014 11:40

Re: Mancato riconoscimento connessione wireless

Post by ermandrea » Sun Jan 01, 2017 11:25

Ho notato che quando cerco di attivare la wifi, quando provo ad attivarla dalle impostazioni della gestione energia di gnome è più probabile che riesca ad attivarmela... Non è che magari c'è qualche mala gestione di una sorta di risparmio energetico o qualcosa del genere?
Intel Core 2 Quad Q8200 2,33 GHz _ ATI Radeon HD4650 _ Memoria 4 GB _ Sabayon KDE

Post Reply