Problemi dopo aggiornamento Sabayon 5.5 con Gnome [Risolto]

Problemi relativi a KDE, GNOME o altri ambienti grafici? Scrivi pure qui!

Moderator: Moderators

defonta
Young Hen
Posts: 28
Joined: Mon Jan 17, 2011 20:18

Problemi dopo aggiornamento Sabayon 5.5 con Gnome [Risolto]

Post by defonta » Mon May 23, 2011 13:00

Ho installato Sabayon 5.5 diversi mesi fà su un vecchio notebook (EVO N610c), circa 10 gg fà ho aggiornato la mia distro, da allora non mi parte più gnome ma devo9 lanciarlo successivamente, ho provato e cercato diverse soluzioni, ma ho dovuto rinunciare, ho reinstallato tutto, e funziona, rifaccio gli aggiornamenti e si riblocca tutto, ho capito che potrebbe dipendere da hal, ma nei repo non esiste più, dovrebbe essere stato sostituito da udev, cerco soluzioni.
Last edited by defonta on Wed Jun 01, 2011 18:09, edited 1 time in total.

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by micia » Mon May 23, 2011 13:07

Ciao,
il problema non può dipendere da HAL, non esiste più, è stato sostituito da udisk e upower che usano udev per i loro scopi (come faceva HAL).
Il problema o risiede nei driver video e nella loro configurazione, o nei file di configurazione di X.
In ambo i casi ci serve sapere meglio cosa succede.

* Cosa vuol dire "non parte"?

Ti viene una schermata testuale, GDM ti avvisa che non può avviarsi e ti mostra un log di errore, o cos'altro?

* Hai qualche log di errore?

Ti viene mostrato un messaggio di errore durante il boot, se premi Alt+F1 o F2, riesci a reperire il file:
/var/log/Xorg.0.log
/var/log/Xorg.0.log.old
?

defonta
Young Hen
Posts: 28
Joined: Mon Jan 17, 2011 20:18

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by defonta » Mon May 23, 2011 16:51

premetto che fino all'aggiornamento tutto funzionava, poi ha cominciato con questo errore:

ERROR: xdm needs service(s) hald

e si fermava sul login testuale
mi logavo, poi con sudo gdm partiva senza errori e funzionava tutto, nel cercare di risolvere questo ho incasinato talmente il sistema che ho reistallato tutto, ieri dopo l'aggiornamento, mi dava lo stesso errore, ma non partiva ne startx, ne gdm come facevo prima, oggi ho reistallato, e voglio vedere chè succede. però prima di aggiornare se hai dei consigli vediamo.

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by micia » Mon May 23, 2011 16:54

Una cosa simile mi fa venire in mente che tu ti sia scordato di aggiornare i file di configurazione.
Dopo l'aggiornamento hai eseguito:
(come root)

Code: Select all

equo conf update
?

Perché quell'errore è dato, con ogni probabilità, da openRC, ovvero chi si occupa di lanciare i servizi iniziali all'avvio del sistema (prima di arrivare al login), vedendo le dipendenze dei servizi stabilisce che serve hald ma, giustamente, non c'è. Una cosa simile può avvenire soltanto se non hai aggiornato gli script che openRC usa per stabilire le dipendenze.

defonta
Young Hen
Posts: 28
Joined: Mon Jan 17, 2011 20:18

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by defonta » Mon May 23, 2011 17:37

por..... credo che tu abbia ragione, la soluzione era una stupidata, e io mi sono perso come un allocco, ora riaggiorno provo e poi ti dico, ma non sarebbe meglio che sulfur facesse anche questo lavoro sporco?

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by sabayonino » Mon May 23, 2011 18:25

è successo anche a me ... ho reinstallato upower

dopo il equo conf update ho dato un bel -5 di sana pianta ...
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

defonta
Young Hen
Posts: 28
Joined: Mon Jan 17, 2011 20:18

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by defonta » Tue May 24, 2011 12:23

quel problema è risolto, ma ora ne ho un altro, gnome ha sostituito i caratteri con quadretti, se scrivo nel terminale mi escono quadretti, come se fosse impostato un altra lingua o addirittura nessun font, se invece apro xterm funziona tutto.

indicazioni?

grazie ancora

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by micia » Tue May 24, 2011 12:42

prova ad eseguire:
(come root)

Code: Select all

equo deptest
equo libtest
poi, per favore, riporta cosa ti dicono:

Code: Select all

eselect python list

User avatar
sabayonino
Sagely Hen
Posts: 3253
Joined: Sun Sep 21, 2008 1:12
Location: Italy
Contact:

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by sabayonino » Tue May 24, 2011 18:24

:D il problema dei quadretti mi sembra si risolvesse con la reinstallazione di x11-libs/gtk+ ... ma ora vado proprio a memoria
Last edited by sabayonino on Tue May 24, 2011 18:46, edited 2 times in total.
[Che Cos'è Il Calcolo Distribuito (BOINC)

BOINC ready ! Sabayon+BOINC = BILD ,my Sabayon spin :cyclops: - Ready to crunch for the Science everywhere :)

micia
Sagely Hen
Posts: 2718
Joined: Wed Nov 26, 2008 16:41
Contact:

Re: Problemi dopo aggiornamento Sabayon 5.5 con Gnome

Post by micia » Tue May 24, 2011 18:28

... Ma son l'unico che ha installato Sabayon 5.5G da pochissimo, ha eseguito gli aggiornamenti e non ha avuto nessun problema di sorta? :shock:

Post Reply