--- Invalid atom in /etc/portage/package.use [Solved]

Anything that pertains to Portage

Moderator: Moderators

--- Invalid atom in /etc/portage/package.use [Solved]

Postby radolx » Fri Jun 26, 2009 11:04

Hi this shows me when I emerge.
This is line from /etc/portage/package.use
Code: Select all
x11-libs/qt-4 -pertty immqt-bc
Last edited by radolx on Sun Jun 28, 2009 0:11, edited 1 time in total.
radolx
Simple Hen
 
Posts: 60
Joined: Wed Jun 17, 2009 16:36

Re: --- Invalid atom in /etc/portage/package.use: x11-libs/qt-4

Postby Thev00d00 » Fri Jun 26, 2009 18:02

Well its because that is an invalid flag as it says in the error.

Did you add that? Do we ship it? It should be just qt4 if you want it off and -qt4 if you want it off, same with pertty.

You should really do some reasearch if you are going to use portage.
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: --- Invalid atom in /etc/portage/package.use: x11-libs/qt-4

Postby radolx » Sun Jun 28, 2009 0:09

Thanks a lot it helped to change it for x11-libs/-qt4 -pertty immqt-bc
radolx
Simple Hen
 
Posts: 60
Joined: Wed Jun 17, 2009 16:36

Re: --- Invalid atom in /etc/portage/package.use [Solved]

Postby Thev00d00 » Mon Jun 29, 2009 7:42

Nope still not quite right, its

Category/appname flags go here

So

x11-libs/qt pertty etc

You should do some reading =p
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests