layman -S not synching overlay - layman -a fails [Solved]

Anything that pertains to Portage

Moderator: Moderators

layman -S not synching overlay - layman -a fails [Solved]

Postby tonyawards » Wed Jun 24, 2009 5:26

I just got an error message when attempting to "emerge --sync && layman -S" - I then tried to re-synch the overlay with the normal sequence (layman -d, -f, -a).
I could delete the overlay, but cannot seem to add the sabayon overlay back in. See:

# layman -d sabayon
* Successfully deleted overlay "sabayon".
# layman -f
# layman -a sabayon
* Running command "/usr/bin/git clone "git://sabayon.org/projects/overlay.git" "/usr/local/portage/layman/sabayon""...
Initialized empty Git repository in /usr/local/portage/layman/sabayon/.git/
sabayon.org[0: 193.200.56.132]: errno=Connection refused
fatal: unable to connect a socket (Connection refused)
* Failed to add overlay "sabayon".
* Error was: Adding the overlay failed! Possible remains of the opration have NOT been removed and may be left at /usr/local/portage/layman/sabayon. Please remove them manually if required.

Any ideas as to why I might be having this problem?

This is what is currently in my overlays file:

<?xml version="1.0" ?>
<overlays/>

and that's all.

What do I need to manually add, and where in the file? Or is there something else I am doing wrong?

Thank you all.
Last edited by tonyawards on Thu Jun 25, 2009 2:40, edited 1 time in total.
SL Version: XI+, just rollin' along / Kernel 3.8.3 | KDE 4.10.1 | HP dv6000z | AMD Turion64 MK-36 | 2GB RAM | nVidia GeForce 6150
tonyawards
Growing Hen
 
Posts: 112
Joined: Sun Nov 23, 2008 4:21

fetch-pack 'overlay.git/' failed. [Solved]

Postby joe3 » Wed Jun 24, 2009 6:24

fetch-pack from 'git://sabayon.org/projects/overlay.git/' failed.

I've got a sabayon 3.5 installation that until recently was the most reliable linux on my ageing pc...

Since it had everything I wanted to use and was more stable on my outdated hardware than sabayon 4, I had no plans to update anything. But recently xine stopped working. So I wanted to see if an 'emerge media-libs/xine-lib --ask' would fix it. so of course I had to do a "emerge --sync" and an "layman -S" The "emerge --sync" led to an "emerge portage"...

So far so good. But when I tried the 'layman -S' I got:

> You currently sync from "http://svn.sabayonlinux.org/overlay/"
> while the global layman list reports "git://sabayon.org/projects/overlay.git"
> as correct location. Please consider removing and readding the overlay!

A little googleing got me to the recommendation to do:

# layman -d sabayon
# layman -a sabayon
# layman -S

The sabayon overly delete worked just fine, but when I tried to re-add it:

> UnderTree =-> layman -a sabayon
> * Running command "/usr/bin/git clone "git://sabayon.org/projects/overlay.git/" "/usr/portage/local/layman/sabayon""...
> Initialized empty Git repository in /usr/portage/local/layman/sabayon/.git/
> sabayon.org[0: 193.200.56.132]: errno=Connection refused
> fatal: unable to connect a socket (Connection refused)
> fetch-pack from 'git://sabayon.org/projects/overlay.git/' failed.
> * Failed to add overlay "sabayon".
> * Error was: Directory /usr/portage/local/layman/sabayon does not exist. Cannot remove the overlay!
> UnderTree =->

Well a little more poking around and I learned that I might need to install git... However I checked with emerge -s and found that I did at least have an older version of it.


> * dev-util/git
> Latest version available: 1.6.3.3
> Latest version installed: 1.5.4.2


Would someone be so kind as to give me a clue what I'm doing wrong?

--
joe3
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: layman -S not synching overlay - layman -a sabayon fails

Postby wolfden » Wed Jun 24, 2009 8:55

post your make.conf file
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: layman -S not synching overlay - layman -a sabayon fails

Postby dave_p_b » Wed Jun 24, 2009 13:30

Hi Wolfden

It's fine now. I just think the "git sabayon overlay" site was down overnight.

All the best

Dave
dave_p_b
Old Dear Hen
 
Posts: 607
Joined: Fri Dec 15, 2006 1:39
Location: Exeter, UK

Re: fetch-pack 'git://sabayon.org/projects/overlay.git/' failed.

Postby kodiakmax » Wed Jun 24, 2009 16:42

try re-adding the overlay again. this git repo seemed to be having some hiccups last night. --> viewtopic.php?f=54&t=17375
If you check the wiki, use the search function and google you can find the answer to most of your questions.

Remember to mark your thread [Solved] if your issue is fixed.
kodiakmax
Advanced Hen
 
Posts: 278
Joined: Thu Oct 16, 2008 23:46

Re: layman -S not synching overlay - layman -a sabayon fails

Postby tonyawards » Thu Jun 25, 2009 2:39

...and that did it - you were right, dave_p_b - it syncs just fine now. For the record, wolfden, the old make.conf was:

PORTDIR_OVERLAY="
$PORTDIR_OVERLAY
"
and now it's better:

PORTDIR_OVERLAY="
/usr/local/portage/layman/sabayon
$PORTDIR_OVERLAY
"
The overlay is looking good too:

<?xml version="1.0" ?>
<overlays>
<overlay contact="[email protected]" name="sabayon" src="git://sabayon.org/projects/overlay.git" type="git">

<link>
http://sabayonlinux.org
</link>
<description>
Purpose To provide ebuilds that were created from
the Sabayon Linux project such as customized programs, ebuilds
not in the official portage, artwork, themes, etc. Bugs to
http://bugs.sabayonlinux.org/bugs/
</description>
</overlay>
</overlays>

Thanks again, as always.
SL Version: XI+, just rollin' along / Kernel 3.8.3 | KDE 4.10.1 | HP dv6000z | AMD Turion64 MK-36 | 2GB RAM | nVidia GeForce 6150
tonyawards
Growing Hen
 
Posts: 112
Joined: Sun Nov 23, 2008 4:21

layman -a sabayon issue is [SOLVED] thanks kodiakmax

Postby joe3 » Thu Jun 25, 2009 6:17

Thanks for the reply kodiakmax. And whatever the problem was, tonight it worked... The layman issue is solved...

To bad upgrading xine didn't solve the other problem. <sigh>

--
joe3
joe3
Advanced Hen
 
Posts: 200
Joined: Sun May 06, 2007 21:28


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests