Can't emerge Texlive [Solved]

Anything that pertains to Portage

Moderator: Moderators

Can't emerge Texlive [Solved]

Postby AlmaFuerte » Thu May 21, 2009 0:14

Hi people! When i trying to emerge app-text/texlive i get the following message:

Code: Select all
emerge: there are no ebuilds built with USE flags to satisfy "media-libs/freetype:1[kpathsea]".                                                               
!!! One of the following packages is required to complete your request:       
- media-libs/freetype-1.4_pre20080316-r1 (Change USE: +kpathsea)               
(dependency required by "app-text/texlive-2008" [ebuild])                     
(dependency required by "app-text/texlive" [argument])     

When i try,

Code: Select all
USE="kpathsea" emerge app-text/texlive

i get

Code: Select all
[blocks B     ] app-text/poppler ("app-text/poppler" is blocking dev-libs/poppler-0.10.7)
[blocks B     ] dev-libs/poppler ("dev-libs/poppler" is blocking app-text/poppler-0.10.5, app-text/poppler-bindings-0.10.5)
[blocks B     ] app-text/poppler-bindings ("app-text/poppler-bindings" is blocking dev-libs/poppler-0.10.7)


I don't know what to do....
Last edited by AlmaFuerte on Thu May 21, 2009 2:19, edited 1 time in total.
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35

Re: Can't emerge Texlive

Postby Fitzcarraldo » Thu May 21, 2009 0:56

Code: Select all
emerge -C dev-libs/poppler
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Can't emerge Texlive

Postby AlmaFuerte » Thu May 21, 2009 1:09

dev-libs/poppler is not installed! Also, is installed app-text/poppler but im not sure to unmerge it because is a pdf rendering library...
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35

Re: Can't emerge Texlive

Postby Fitzcarraldo » Thu May 21, 2009 1:14

In that case, I got it the wrong way round:

Code: Select all
emerge -C app-test/poppler app-text/poppler-bindings


Poppler has been split into various new packages, so it's going to be the old conflicting with the new I suppose. The new version dev-libs/poppler will be installed.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7981
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Can't emerge Texlive

Postby AlmaFuerte » Thu May 21, 2009 2:19

Thanks Fitzcarraldo! Now i can emerge it.
For anyone who has this problem the exact code is

Code: Select all
emerge -C app-text/poppler app-text/poppler-bindings


(the previous post has app-test/poppler wich is no correct)
Imagination is more important than knowledge. Albert Einstein.
AlmaFuerte
Simple Hen
 
Posts: 51
Joined: Fri Sep 28, 2007 2:35


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron