Updated new installation, now boot = runlevel 3 [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Post Reply
Baby Hen
Posts: 6
Joined: Sun May 17, 2009 3:36

Updated new installation, now boot = runlevel 3 [Solved]

Post by cookdav » Sun May 17, 2009 21:37

Hmm...I too am totally new to Gentoo/Sabayon, tho I've used lots of Debian
and openSUSE. So, clearly I too do not know Entropy from a hole in the ground. :mrgreen:

I did my first installation of Sabayon yesterday, from the 4.1 K (KDE-4) Live-DVD.
All that part went fine, got wifi-adapter working on the next reboot, installed 'ffmpeg'
and 'wine' and figured I'd try to read a little and try to get my head around 'Entropy',
'emerge', 'ebuild', and any other 'E' words.

So, after perusing the wiki, I concluded that where I once would say:
'apt-get update' followed by 'apt-get upgrade'
that I now should try to say:
'equo update' followed by 'equo world --ask'
to bring a just-installed system up-to-date.

I'll bet you know where my story goes from here. I just read a thread that
sounds VERY SIMILAR to my story: the result being that when I boot my
system now, I get no explicit errors, but it comes up just to run-level-3
and invites me to do a console login.

Based on my knowledge of other (non-Gentoo-based) distros, I suspected that
X-windows or my nvidia-graphics driver might have been involved in one of the
couple hundred of updates that got executed in that two-hour 'update' of the
installed software. But, xorg.conf hadn't been touched at all, based on my
browsing of the dates of the various xorg.conf variants lying around in '/etc/X11'.
[Just for grins, I tried switching back from 'nvidia' to 'vesa', but that didn't
change the symptom.]

And, near as I can tell, none of those couple-hundred updates involved updating
my kernel. It still says 2.6.29-Sabayon, and /boot/grub/menu.lst didn't get
touched by the updates either. Yet, this breakage symptom SEEMS to
resemble symptoms found in other distros after the kernel changes, but
some drivers didn't. [Yet, I didn't need to BUILD any drivers during/after
my installation, so I don't understand what got upgraded that borked things.]

So, why did it break, what do I need to learn about software updates
on Gentoo-based distros, and what run-level-3 incantations to I need to
invoke to fix it? [I'm reasonably comfortable at run-level-3 with 'vi' and
the command-line, etc.]


Advanced Hen
Posts: 278
Joined: Thu Oct 16, 2008 23:46

Re: Updated new installation, now boot = runlevel 3

Post by kodiakmax » Sun May 17, 2009 22:15

check your eselect

Code: Select all

eselect opengl list
then set the correct one for your video card

Code: Select all

eselect opengl set 1/2/3
if that doesn't work try re-installing your video drivers

Code: Select all

equo install nvidia-drivers
equo install ati-drivers
then check your eselect again after you re-install your drivers.
If you check the wiki, use the search function and google you can find the answer to most of your questions.

Remember to mark your thread [Solved] if your issue is fixed.

Baby Hen
Posts: 6
Joined: Sun May 17, 2009 3:36

SOLVED: Updated new installation, now boot = runlevel 3

Post by cookdav » Sun May 17, 2009 22:31

Hmm...before I saw the answer to my base post, I did some more
reading in the wiki about Entropy, and found some first-time/one-time
cmd suggestions about '...emerge --synch && layman -S'
so I did that stuff at run-level-3 and a fresh 'equo world --ask'
and it coughed up one more update to some piece of x-server
and after it applied that and rebooted, it came back up, and
my login to the new KDE-4.2.3 was working.

[Not sure what that was all about...but if it's just some one-time
thing that must be done following installations, maybe it could
get incorporated into the tail of installer, as a post-install step!?!]

Anyway, no biggie. I'm back in working order. Thanks for the reponse! :D

Post Reply