Touchpad annoying in Sabayon 4.1 KDE [Solved]

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

Touchpad annoying in Sabayon 4.1 KDE [Solved]

Postby marshalleq » Sun May 03, 2009 0:44

Anyone else find this annoying? If I go anywhere near the edge of the touchpad the virtual desktop (non 3d) changes and the mouse won't move. Have to constanly remember to put my finger right in the middle of the touchpad. Don't see any option to disable it (maybe I'm blind) :) A config file change then?
marshalleq
Baby Hen
 
Posts: 7
Joined: Mon Jan 12, 2009 23:09

Re: Touchpad annoying in Sabayon 4.1 KDE

Postby micia » Sun May 03, 2009 10:07

Actually there are option to disable and enable many Touchpad behaviours, but
they are not so easy to find out at first.

Default touchpad configurations are located in:
/etc/hal/fdi/policy/11-x11-synaptics.fdi
(if it is not there probably default configuration is used)

There is an example of this file in:
/usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi

you could do this as root:
Code: Select all
cp /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi /etc/hal/fdi/policy/11-x11-synaptics.fdi


and edit the /etc/hal... file as root with your favourite editor,
for example the touchpad scrolling at edges was very annoying for me, so I disabled it
since my touchpad supports the double finger scrolling.
So my /etc/hal/fdi/policy/11-x11-synaptics.fdi looks like this:
Code: Select all
<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.touchpad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <!-- Arbitrary options can be passed to the driver using
             the input.x11_options property since xorg-server-1.5. -->

   <merge key="input.x11_options.SHMConfig" type="string">true</merge>
   <merge key="input.x11_options.MaxTapMove" type="string">2000</merge>
   <merge key="input.x11_options.VertEdgeScroll" type="string">false</merge>
   <merge key="input.x11_options.VertTwoFingerScroll" type="string">true</merge>
   <merge key="input.x11_options.HorizTwoFingerScroll" type="string">false</merge>
   <merge key="input.x11_options.CircularScrolling" type="string">false</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.TapButton2" type="string">2</merge>
        <merge key="input.x11_options.TapButton3" type="string">3</merge>

    </match>
  </device>
</deviceinfo>


see the man page for synaptics:
Code: Select all
man synaptics

for many informations.
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Touchpad annoying in Sabayon 4.1 KDE

Postby marshalleq » Sun May 03, 2009 12:53

Thanks! Again impressed with the speed and attitude to helping around here :) Sabayon really does have a helpful community which I think shines though as much as the distro does.
marshalleq
Baby Hen
 
Posts: 7
Joined: Mon Jan 12, 2009 23:09

Re: Touchpad annoying in Sabayon 4.1 KDE

Postby micia » Sun May 03, 2009 13:00

Thank you, users like you make this rewarding :wink:

I forgot to mention that a reboot should be needed in order to let the changes take effect and to be careful editing
that file.

If this helped remember to mark this thread as [Solved] editing your first post, so many ones with this problem
will have their answer already there :D
micia
Sagely Hen
 
Posts: 2718
Joined: Wed Nov 26, 2008 16:41

Re: Touchpad annoying in Sabayon 4.1 KDE

Postby wolfden » Tue May 05, 2009 3:03

moved to correct forum, not an installation issue

please post in correct forum
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest