world update frustrations

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

world update frustrations

Postby IsaLandr » Wed Apr 15, 2009 18:57

okay, i'm new to Sabayon and the whole gentoo attitude. i don't understand a lot of how this particular system works. i'm having some troubles with world updates and i'm getting very frustrated, i could use some advice and/or help.

the system is a Dell Inspiron 8200 laptop. 30gb hard drive, 1.7GHz P4-M, 512mb ram, nVidia NV11 GeForce2 32mb display adaptor, 15" 1600x1200 UXGA screen.

when i install Sabayon 4r1, everything goes smoothly. it installs KDE, detects and sets up networking including the onboard wireless, sets the display at 1600x1200 by default, and everything just plaiin works. this is why i chose Sabayon in the first place. of all the distributions i tried, this is the only one that just plain worked, straight out of the box. i tried doing a cold gentoo install, and never did get X working, much less the nVidia drivers. other distributions, i could get X, but couldn't get the nVidia stuff to work.

anyway, i keep trying to do a world update on this system, and i'm getting very frustrated. i need that laptop to just work, i don't have the time or the patience to muck about trying to fiddle with this and tamper with that, just getting X to work. i have done "equo update && equo world" a number of times now, each time after a cold fresh install. every single time, as soon as i reboot, i lose X. and nothing i do revives it. to get X back, i have to go back to the install DVD and do another cold install. i tried doing a recovery and that didn't work, it generated errors and halted the installer.

what am i doing wrong? i am no on the ninth or tenth world update after a fresh install. and once again, X stopped working on reboot. this most recent time, i put ">=xorg-drivers/nvidia-drivers-97.0.0" in /etc/portage/package.mask because i read on one of the forums that any nVidia drivers later than 96.x are incompatible with my display. well, that didn't help either. after equo update && equo world, once again X is screwed up.

this time, once it's booted up and i'm logged in as root, i did "equo install nvidia-drivers-96*" and let it go. when that was done, i ran startx, and it loaded XFCE4, which at least indicates that X now works. reboot, and sure enough, it loads the X login. however, it still isn't right. it doesn't pop straight to the X screen. it shows the nvidia loading screen, then pops back to the first virtual terminal and stays there to finish the loading sequence, but never goes back to the graphical login screen. i have to manually switch to it in order to use it.

why is it behaving this way, and how do i fix it? i'm not sure what the problem is, or how to address it, but is there a way to convince the updater not to install a newer driver which is known not to work with the existing hardware? and, can someone please tell me how to get it to switch to the GUI screen automatically at bootup?

thank you for taking the time to read through this whole thing.
Baby Hen
Posts: 3
Joined: Wed Apr 15, 2009 18:12

Re: world update frustrations

Postby thenthenio » Wed Apr 15, 2009 23:13

Hello IsaLandr.
You are right very often world updates are so frustrating...
What is happening to you is common with Sabayon, mainly I think because it is a bleeding edge distro.
I have been on Sabayon for about 3 years now and this is exactly what happened to me right today, but now I learned how to come out...
Ok, open a konsole and become root user:
Code: Select all
$ su
Password: <Type your root password here>

First of all check that the booted kernel version and the selected kernel version match:
Code: Select all
# uname -r
# eselect kernel list

You should get the * on the line where your boot kernel is listed, if this is not the case:
Code: Select all
# eselect kernel set <The number of the line where your boot kernel is listed>

Now check the installed nvidia-drivers version: the installed version of nvidia-drivers should have been "tagged" for your boot kernel, if this is not the case search for nvidia-drivers and then install the latest one witch is tagged for your boot kernel:
Code: Select all
# equo search nvidia-drivers
# equo install x11-drivers/nvidia-drivers-<Latest driver version>#<Boot kernel version>-sabayon

Please note that often recent drivers do not work any more on old hardware, do some googling to check what is the most recent driver that is working on your specific graphic card.
Then chack and if necessary (if * is not on the same line as nvidia) select the nvidia drivers:
Code: Select all
# eselect opengl list
# eselect opengl set nvidia

Now you should be done!
You can try to restart X (not with startx but with):
Code: Select all
# /etc/init.d/xdm restart

If it does not work try rebooting and cross your fingers!
If it does not work check what you did, or try another version of nvidia-drivers and maybe post your /var/log/Xorg.0.log here.
You can also try asking help using the IRC channel #sabayon on (by using an IRC client or directly bya using the browser here:, usually people there are very helpful an you can do your job step by step interactively with their help.

Old Dear Hen
Posts: 522
Joined: Thu Mar 01, 2007 23:11
Location: Melegnano (MI) Italy

Re: world update frustrations

Postby WarraWarra » Thu Apr 16, 2009 0:53

Keep in mind that the 96 driver = legacy drivers and all video cards before the nvidia 6800 models defaults or works with teh legacy driver in all Linux.

The latest drivers is only for nvidia products after 6800 versions.

Alternatively you can use the nv driver xdriver=nv instead of xdriver=nvidia.
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: world update frustrations

Postby wolfden » Thu Apr 16, 2009 1:35

i put ">=xorg-drivers/nvidia-drivers-97.0.0" in /etc/portage/package.mask

entropy doesn't pay attention to /etc/portage/package.mask << that is portage

you need to mask it in entropy
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: world update frustrations

Postby IsaLandr » Thu Apr 16, 2009 4:59

ahhh, see, now i wish i had known that from the beginning. it's now in the entropy package.mask, and the newer drivers have disappeared from the list of available updates in spritz. i guess i didn't have a good enough grasp of entropy versus portage. i'll keep this in mind for the future.

with the re-installation of the nvidia 96.x drivers, and a couple of reboots, equo conf update, etc etc etc, things have pretty well settled down again and the system appears to be in good shape, running Sabayon 4.1, all seems well. do i still need to do things like sync or related functions, or is "equo update" and "equo world" and "equo conf update" sufficient for my needs?

i'd still like to know why the updater can't figure out that the newer drivers don't work with the installed hardware. the initial installer on the 4r1 DVD was able to figure that out. it has several nVidia drivers included, and chooses the correct one without any problems. why does the updater appear incapable of the same thing?
Baby Hen
Posts: 3
Joined: Wed Apr 15, 2009 18:12

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests