world update nvidia problem

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

world update nvidia problem

Postby MerryMurray » Mon Mar 30, 2009 23:37

Hi
Just did a world update in Sabayon Four to kernel 2.26.29. Installed the Nvidia 2.26.29 driver before rebooting and eseleted it. On reboot got the following error:
"Api mismatch: The Nvidia kernel module has version 180.11 but the Nvidia driver component has version 180.41. Please make sure the that the kernel
module and all Nvidia drivers components have the same version."

How do I do this? Modprobe , I think, but how?

Thanks in advance, Murray.
MerryMurray
Baby Hen
 
Posts: 3
Joined: Tue Jul 29, 2008 7:13

Re: world update nvidia problem

Postby wolfden » Tue Mar 31, 2009 6:00

moved to correct forum

try:
Code: Select all
equo remove nvidia-drivers && rmmod nvidia && rm /lib/modules/$(uname -r)/video/nvidia.ko && rm /usr/lib/opengl/nvidia -rf && equo install nvidia-drivers && eselect opengl set nvidia && reboot
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: world update nvidia problem

Postby dottzaius » Sun Apr 12, 2009 19:58

I have the same problem....as wolfden know (in chat 2 days ago, remember?)... i used that command and now my error is: FATAL: Module nvidia not found.
(EE) NVIDIA(0): failed to loadthe nvidia kernel module!
aborting
(EE) screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
dottzaius
Baby Hen
 
Posts: 6
Joined: Tue Feb 03, 2009 17:45

Re: world update nvidia problem

Postby wolfden » Mon Apr 13, 2009 2:31

does modprobe nvidia work?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: world update nvidia problem

Postby dottzaius » Mon Apr 13, 2009 17:58

no, wolfden...it seems that the module doesn't exist...i tried to reinstall the drivers but it's the same error
dottzaius
Baby Hen
 
Posts: 6
Joined: Tue Feb 03, 2009 17:45

Re: world update nvidia problem

Postby wolfden » Mon Apr 13, 2009 18:39

weird

what about

Code: Select all
emerge --sync && emerge nvidia-drivers
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: world update nvidia problem

Postby ehcstapp » Thu Apr 16, 2009 2:05

MerryMurray wrote:The Nvidia kernel module has version 180.11 but the Nvidia driver component has version 180.41. Please make sure the that the kernel
module and all Nvidia drivers components have the same version."


I had the same problem, what solves it is downgrading your driver to the same version that your settings have.

I mean if you have nvidia-settings-180.11, you should also have nvidia-driver-180.11, as your comment mentions you have a newer driver so settings have problems :s

on terminal run emerge -s nvidia, that'll tell you what's the newer version available, just make sure you install the same on both.

let me know if this works for you

regards
ehcstapp
Baby Hen
 
Posts: 1
Joined: Fri Jan 02, 2009 18:53
Location: Chihuahua, Mexico


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 0 guests

cron