Entropy, Branch4, errors inpackages. Info for Dev [Solved]

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Entropy, Branch4, errors inpackages. Info for Dev [Solved]

Postby albfneto » Fri Nov 28, 2008 2:33

I'm still testing a new installation of Sabayon in witch, Portage was never used. I installed today, is a new 3.5.1 installation.
many packages install and works, but, for example, Emesene,epiphany, not!
equo install emesene, installed emesene
equo install epiphany installed epiphany, but they not open.
amarok installed by defautbut not run.

see thh code, output after installed and try to run the package...
Code: Select all
equo install epiphany
>>  @@ Calculating dependencies ...
>>  @@ Packages needing to be installed/updated/downgraded: 1
>>  @@ Packages needing to be removed: 0
>>  @@ Download size: 0b
>>  @@ Freed disk space: 0.0b
>>  @@ You need at least: 9.9MB of free space
>>  :: (1/1) >>> www-client/epiphany-2.24.1-r10
>>    ## Package checksum matches.
>>  ++ (1/1) >>> www-client/epiphany-2.24.1-r10
>>    ## Unpacking package: www-client:epiphany-2.24.1-r10~2.tbz2
>>    ## Ebuild: pkg_preinst()
>>    ## Installing package: www-client/epiphany-2.24.1-r10
>>    ## Updating database: www-client/epiphany-2.24.1-r10
>>    ## Ebuild: pkg_postinst()
 * Installing GNOME 2 GConf schemas
 * Updating desktop mime database ...
 * Updating shared mime info database ...
 * Updating icons cache ...                                               [ ok ]
 * Updating scrollkeeper database ...
>>    ## Cleaning: www-client/epiphany-2.24.1-r10
>>  @@ Installation completed.
>>  @@ Caching complete.
localhost albfneto # epiphany
epiphany: error while loading shared libraries: libltdl.so.7: cannot open shared object file: No such file or directory
localhost albfneto #   

calhost albfneto # equo install emesene
>>  @@ Calculating dependencies ...
>>  @@ Packages needing to be installed/updated/downgraded: 1
>>  @@ Packages needing to be removed: 0
>>  @@ Download size: 0b
>>  @@ Freed disk space: 0.0b
>>  @@ You need at least: 2.2MB of free space
>>  :: (1/1) >>> net-im/emesene-9999
>>    ## Package checksum matches.
>>  ++ (1/1) >>> net-im/emesene-9999
>>    ## Unpacking package: net-im:emesene-9999~0.tbz2
>>    ## Ebuild: pkg_preinst()
>>    ## Installing package: net-im/emesene-9999
>>    ## Updating database: net-im/emesene-9999
>>    ## Ebuild: pkg_postinst()
 * Remember, this stuff is SVN only code so dont cry when
 * I break you :).
 * If you want to report bugs, go to our forum at http://emesene.org/forums
>>    ## Cleaning: net-im/emesene-9999
>>  @@ Installation completed.
>>  @@ Caching complete.
localhost albfneto # emesene
  File "/usr/bin/emesene", line 27
    python /usr/share/emesene/Controller.py
    ^
IndentationError: unexpected indent
localhost albfneto #       

amarok was installed by defualt, but:

[email protected] ~ $ amarok
Amarok: [Loader] Starting amarokapp..
Amarok: [Loader] Don't run gdb, valgrind, etc. against this binary! Use amarokap                    p.
amarokapp: error while loading shared libraries: libltdl.so.7: cannot open share                    d object file: No such file or directory
[email protected] ~ $

Now see Dolphin,installed but notfound:

localhost albfneto # equo install dolphin
>>  @@ Calculating dependencies ...
>>  @@ Packages needing to be installed/updated/downgraded: 1
>>  @@ Packages needing to be removed: 0
>>  @@ Download size: 0b
>>  @@ Freed disk space: 0.0b
>>  @@ You need at least: 2.3MB of free space
>>  :: (1/1) >>> kde-base/dolphin-4.1.3
>>    ## Package checksum matches.
>>  ++ (1/1) >>> kde-base/dolphin-4.1.3
>>    ## Unpacking package: kde-base:dolphin-4.1.3~1.tbz2
>>    ## Ebuild: pkg_preinst()
>>    ## Installing package: kde-base/dolphin-4.1.3
>>    ## Updating database: kde-base/dolphin-4.1.3
>>    ## Ebuild: pkg_postinst()
>>    ## Regenerating /etc/ld.so.cache
>>    ## Cleaning: kde-base/dolphin-4.1.3
>>  @@ Installation completed.
>>  @@ Caching complete.
localhost albfneto # dolphin
bash: dolphin: command not found
localhost albfneto #                 

                                   
Last edited by albfneto on Tue Dec 02, 2008 5:09, edited 2 times in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy not install completely some packages

Postby albfneto » Fri Nov 28, 2008 10:42

In the same system,alsosound server not run. Crash sound.
error:
Code: Select all
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f465b903700 (LWP 11849)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0x00007f465b272b12 in Arts::PlayObject_base::_create ()
   from /usr/kde/3.5/lib64/libkmedia2_idl.so.1
#4  0x0000000000410e6f in ?? ()
#5  0x00007f465b26fedb in ?? () from /usr/kde/3.5/lib64/libkmedia2_idl.so.1
#6  0x00007f465a0540c6 in Arts::Dispatcher::handle ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#7  0x00007f465a0400e0 in Arts::Connection::receive ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#8  0x00007f465a05c542 in Arts::SocketConnection::notifyIO ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#9  0x00007f465a057b1f in Arts::StdIOManager::processOneEvent ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#10 0x00007f465a057138 in Arts::StdIOManager::run ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#11 0x0000000000417ba3 in ?? ()
#12 0x00007f4657c064a4 in __libc_start_main () from /lib/libc.so.6
#13 0x000000000040fb29 in ?? ()
#14 0x00007fff639556d8 in ?? ()
#15 0x0000000000000000 in ?? ()



I tried the rescue system of the live dvd, and this also giveerrors. Anaconda installer not able to correct.
Last edited by albfneto on Mon Dec 01, 2008 15:59, edited 1 time in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy not install completely some packages

Postby Thev00d00 » Fri Nov 28, 2008 15:19

the current entropy emesene is broke, try the version in Zenana, it works, and is newer
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: Entropy not install completely some packages

Postby albfneto » Fri Nov 28, 2008 17:53

thanks.
epiphany also?
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy not install completely some packages

Postby albfneto » Mon Dec 01, 2008 16:10

in this system... Portage not used,only entropy.
In my tests, i used the trunk Branch 4..
After installation, some packages have errors..
for example, sound server, emesene, epiphany gives errors:

Code: Select all
(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f628cebd700 (LWP 12359)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#3  0x00007f628c828b12 in Arts::PlayObject_base::_create ()
   from /usr/kde/3.5/lib64/libkmedia2_idl.so.1
#4  0x0000000000410e6f in ?? ()
#5  0x00007f628c825edb in ?? () from /usr/kde/3.5/lib64/libkmedia2_idl.so.1
#6  0x00007f628b60a0c6 in Arts::Dispatcher::handle ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#7  0x00007f628b5f60e0 in Arts::Connection::receive ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#8  0x00007f628b612542 in Arts::SocketConnection::notifyIO ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#9  0x00007f628b60db1f in Arts::StdIOManager::processOneEvent ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#10 0x00007f628b60d138 in Arts::StdIOManager::run ()
   from /usr/kde/3.5/lib64/libmcop.so.1
#11 0x0000000000417ba3 in ?? ()
#12 0x00007f62891bc4a4 in __libc_start_main () from /lib/libc.so.6
#13 0x000000000040fb29 in ?? ()
#14 0x00007fff94f09eb8 in ?? ()
#15 0x0000000000000000 in ?? ()
 
epiphany errors, not opened

[email protected] ~ $ epiphany
epiphany: error while loading shared libraries: libltdl.so.7: cannot open shared object file: No such file or directory
[email protected] ~ $
[email protected] ~ $



emesene also, etc...

More errors: when the command equo world --update 4 is used, to switch to Branch 4, If the Zenana repo was added,the repositories.conf file is automatically changed,and Zenana Repo removed....
I have in Mind that Branch 4 is unstable and Experimental.
Bui i send this only to inform the developers. This info may be useful.
Resuming, some packages had errors or may be installed no completelly, using Entropy
In other Sabayon installations, Branch 3.5 works well as the same packages, when installed with Portage, also works.
The problems seems to be only in Entropy, Branch 4.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy, Branch4, errors in installed packages. Info to Dev

Postby DHalens » Mon Dec 01, 2008 19:14

Check if you have sys-devel/libtool installed.
I had a similar issue with sys-libs/db and i was told it is already solved and shouldn't happen anymore.
Former Sabayon staff (retired).
For any personal questions or whatever, contact me trough my G+ profile
DHalens
Old Dear Hen
 
Posts: 933
Joined: Thu Apr 10, 2008 23:08
Location: Canary Islands, Spain

Re: Entropy, Branch4, errors in installed packages. Info to Dev

Postby albfneto » Mon Dec 01, 2008 19:52

i will tru this, Dhallens. It is installed bul an old version.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy, Branch4, errors in installed packages. Info to Dev

Postby wolfden » Tue Dec 02, 2008 2:46

remember branch4 is gonna have breakage
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Entropy, Branch4, errors in installed packages. Info to Dev

Postby albfneto » Tue Dec 02, 2008 4:21

Yes i know.
i installed compiz from branch 4, and in this comp, i'm testing branch four
for this i posted the errors.
Partially solved, except for Zenana repo problem, that when "re-added", is no found by the system

# equo update
# equo world
# equo update

Yesterday, normally i was made equo world --update 4, to use the 4 branch.


Epiphany, Emesene, sound etc... all works, even using Branch four
May be certain some outdated libraries or packages....
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Entropy, Branch4, errors inpackages. Info for Dev [Solved]

Postby chad1 » Mon Apr 06, 2009 17:30

I, too, am trying to install emesene. Just regular equo install emesene doesn't work.

How do I get emesene to work?
chad1
Young Hen
 
Posts: 30
Joined: Wed Feb 25, 2009 19:24

Next

Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests