emerge -u world

Anything that pertains to Portage

Moderator: Moderators

emerge -u world

Postby Nuts » Wed Apr 01, 2009 19:50

i'm getting error when updating world

Code: Select all
nuts ~ # emerge -u world
Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/wxGTK:2.8

  ('ebuild', '/', 'x11-libs/wxGTK-2.8.9.2', 'merge') pulled in by
    >=x11-libs/wxGTK-2.8.9 required by ('ebuild', '/', 'net-ftp/filezilla-3.2.3.1', 'merge')
    x11-libs/wxGTK:2.8 required by ('ebuild', '/', 'media-gfx/hugin-0.7.0-r1', 'merge')
    x11-libs/wxGTK:2.8 required by world

  ('installed', '/', 'x11-libs/wxGTK-2.8.9.1-r3', 'nomerge') pulled in by
    x11-libs/wxGTK:2.8 required by world
    x11-libs/wxGTK:2.8[X,opengl] required by ('ebuild', '/', 'sci-misc/boinc-6.4.5-r1', 'merge')

net-libs/ortp:0

  ('ebuild', '/', 'net-libs/ortp-0.7.1-r1', 'merge') pulled in by
    ~net-libs/ortp-0.7.1 required by ('ebuild', '/', 'kde-base/kopete-3.5.10-r1', 'merge')
    net-libs/ortp:0 required by world

  ('ebuild', '/', 'net-libs/ortp-0.13.1-r1', 'merge') pulled in by
    net-libs/ortp:0 required by world


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
app-emulation/virtualbox-modules:2.6.25-sabayon-r1 sys-apps/suspend2-userui net-misc/logjam:0 dev-dotnet/glade-sharp:1 dev-libs/libol dev-java/gcj-jdk:0 x11-drivers/ati-drivers:2.6.25-sabayon-r1 net-wireless/ndiswrapper:2.6.26-sabayon dev-dotnet/gnome-sharp:1 net-misc/et131x:2.6.26-sabayon net-wireless/madwifi-ng:2.6.26-sabayon sys-auth/pam_keyring app-portage/etcproposals net-wireless/acx:2.6.26-sabayon app-crypt/cryptplug dev-perl/FileHandle-Rollback dev-util/cogito gnome-extra/gal:2.2 gnome-extra/gal:2.4 app-emulation/virtualbox-modules:2.6.26-sabayon app-crypt/truecrypt:0 x11-drivers/nvidia-drivers:2.6.26-sabayon net-dialup/slmodem:2.6.26-sabayon media-video/realplayer:0 gnome-extra/gal dev-dotnet/gtksourceview-sharp:0 x11-drivers/ati-drivers:2.6.26-sabayon net-dns/resolvconf-gentoo media-video/gspcav1:2.6.26-sabayon

emerge: there are no ebuilds built with USE flags to satisfy "~app-text/poppler-bindings-0.10.5[qt3]".
!!! One of the following packages is required to complete your request:
- app-text/poppler-bindings-0.10.5 (Change USE: +qt3)
(dependency required by "kde-base/kpdf-3.5.10" [ebuild])
(dependency required by "world" [argument])


how can i resolve it, i tryed to use google, but nothing..
Nuts
Baby Hen
 
Posts: 6
Joined: Wed Apr 01, 2009 15:26

Re: emerge -u world

Postby DontPanic » Thu Apr 02, 2009 1:27

You look like you are using a relatively old version of Sabayon Linux (I could be wrong, but I'm guessing by the errors with a 2.6.26 kernel). Older versions often are more difficult to upgrade, but not impossible.

At any rate, these are all common portage problems. There are many threads dealing with these kind of problems.

If you look around this forum or Gentoo's portage forum, you can find many examples of these problems and how to solve them.

You may want to start with just updating individual packages to get the hang of how to use portage.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: emerge -u world

Postby Nuts » Sun Apr 05, 2009 12:55

ermm...its the new sabayon with .27 kernel and new portage, i'm with gentoo over 1 year, and i cant solve this prob
Nuts
Baby Hen
 
Posts: 6
Joined: Wed Apr 01, 2009 15:26

Re: emerge -u world

Postby DontPanic » Sun Apr 05, 2009 14:45

I'd recommend the following:

First, run 'emaint --fix world'. That may shorten your list of issues.

The last error is pretty easy to fix. Check your /etc/portage/package.use file, and add an entry for:
Code: Select all
app-text/poppler-bindings qt3


As for the blocked packages, Sabayon is a fairly comprehensive installation with a lot of packages, and this increases the likelihood that you'll run into issues with blockages as changes are made to the portage tree. But portage blocked packages crop up on just about any Gentoo/portage-based installation.

Sometimes, the issues with blocked packages can be addressed by removing the blocked package, and letting emerge resolve the dependencies without the package installed.

Other times, it might just be easier to remove the package that is introducing the blockage. For example. The package sci-misc/boinc is cited as one of your blockage issues. You may decide you don't need sci-misc/boinc, and just decide to remove it. Or you may decide to upgrade sci-misc/boinc to see if that resolves the issue.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA

Re: emerge -u world

Postby wolfden » Mon Apr 06, 2009 9:05

if u want to use portage

core install, edit configs, rebuild, build on top of that

using portage with current configs is pointless
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: emerge -u world

Postby Nuts » Sat Apr 11, 2009 9:32

emaint --fix world partitially solved my prb.
but there's another one,i'll create new topic
Nuts
Baby Hen
 
Posts: 6
Joined: Wed Apr 01, 2009 15:26


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests