First update with Sabayon 4 problem

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

First update with Sabayon 4 problem

Postby deonild » Tue Mar 31, 2009 3:31

Hey all. I'm new to Sabayon. Got into Linux a few months ago. Tried out a ton of distros, messed up alot of installs screwin around/learning. Have tried to install Gentoo a few times never got it 100% working. Just found this and I can't be happier :D suits my taste and it works great! I want to treat this install nice, keep it working, so I plan to just use spritz, no downloading .tar's or even emerge for now.

I installed a few hours ago, used spritz to install a few things, both times I had the problem where it hangs at the end cleaning up saying something like can't load blocked?/closed? database, i forget, but quit and restart spritz showed everything in working order. I just got a popup about updates, it downloaded some things, 30-70ish I don't remember for sure. It seemed to be hanging checking for updates for quite some time(I believe the hanging stuff is a seperate issue from this post) after that, so I right-click > check for updates. It found 318 security updates.

Clicking Add All gives me this error:

Attention
Some dependencies couldn't be found. It can either be because they are masked or because they aren't in any active repository.

=sys-kernel/linux-sabayon-2.6.29~-1
=sys-kernel/linux-sabayon-2.6.27~-1

They arn't masked. I don't think they are installed. I have kernel-genkernel-x86-2.6.27-sabayon in /boot.
From my failed attempts with Gentoo I know genkernel is different from non-genkernels... right?

What should I do, I don't know which of the 318 packages need the dependency, or how to search for that without going through each at a time, which takes at least few seconds each.

Also, it wants to install all Xorg video drivers, I assume this is normal?

What other info could be useful? Thx for any info,
Deo

EDIT: If this helps at all, from full install CD, I'm using XFCE Desktop environment with no GNOME/KDE environments. Only things I installed were XFCE extras, bout 95% of them.

EDIT 2: equo --info is at sabayonlinux.org/pastie/830. Equo: v0.24.6
deonild
Baby Hen
 
Posts: 1
Joined: Mon Mar 30, 2009 23:32

Re: First update with Sabayon 4 problem

Postby wolfden » Tue Mar 31, 2009 5:52

wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest