slot conflicts

Anything that pertains to Portage

Moderator: Moderators

slot conflicts

Postby xipi » Sun Mar 01, 2009 12:11

I find that doing "emerge -DupvtN world" complains about slot conflicts, and suggests me to mask some packages in my system.

But I don't know exactly what is a slot conflict, and how should I proceed.

More accurately, emerge says following:

Code: Select all
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-python/twisted:0

  ('installed', '/', 'dev-python/twisted-8.1.0', 'nomerge') pulled in by
    =dev-python/twisted-8.1* required by ('installed', '/', 'dev-python/twisted-web2-8.1.0', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'dev-python/twisted-8.2.0', 'merge') pulled in by
    =dev-python/twisted-8.2* required by ('ebuild', '/', 'dev-python/twisted-web-8.2.0', 'merge')
    (and 4 more)

x11-libs/qt-script:4

  ('ebuild', '/', 'x11-libs/qt-script-4.5.0_rc1', 'merge') pulled in by
    ~x11-libs/qt-script-4.5.0_rc1[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0_rc1-r1', 'merge')
    ~x11-libs/qt-script-4.5.0_rc1 required by ('ebuild', '/', 'x11-libs/qt-4.5.0_rc1', 'merge')
    (and 7 more)

  ('ebuild', '/', 'x11-libs/qt-script-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-script-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
    (and 7 more)

net-libs/libgadu:0

  ('ebuild', '/', 'net-libs/libgadu-1.8.2', 'merge') pulled in by
    net-libs/libgadu:0 required by world

  ('installed', '/', 'net-libs/libgadu-1.8.0', 'nomerge') pulled in by
    net-libs/libgadu[ssl] required by ('ebuild', '/', 'net-im/pidgin-2.5.4-r1', 'merge')
    (and 1 more)

  Explanation:

    New USE for 'net-libs/libgadu:0' are incorrectly set. In order to
    solve this, adjust USE to satisfy 'net-libs/libgadu[ssl]'.

x11-libs/qt-core:4

  ('ebuild', '/', 'x11-libs/qt-core-4.5.0_rc1', 'merge') pulled in by
    ~x11-libs/qt-core-4.5.0_rc1[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-opengl-4.5.0_rc1', 'merge')
    ~x11-libs/qt-core-4.5.0_rc1[-debug] required by ('ebuild', '/', 'x11-libs/qt-dbus-4.5.0_rc1', 'merge')
    ~x11-libs/qt-core-4.5.0_rc1[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-sql-4.5.0_rc1', 'merge')
    (and 25 more)

  ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge') pulled in by
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge')
    ~x11-libs/qt-core-4.4.2 required by ('installed', '/', 'x11-libs/qt-sql-4.4.2', 'nomerge')
    ~x11-libs/qt-core-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge')
    (and 21 more)

x11-libs/qt-sql:4

  ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge') pulled in by
    ~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
    (and 7 more)

  ('ebuild', '/', 'x11-libs/qt-sql-4.5.0_rc1', 'merge') pulled in by
    ~x11-libs/qt-sql-4.5.0_rc1[qt3support,-debug] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.0_rc1', 'merge')
    ~x11-libs/qt-sql-4.5.0_rc1 required by ('ebuild', '/', 'x11-libs/qt-4.5.0_rc1', 'merge')
    ~x11-libs/qt-sql-4.5.0_rc1[sqlite,-debug] required by ('ebuild', '/', 'x11-libs/qt-assistant-4.5.0_rc1', 'merge')
    (and 7 more)

  ('installed', '/', 'x11-libs/qt-sql-4.4.2', 'nomerge') pulled in by
    ~x11-libs/qt-sql-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
    x11-libs/qt-sql:4[mysql] required by ('ebuild', '/', 'app-office/akonadi-server-1.1.1', 'merge')
    (and 7 more)

x11-libs/qt-dbus:4

  ('ebuild', '/', 'x11-libs/qt-dbus-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-dbus-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
    (and 7 more)

  ('ebuild', '/', 'x11-libs/qt-dbus-4.5.0_rc1', 'merge') pulled in by
    ~x11-libs/qt-dbus-4.5.0_rc1[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0_rc1-r1', 'merge')
    ~x11-libs/qt-dbus-4.5.0_rc1 required by ('ebuild', '/', 'x11-libs/qt-4.5.0_rc1', 'merge')
    (and 7 more)

dev-db/sqlite:3

  ('installed', '/', 'dev-db/sqlite-3.6.2', 'nomerge') pulled in by
    dev-db/sqlite[soundex] required by ('installed', '/', 'sys-apps/entropy-0.51.0', 'nomerge')
    (and 16 more)

  ('ebuild', '/', 'dev-db/sqlite-3.6.10', 'merge') pulled in by
    dev-db/sqlite:3 required by world
    dev-db/sqlite:3 required by ('ebuild', '/', 'x11-libs/qt-sql-4.4.2-r1', 'merge')
    dev-db/sqlite:3 required by ('installed', '/', 'x11-libs/qt-sql-4.4.2', 'nomerge')
    (and 13 more)

  Explanation:

    New USE for 'dev-db/sqlite:3' are incorrectly set. In order to solve
    this, adjust USE to satisfy 'dev-db/sqlite[soundex]'.

x11-libs/qt-gui:4

  ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge') pulled in by
    ~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge')
    ~x11-libs/qt-gui-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-core-4.4.2-r2', 'merge')
    (and 20 more)

  ('ebuild', '/', 'x11-libs/qt-gui-4.5.0_rc1-r1', 'merge') pulled in by
    ~x11-libs/qt-gui-4.5.0_rc1[-debug] required by ('ebuild', '/', 'x11-libs/qt-assistant-4.5.0_rc1', 'merge')
    ~x11-libs/qt-gui-4.5.0_rc1[qt3support,accessibility,-debug] required by ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.0_rc1', 'merge')
    ~x11-libs/qt-gui-4.5.0_rc1[qt3support] required by ('ebuild', '/', 'x11-libs/qt-core-4.5.0_rc1', 'merge')
    (and 24 more)

x11-libs/qt-qt3support:4

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.5.0_rc1', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.5.0_rc1 required by ('ebuild', '/', 'x11-libs/qt-4.5.0_rc1', 'merge')
    ~x11-libs/qt-qt3support-4.5.0_rc1[-debug] required by ('ebuild', '/', 'x11-libs/qt-gui-4.5.0_rc1-r1', 'merge')
    (and 8 more)

  ('ebuild', '/', 'x11-libs/qt-qt3support-4.4.2', 'merge') pulled in by
    ~x11-libs/qt-qt3support-4.4.2 required by ('ebuild', '/', 'x11-libs/qt-gui-4.4.2-r3', 'merge')
    (and 8 more)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.


So lets focus in the first case. In front of:

Code: Select all
dev-python/twisted:0

  ('installed', '/', 'dev-python/twisted-8.1.0', 'nomerge') pulled in by
    =dev-python/twisted-8.1* required by ('installed', '/', 'dev-python/twisted-web2-8.1.0', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'dev-python/twisted-8.2.0', 'merge') pulled in by
    =dev-python/twisted-8.2* required by ('ebuild', '/', 'dev-python/twisted-web-8.2.0', 'merge')
    (and 4 more)


How should I exactly proceed? What could be the cause of this slot conflict?

On the other hand, I see that "emerge -DuptvN world" suggests to download about 400+ packages. Wouldn't it leave my computer compiling over the next two weeks? I wonder also how safe is it to do that after having done an update of 300+ packages with Spritz.
xipi
Young Hen
 
Posts: 23
Joined: Sun Feb 15, 2009 13:34

Re: slot conflicts

Postby wolfden » Sun Mar 01, 2009 18:14

on stuff like that you have to work it out individually before a world update - read what it is telling you, it's pretty clear

400 packages a week? I hope not, unless you are on a really old computer, as I can emerge -e system in a couple hours

I always recommend if you are going to go portage to do a core install, edit configs, rebuild, than build on top of that. It will be a lot better since SL is entropy orientated
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: slot conflicts

Postby xipi » Sun Mar 08, 2009 20:25

I still can't see the origin of the issue.

So far, I know that "slots" is the way that portage uses in my system to have different versions of a library living together in my system.

I've googled some forums around with similar troubles, but was unable to find a clear description on what the issue is about.

Do you know of any documentation explaining the issue of slot conflicts?

Thanks,
xipi
Young Hen
 
Posts: 23
Joined: Sun Feb 15, 2009 13:34

Re: slot conflicts

Postby Thev00d00 » Sun Mar 08, 2009 23:56

This is caused by elisa, remove elisa and its deps if you dont use it
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom

Re: slot conflicts

Postby xipi » Mon Mar 09, 2009 12:43

Thanks!

I will try removing Elisa then.

Though, I wonder why Elisa produces that, and if there is a way of having it installed without these conflicts when doing updates. I mean, does *this* happen to all Elisa users? (if they have the app's that use the libraries conflicting with it)
xipi
Young Hen
 
Posts: 23
Joined: Sun Feb 15, 2009 13:34

Re: slot conflicts

Postby albfneto » Mon Mar 09, 2009 21:51

you updated sabayon with entropy.
Sabayon have a large number od packages, gentoo not, at least you have installed many packs...
if you want to work with portage, really prefer to construct the system from the core install, but iy you really want to mix installers, deeply emerge world commands, are not so good in Sabayon.
prefer to make:

emerge --sync && emerge -e world

Slot conflicts occurs when the same deps are required by two versions of packages and therefore cannot be installed together. see:

http://dev.gentoo.org/~zmedico/portage/ ... -conflicts

different versions of the ebuilds, may be in your system, in different slots...
resolve slot conflicts and blockers are not so easy...ex.

http://blogs.gentoo.org/zmedico
viewtopic.php?f=54&t=15248&p=87136&hilit=slot+conflicts#p87136
http://blogs.gentoo.org/zmedico/2008/05 ... collisions

methods used are remove blocking packages prior the installation of the other pack, simply not update ou use blocked package, or modify the order of the installation of the package etc.,
in a example, in your code:
Code: Select all
 ('installed', '/', 'dev-python/twisted-8.1.0', 'nomerge') pulled in by
    =dev-python/twisted-8.1* required by ('installed', '/', 'dev-python/twisted-web2-8.1.0', 'nomerge')
    (and 4 more)

  ('ebuild', '/', 'dev-python/twisted-8.2.0', 'merge') pulled in by
    =dev-python/twisted-8.2* required by ('ebuild', '/', 'dev-python/twisted-web-8.2.0', 'merge')
    (and 4 more)

this indicates that twisted-web2-8.1.0 should be removed or masked, prior that twisted 8.2.0 can be emerged,,,
but in your system they are many packages with these problems, and the solution may be not practical...
if you do not re-install all the system, you may:
simply working, and for update portage in Sabayon simply use:
emerge --sync
emerge -e world
if you use deep word options, you in certain form, convert you sabayon in a modified "gentoo-ized" sabayon, but Sabayon is much larger than a typical gentoo installation, and this may presents many, many blocked, masked, conflicted or collision packages that turns the maintainance difficult!
Fortunately, in many cases, the installed packages are working, and updatable each by each, using portage, portato, entropy or spritz....
remember also, that in gentoo, some system configurations does not easy possibly to use rigorously the most recent version:
example:

http://bugs.gentoo.org/106287
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1706
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: slot conflicts

Postby Thev00d00 » Tue Mar 10, 2009 9:29

Its like that cos elisa depends on an older set of libs. The update pulls newer versions and there is a conflict.

I have yet to get it to work on newer libs hence the dependancy on the newer libs. Have you

layman -S

I swore I masked the newer versions on overlay
Image
Please report Bugs on the Bugzilla, not forum
Please Adopt an Unanswered thread
Website / Blog : v00d00.net
twitter: Follow Me
G+: Circle Me
Thev00d00
Generally Awesome (tm)
 
Posts: 1472
Joined: Wed Feb 21, 2007 15:52
Location: United Kingdom


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron