Entropy trouble with Python 3

Anything that pertains to Entropy, Equo or Sulfur

Moderator: Moderators

Entropy trouble with Python 3

Postby zemog86 » Sun Feb 22, 2009 8:00

Hi there,

Iam using Sabayon 4 on my System and now I got trouble ... I installed python 3 to update my applications and the Problem is that Portage/Entropy is not Compatible with it.
So I need to find a solution for that issue, or should I wait until Portage/Entropy is updated to python 3?

Can anyone help me out?

edit: here the error that I got searching for ruby via equo search ruby:

linux / # equo search ruby
File "/usr/lib64/entropy/client/equo.py", line 649
except exceptionTools.OnlineMirrorError, e:
^
SyntaxError: invalid syntax



cheers

zem
zemog86
Baby Hen
 
Posts: 2
Joined: Sun Feb 22, 2009 7:54

Re: Entropy trouble with Python 3

Postby lxnay » Sun Feb 22, 2009 18:42

Open /usr/lib/entropy/client/equo.py and change the first line to:
Code: Select all
#!/usr/bin/python2
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3596
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Re: Entropy trouble with Python 3

Postby zemog86 » Sun Feb 22, 2009 22:39

still the same error
zemog86
Baby Hen
 
Posts: 2
Joined: Sun Feb 22, 2009 7:54


Return to Entropy|Equo|Rigo Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron