Portage proposed downgrade..[Solved]

Anything that pertains to Portage

Moderator: Moderators

Portage proposed downgrade..[Solved]

Postby albfneto » Thu Feb 19, 2009 4:12

In one of my sabayon systems, portage propose an downgrade...
If the new portage willappers, what is the means for avoid this downgrade.

see the reply of the command

emerge -s portage:

Code: Select all
emerge -s portage
Searching...
[ Results for search key : portage ]
[ Applications found : 5 ]

*  app-portage/portage-mod_jabber
      Latest version available: 0.0.5.1
      Latest version installed: [ Not Installed ]

      Size of files: 8 kB
      Homepage:      http://usrportage.de/
      Description:   A notification module for the portage elog-system to notify via the XMPP (Jabber) protocol
      License:       GPL-2

Thanks, wolfden.
Topic explained....
*  app-portage/portage-utils
      Latest version available: 0.1.29
      Latest version installed: 0.1.29
      Size of files: 77 kB
      Homepage:      http://www.gentoo.org/
      Description:   small and fast portage helper tools written in C
      License:       GPL-2

*  dev-perl/PortageXS
      Latest version available: 0.02.09
      Latest version installed: 0.02.09
      Size of files: 28 kB
      Homepage:      http://download.mpsna.de/opensource/PortageXS/
      Description:   Portage abstraction layer for perl
      License:       GPL-2

*  dev-python/yolk-portage
      Latest version available: 0.1
      Latest version installed: [ Not Installed ]
      Size of files: 2 kB
      Homepage:      http://cheeseshop.python.org/pypi/yolk
      Description:   Gentoo Portage plugin for yolk
      License:       GPL-2

*  sys-apps/portage
      Latest version available: 2.1.6.7
      Latest version installed: 2.2_rc23
      Size of files: 608 kB
      Homepage:      http://www.gentoo.org/proj/en/portage/index.xml
      Description:   Portage is the package management and distribution system for Gentoo
      License:       GPL-2

Last edited by albfneto on Thu Feb 19, 2009 16:41, edited 1 time in total.
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Portage proposed downgrade..

Postby wolfden » Thu Feb 19, 2009 7:38

ummmmm that has been masked for long time now

23 Nov 2008; Zac Medico <[email protected]> +portage-2.1.6_rc1.ebuild:
2.1.6_rc1 release. The portage-2.1.6 branch is very close to portage-2.2 except that the unstable features, package sets and preserve-libs, have been removed. In order to ensure that portage-2.1.6 gets sufficient testing, portage-2.2 will be masked in package.mask until portage-2.1.6 has been marked stable. If you would like to continue using portage-2.2 then you should unmask it (instead of downgrading to portage-2.1.6). If you are downgrading from portage-2.2 to portage-2.1.6, do not forget to use revdep-rebuild when appropriate, since the @preserved-rebuild package set is only supported with portage-2.2.
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Portage proposed downgrade..

Postby exsencon » Thu Feb 19, 2009 15:56

forgot to mention that in my thread
Cannot install ebuilds in Sabayon 4


After Sn 4 install portage was really buggy with all kinds of bug messages so I did
emerge --sync and it downgraded from 2.2.rc2 to 2.1.6.7 and worked like a charm. For the moment I am keeping it as it is now,everything works.
exsencon
Young Hen
 
Posts: 30
Joined: Mon Feb 02, 2009 19:26
Location: Belgium


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 0 guests