printer problem /usr/libexec/cups/filter/foomatic-rip failed

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

printer problem /usr/libexec/cups/filter/foomatic-rip failed

Postby jsizzle » Thu Jul 03, 2008 5:02

if when trying to print you get the following error message in the cups web interface "/usr/libexec/cups/filter/foomatic-rip failed" like I did with my HP F4180 or like my buddy mythus who has a f HP photosmart D7100 series from #sabayon on irc. Don't worry too much your friend Jsizzle's got the medicine for ya :)

Here's what ya need to do
"emerge --sync && layman -S && emerge -u foomatic-filters foomatic-filters-ppds && /etc/init.d/cupsd restart"

Be sure your doing this as root. After this is all done you should be fine, if not reply to this post and I'll try to help ya out.

Hope this helps some folks,

Jsizzle
Jsizzle
jsizzle
Baby Hen
 
Posts: 18
Joined: Sun Jan 13, 2008 1:59

Re: printer problem /usr/libexec/cups/filter/foomatic-rip failed

Postby CatalanUser » Thu Jul 03, 2008 11:12

Hi jsizzle,

Edited:
I tried your solution in a 3.5 fresh install, but it didn't work for me:
"error: CUPSEXT could not be loaded. Please check HPLIP installation."

I tryed reinstalling HPLIP, but I get the same results :(


After reinstalling some pakages I got success! Thanks a lot! :mrgreen:
CatalanUser
Growing Hen
 
Posts: 159
Joined: Fri Oct 26, 2007 9:26
Location: Catalunya

Re: printer problem /usr/libexec/cups/filter/foomatic-rip failed

Postby joost » Thu Jul 03, 2008 15:18

Bumping them in Entropy.

:D
joost
Sagely Hen
 
Posts: 2604
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: printer problem /usr/libexec/cups/filter/foomatic-rip failed

Postby dyingmuppet » Fri Jul 04, 2008 10:49

I also had a problem with cups, It told me CUPS wasn't start right, so I ran /etc/init.d/cupsd restart and now it works fine...
I have no HP printer so I really wouldn't know if that one still is active... I suppose with an equo world that should be fixed too :wink:

Grtz Dre
dyingmuppet
Growing Hen
 
Posts: 130
Joined: Sun Jan 07, 2007 15:43
Location: Netherlands

Re: printer problem /usr/libexec/cups/filter/foomatic-rip failed

Postby dunsurfin » Fri Jul 04, 2008 11:37

joost wrote:Bumping them in Entropy.

:D


A good example of things working well. Shortly after installing my HP Deskjet F380 and finding the test page wouldn't print and then getting the error the OP mentioned, the update notification told me about the updates. Spritz installed them and my printer works :D
Thanks to everyone involved.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: printer problem /usr/libexec/cups/filter/foomatic-rip failed

Postby dogwater » Mon Feb 02, 2009 20:30

None of this worked for me but eventually running "emerge ghostscript" did. This was with the foomatic-rip failure error using an HP DeskJet 1000c printer. Printer works like a charm now.
dogwater
Baby Hen
 
Posts: 2
Joined: Mon Feb 02, 2009 20:23
Location: Vermont, USA


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron