Masked by: Corruption

Anything that pertains to Portage

Moderator: Moderators

Masked by: Corruption

Postby apollyon0810 » Mon Jan 19, 2009 7:14

Quick question hopefully. I'm really trying to get the hang of using a Gentoo-based distro. This is what happened.

I installed Sabayon 4, and fired up spritz. I went to update my video drivers to the nvidia version 180.22. It said it had to install kernel 2.6.28 as a dependency. Normal, right? So Spritz finishes downloading everything and freezes (of course). I waited a good 20 minutes before I "force quit" it. Rebooted and now Spritz does nothing when I try to "reinstall" the nvidia-drivers. An "emerge -av nvidia-drivers" yields this.

Code: Select all
localhost matthew # emerge -av nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! All ebuilds that could satisfy "x11-drivers/nvidia-drivers" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-drivers/nvidia-drivers-180.22-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-180.18 (masked by: corruption)
- x11-drivers/nvidia-drivers-177.80-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-173.14.15-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-173.14.12-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-173.14.05-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-173.08-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-169.12-r11 (masked by: corruption)
- x11-drivers/nvidia-drivers-169.12-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-169.09-r11 (masked by: corruption)
- x11-drivers/nvidia-drivers-169.09-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-96.43.09-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-96.43.07-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-96.43.05-r11 (masked by: corruption)
- x11-drivers/nvidia-drivers-71.86.07-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-71.86.06-r10 (masked by: corruption)
- x11-drivers/nvidia-drivers-71.86.04-r11 (masked by: corruption)

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
apollyon0810
Baby Hen
 
Posts: 15
Joined: Sun Nov 23, 2008 22:11

Re: Masked by: Corruption

Postby joost » Mon Jan 19, 2009 8:57

emerge is not entropy!

do it like this as root:
Code: Select all
equo install x11-drivers/nvidia-drivers-180.22-r10


Reason your emerge fails could be that you need todo a resync:
Code: Select all
emerge --sync && layman -S


But i must warn you to not mix portage and entropy, so make a choice.
joost
Sagely Hen
 
Posts: 2605
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Masked by: Corruption

Postby wolfden » Mon Jan 19, 2009 9:01

well if you go to portage you need to emerge --sync first, like our wiki explains

you need to pick one package manager and stick with it, mixing is not recommended unless you know what you are doing

if you can't get it via spritz than do equo update && equo install linux-sabayon && equo install nvidia-drivers

Our wiki covers the package managers well so look over them and decide which route you want. Entropy will be much easier for people new.
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest