Problem with emerging packages [Solved]

Anything that pertains to Portage

Moderator: Moderators

Problem with emerging packages [Solved]

Postby dimka » Mon Jan 12, 2009 10:40

I have recently installed sabayon 3.5 to my laptop.
Since I have been using gentoo for quite some time I would like to continue using portage for some packages that I want to install.

While I trying to install/upgrade a package through portage I get the following errors (I am trying to upgrade apache-was installed using spritz/entropy)
Code: Select all
emerge -pv apache

These are the packages that would be merged, in order:

Calculating dependencies -

!!! Invalid or corrupt dependency specification:

>=dev-lang/python-2.5[sqlite]

('installed', '/', 'sys-apps/entropy-0.24.6', 'nomerge')

sys-devel/gettext sys-apps/diffutils >=dev-lang/python-2.5[sqlite] dev-util/subversion net-misc/rsync sys-devel/gettext sys-apps/diffutils >=dev-lang/python-2.5[sqlite]

Portage is unable to process the dependencies of the
'sys-apps/entropy-0.24.6' package. In order to correct this problem, the
package should be uninstalled, reinstalled, or upgraded. As a temporary
workaround, the --nodeps option can be used to ignore all dependencies.
For reference, the problematic dependencies can be found in the *DEPEND
files located in '/var/db/pkg/sys-apps/entropy-0.24.6/'.

Traceback (most recent call last):
  File "/usr/bin/emerge", line 9205, in <module>
    retval = emerge_main()
  File "/usr/bin/emerge", line 9199, in emerge_main
    myopts, myaction, myfiles, spinner)
  File "/usr/bin/emerge", line 8460, in action_build
    retval, favorites = mydepgraph.select_files(myfiles)
  File "/usr/bin/emerge", line 2999, in select_files
    self.altlist()
  File "/usr/bin/emerge", line 3824, in altlist
    self._resolve_conflicts()
  File "/usr/bin/emerge", line 3839, in _resolve_conflicts
    if not self.validate_blockers():
  File "/usr/bin/emerge", line 3631, in validate_blockers
    trees=self._graph_trees, myroot=myroot)
  File "/usr/lib/portage/pym/portage.py", line 5830, in dep_check
    mysplit2=dep_wordreduce(mysplit2,mysettings,mydbapi,mode,use_cache=use_cache)
  File "/usr/lib/portage/pym/portage.py", line 5879, in dep_wordreduce
    mydep=mydbapi.match(deplist[mypos],use_cache=use_cache)
  File "/usr/bin/emerge", line 1917, in match
    result = portage.dbapi.match(self, origdep, use_cache=use_cache)
  File "/usr/lib/portage/pym/portage.py", line 6329, in match
    mydep = dep_expand(origdep, mydb=self, settings=self.settings)
  File "/usr/lib/portage/pym/portage.py", line 5753, in dep_expand
    return portage_dep.Atom(prefix + expanded + postfix)
  File "/usr/lib/portage/pym/portage_dep.py", line 289, in __init__
    raise InvalidAtom(s)
portage_exception.InvalidAtom: >=dev-lang/python-2.5[sqlite]


I am also posting the info for portage
Code: Select all
emerge --info
Portage 2.1.5.3 (default/linux/x86/2008.0/desktop, gcc-4.2.3, glibc-2.7-r1, 2.6.25-sabayon-r1 i686)
=================================================================
System uname: 2.6.25-sabayon-r1 i686 Intel(R) Core(TM)2 Duo CPU T7250 @ 2.00GHz
Timestamp of tree: Mon, 05 Jan 2009 10:30:01 +0000
distcc 2.18.3 i586-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
app-shells/bash:     3.2_p33
dev-java/java-config: 1.3.7, 2.1.6
dev-lang/python:     2.5.1-r5
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
dev-util/cmake:      2.4.7-r2
sys-apps/baselayout: 2.0.0
sys-apps/openrc:     0.2.5-r1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.62
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.1
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.24
ACCEPT_KEYWORDS="x86"
CBUILD="i586-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
CHOST="i586-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/share/config/kdm/ /usr/kde/3.5/shutdown /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="collision-protect distlocks parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.UTF-8"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en el"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/sabayon"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dfx 7Zip X a52 aac aalib accessibility acl acpi aiglx aim alsa artswrappersuid asf audiofile avahi berkdb bidi bluetooth branding bzip2 cairo cdda cddb cdr chm cjk cli commercial config_wizard cpudetection cracklib crypt css cups dbox2 dbus device-mapper dga dri dts dv dvb dvd dvdr dvdread dvi dxr3 emboss encode exscalibar extramodules fam fame fat ffmpeg fftw firefox flac flash foomatic-db fortran freetype gcj gdbm gif gimpprint gnutls gphoto2 gpm gs gsm gstreamer gtk hal hfs iconv icq ieee1394 imap inotify ipod ipv6 irc irda isdnlog jabber jack jfs jingle joystick jpeg kde kdeenablefinal kdehiddenvisibility kerberos kickoff kipi lame lcd ldap libao libnotify live lj lm_sensors logitech-mouse lzo mad mail midi mikmod mjpeg mmx mng mozdevelop mp3 mp3rtp mpeg msn mudflap musepack musicbrainz ncurses network new-login nls nptl nptlonly nsplugin ntfs ogg openal openexr opengl openmp pam pcmcia pcre pda pdf perl png povray ppds pppd pulseaudio pwdb python qt3 qt3support qt4 quicktime quotas rar rdesktop readline reflection reiserfs rss scanner sdl session slp sms speex spell spl spreadsheet ssl startup-notification stream svg switch_all_desktops sysfs tcpd theora tiff tracker truetype udev unicode usb v4l v4l2 visualization voice vorbis weather wifi win32codecs wmf x264 x86 xcb xfs xine xinerama xml xorg xpm xprint xulrunner xv xvid xvmc yahoo zeroconf zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" APACHE2_MPMS="prefork" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en el" LIRC_DEVICES="audio audio_alsa" USERLAND="GNU"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


The equo info also if needed
Code: Select all
equo --info
Architecture: i686
Collision Protection: 1
Current branch: 3.5
Entropy API: 3
Entropy Official Repository identifier: sabayonlinux.org
Entropy configuration directory: /etc/entropy
Entropy database tag: |ENTROPY:PROJECT:DB:MAGIC:START|
Entropy logging directory: /var/lib/entropy/logs
Entropy packages directory: /var/lib/entropy/packages/x86
Entropy unpack directory: /var/tmp/entropy
Entropy version: 0.24.6
Entropy work directory: /var/lib/entropy
Equo Log Level: 1
Equo pidfile: /var/lib/entropy/entropy.pid
Gentoo Compatibility: True
Installed database: False
Kernel: 2.6.25-sabayon-r1
OS: Linux
Repositories: sabayonlinux.org => configprotect => [u'/etc', u'/opt/glftpd/etc', u'/opt/glftpd/ftp-data', u'/opt/openfire/resources/security/', u'/usr/grass60/etc', u'/usr/kde/3.5/env', u'/usr/kde/3.5/share/config', u'/usr/kde/3.5/share/config/kdm/', u'/usr/kde/3.5/shutdown', u'/usr/kde/4.0/env', u'/usr/kde/4.0/share/config', u'/usr/kde/4.0/shutdown', u'/usr/lib/fax', u'/usr/share/config', u'/var/bind', u'/var/lib/hsqldb', u'/var/spool/fax/etc', u'/var/spool/torque', u'/usr/kde/3.9/env', u'/usr/kde/3.9/share/config', u'/usr/kde/3.9/shutdown', u'/usr/share/X11/xkb', u'/etc/env.d', u'/etc/env.d/java/', u'/etc/fonts/fonts.conf', u'/etc/gconf', u'/etc/gentoo-release', u'/etc/php/apache2-php5/ext-active/', u'/etc/php/cgi-php5/ext-active/', u'/etc/php/cli-php5/ext-active/', u'/etc/revdep-rebuild', u'/etc/splash', u'/etc/terminfo', u'/etc/texmf/web2c', u'/etc/udev/rules.d', u'/usr/NX/etc', u'/usr/NX/home', u'/etc/conf.d', u'/etc/hosts', u'/etc/X11/xorg.conf', u'/etc/X11', u'/etc/entropy']
Repositories: sabayonlinux.org => configprotectmask => [u'/etc', u'/opt/glftpd/etc', u'/opt/glftpd/ftp-data', u'/opt/openfire/resources/security/', u'/usr/grass60/etc', u'/usr/kde/3.5/env', u'/usr/kde/3.5/share/config', u'/usr/kde/3.5/share/config/kdm/', u'/usr/kde/3.5/shutdown', u'/usr/kde/4.0/env', u'/usr/kde/4.0/share/config', u'/usr/kde/4.0/shutdown', u'/usr/lib/fax', u'/usr/share/config', u'/var/bind', u'/var/lib/hsqldb', u'/var/spool/fax/etc', u'/var/spool/torque', u'/usr/kde/3.9/env', u'/usr/kde/3.9/share/config', u'/usr/kde/3.9/shutdown', u'/usr/share/X11/xkb', u'/etc/env.d', u'/etc/env.d/java/', u'/etc/fonts/fonts.conf', u'/etc/gconf', u'/etc/gentoo-release', u'/etc/php/apache2-php5/ext-active/', u'/etc/php/cgi-php5/ext-active/', u'/etc/php/cli-php5/ext-active/', u'/etc/revdep-rebuild', u'/etc/skel', u'/etc/splash', u'/etc/terminfo', u'/etc/texmf/web2c', u'/etc/udev/rules.d', u'/usr/NX/etc', u'/usr/NX/home', u'/etc/pam.d']
Repositories: sabayonlinux.org => database => http://svn.sabayonlinux.org/entropy/standard/sabayonlinux.org/database/x86/3.5
Repositories: sabayonlinux.org => dbcformat => bz2
Repositories: sabayonlinux.org => dbpath => /var/lib/entropy/client/database/x86/sabayonlinux.org/standard/x86/3.5
Repositories: sabayonlinux.org => dbrevision => 649
Repositories: sabayonlinux.org => description => Sabayon Linux Official Repository
Repositories: sabayonlinux.org => local_notice_board => /var/lib/entropy/client/database/x86/sabayonlinux.org/standard/x86/3.5/notice.rss
Repositories: sabayonlinux.org => notice_board => http://svn.sabayonlinux.org/entropy/standard/sabayonlinux.org/database/x86/3.5/notice.rss
Repositories: sabayonlinux.org => packages => ['http://svn.sabayonlinux.org/entropy/standard/sabayonlinux.org', 'http://mirrors.cs.wmich.edu/sabayon/entropy/standard/sabayonlinux.org', 'http://ftp.cc.uoc.gr/mirrors/linux/SabayonLinux/entropy/standard/sabayonlinux.org', 'http://mirror.dun.nu/sabayonlinux/entropy/standard/sabayonlinux.org', 'http://mirror.holland.sabayonlinux.org/entropy/standard/sabayonlinux.org', 'http://cross-lfs.sabayonlinux.org/entropy/standard/sabayonlinux.org', 'http://ftp.surfnet.nl/pub/os/Linux/distr/sabayonlinux/entropy/standard/sabayonlinux.org', 'http://na.mirror.garr.it/mirrors/sabayonlinux/entropy/standard/sabayonlinux.org']
Repositories: sabayonlinux.org => plain_database => http://svn.sabayonlinux.org/entropy
Repositories: sabayonlinux.org => plain_packages => ['http://svn.sabayonlinux.org/entropy', 'http://mirrors.cs.wmich.edu/sabayon/entropy', 'http://ftp.cc.uoc.gr/mirrors/linux/SabayonLinux/entropy', 'http://mirror.dun.nu/sabayonlinux/entropy', 'http://mirror.holland.sabayonlinux.org/entropy', 'http://cross-lfs.sabayonlinux.org/entropy', 'http://ftp.surfnet.nl/pub/os/Linux/distr/sabayonlinux/entropy', 'http://na.mirror.garr.it/mirrors/sabayonlinux/entropy']
Repositories: sabayonlinux.org => repoid => sabayonlinux.org
Repositories: sabayonlinux.org => service_port => 1026
Repositories: sabayonlinux.org => ssl_service_port => 1027
Repository databases: sabayonlinux.org => Database hash => -1
Repository databases: sabayonlinux.org => Database revision => 649
Repository databases: sabayonlinux.org => Installation internal protected directories => [u'/etc', u'/opt/glftpd/etc', u'/opt/glftpd/ftp-data', u'/opt/openfire/resources/security/', u'/usr/grass60/etc', u'/usr/kde/3.5/env', u'/usr/kde/3.5/share/config', u'/usr/kde/3.5/share/config/kdm/', u'/usr/kde/3.5/shutdown', u'/usr/kde/4.0/env', u'/usr/kde/4.0/share/config', u'/usr/kde/4.0/shutdown', u'/usr/lib/fax', u'/usr/share/config', u'/var/bind', u'/var/lib/hsqldb', u'/var/spool/fax/etc', u'/var/spool/torque', u'/usr/kde/3.9/env', u'/usr/kde/3.9/share/config', u'/usr/kde/3.9/shutdown', u'/usr/share/X11/xkb', u'/etc/env.d', u'/etc/env.d/java/', u'/etc/fonts/fonts.conf', u'/etc/gconf', u'/etc/gentoo-release', u'/etc/php/apache2-php5/ext-active/', u'/etc/php/cgi-php5/ext-active/', u'/etc/php/cli-php5/ext-active/', u'/etc/revdep-rebuild', u'/etc/splash', u'/etc/terminfo', u'/etc/texmf/web2c', u'/etc/udev/rules.d', u'/usr/NX/etc', u'/usr/NX/home']
Repository databases: sabayonlinux.org => Installation internal protected directory masks => [u'/etc', u'/opt/glftpd/etc', u'/opt/glftpd/ftp-data', u'/opt/openfire/resources/security/', u'/usr/grass60/etc', u'/usr/kde/3.5/env', u'/usr/kde/3.5/share/config', u'/usr/kde/3.5/share/config/kdm/', u'/usr/kde/3.5/shutdown', u'/usr/kde/4.0/env', u'/usr/kde/4.0/share/config', u'/usr/kde/4.0/shutdown', u'/usr/lib/fax', u'/usr/share/config', u'/var/bind', u'/var/lib/hsqldb', u'/var/spool/fax/etc', u'/var/spool/torque', u'/usr/kde/3.9/env', u'/usr/kde/3.9/share/config', u'/usr/kde/3.9/shutdown', u'/usr/share/X11/xkb', u'/etc/env.d', u'/etc/env.d/java/', u'/etc/fonts/fonts.conf', u'/etc/gconf', u'/etc/gentoo-release', u'/etc/php/apache2-php5/ext-active/', u'/etc/php/cgi-php5/ext-active/', u'/etc/php/cli-php5/ext-active/', u'/etc/revdep-rebuild', u'/etc/skel', u'/etc/splash', u'/etc/terminfo', u'/etc/texmf/web2c', u'/etc/udev/rules.d', u'/usr/NX/etc', u'/usr/NX/home']
Repository databases: sabayonlinux.org => Total available packages => 8828
System Config: api => 3
System Config: arch => x86
System Config: archs => ['x86', 'amd64']
System Config: dirstoclean => set([])
System Config: killpids => set([])
System Config: maxthreads => 100
System Config: rootdir =>
System Config: serverside => False
UI Config: ask => False
UI Config: clean => False
UI Config: debug => False
UI Config: mute => False
UI Config: nolog => False
UI Config: postinstall_triggers_disable => set([])
UI Config: postremove_triggers_disable => set([])
UI Config: preinstall_triggers_disable => set([])
UI Config: preremove_triggers_disable => set([])
UI Config: pretend => False
UI Config: quiet => False
UI Config: verbose => False
User protected directories: [u'/etc/conf.d', u'/etc/hosts', u'/etc/X11/xorg.conf', u'/etc/X11', u'/etc/entropy']
Last edited by dimka on Mon Jan 12, 2009 12:59, edited 1 time in total.
dimka
Baby Hen
 
Posts: 4
Joined: Mon Jan 12, 2009 10:27

Re: Problem with emerging packages

Postby joost » Mon Jan 12, 2009 11:06

do as the error says i guess.

Code: Select all
emerge -C entropy && layman -s sabayon && emerge entropy


Then try again
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Problem with emerging packages

Postby dimka » Mon Jan 12, 2009 11:30

joost wrote:do as the error says i guess.

Code: Select all
emerge -C entropy && layman -s sabayon && emerge entropy


Then try again


No problem with unmerging entropy and updating the sabayon repository but when trying to remerge entropy
Code: Select all
!!! Invalid or corrupt dependency specification:

invalid atom: '>=dev-lang/python-2.5[sqlite]'

('ebuild', '/', 'sys-apps/entropy-0.24.8', 'merge')

sys-devel/gettext sys-apps/diffutils >=dev-lang/python-2.5[sqlite] dev-util/subversion net-misc/rsync

This package can not be installed. Please notify the
'sys-apps/entropy-0.24.8' package maintainer about this problem.

... done!
dimka
Baby Hen
 
Posts: 4
Joined: Mon Jan 12, 2009 10:27

Re: Problem with emerging packages

Postby joost » Mon Jan 12, 2009 11:41

I'll inform the package maintainer about it!

:D
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Problem with emerging packages

Postby joost » Mon Jan 12, 2009 11:48

In addition, i'm trying to reproduce the error here... but i cannot
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Problem with emerging packages

Postby dimka » Mon Jan 12, 2009 12:04

Do you need any more info from me? I would be more than happy to send you what is needed.
dimka
Baby Hen
 
Posts: 4
Joined: Mon Jan 12, 2009 10:27

Re: Problem with emerging packages

Postby joost » Mon Jan 12, 2009 12:05

well what i think you need todo is this:

Code: Select all
echo "=sys-apps/portage-2.2_rc20" >> /etc/portage/package.unmask
emerge --sync && emerge portage
joost
Sagely Hen
 
Posts: 2549
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Problem with emerging packages

Postby dimka » Mon Jan 12, 2009 12:30

joost wrote:well what i think you need todo is this:

Code: Select all
echo "=sys-apps/portage-2.2_rc20" >> /etc/portage/package.unmask
emerge --sync && emerge portage


Remerging portage to version 2.1.6.4 from 2.1.5.3 did the trick.Version 2.2_rc20 is hard masked.

Thank you.
dimka
Baby Hen
 
Posts: 4
Joined: Mon Jan 12, 2009 10:27


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron