Portage throwing error

Anything that pertains to Portage

Moderator: Moderators

Portage throwing error

Postby eodchop » Wed Dec 17, 2008 6:18

!!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
net-dialup/slmodem:2.6.26-sabayon x11-drivers/ati-drivers:2.6.25-sabayon-r1 net-wireless/ndiswrapper:2.6.26-sabayon net-misc/et131x:2.6.26-sabayon media-video/manslide net-wireless/madwifi-ng:2.6.26-sabayon app-portage/etcproposals net-wireless/acx:2.6.26-sabayon app-emulation/virtualbox-modules:2.6.26-sabayon x11-drivers/nvidia-drivers:2.6.26-sabayon dev-util/cogito app-emulation/virtualbox-modules:2.6.25-sabayon-r1 x11-drivers/ati-drivers:2.6.26-sabayon net-dns/resolvconf-gentoo media-video/gspcav1:2.6.26-sabayon

Emaint--check world doesnt fix the problem. Should i just unemerge all packages that are casuing the error?
Penguin Power
eodchop
Baby Hen
 
Posts: 2
Joined: Tue Dec 16, 2008 2:59
Location: Missouri, United States

Re: Portage throwing error

Postby wolfden » Wed Dec 17, 2008 7:15

emerge won't find them if I recall correctly so you should equo remove the packages and than emerge back the ones you need.
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Portage throwing error

Postby albfneto » Wed Dec 17, 2008 12:34

Codchop, Is you mixing Portage with Entropy Installers?
this is for testing purposes, it is not so well.
you may have some problems in Databanks...
you may re-merge ou re-install with entropy, only the packs that you may use, or your kernel used, for example, if your sabayon
was updated to 26 kernel, some 25 kernel files, may be no longer necessary.
other examples are some packs> example.... even in Gentoo, Cogito is obsolete....
when you update the git system,git packages, webgit etc this substitute Cogito.....
ALBERTO FEDERMAN NETO
albfneto
[email protected]
Favorite Distros: Sabayon, Gentoo, Mageia and OpenSUSE
User avatar
albfneto
Sagely Hen
 
Posts: 1728
Joined: Fri Nov 16, 2007 1:15
Location: Ribeirão Preto City, São Paulo State, Brazil

Re: Portage throwing error

Postby zambayoni » Tue Feb 03, 2009 22:03

Hi, eodchop, do you are:

Code: Select all
#emerge --update world


I have the same errors when try update system with console. I update system with Spritz, but emerge call gentoo.org (mirror of gentoo), an with spritz, te update is with garr.it , a Sabayon mirror.

May be that update with emerge not is possible
User avatar
zambayoni
Young Hen
 
Posts: 33
Joined: Sun Dec 28, 2008 23:46

Re: Portage throwing error

Postby wolfden » Tue Feb 03, 2009 23:52

it is, you just need to know what you are doing - that is why I stress over and over and over that people need to learn the package manager first before attempting such things. You need to understand portage to be able to work with it. Stick with entropy for world updates till you become better with portage.

Do a portage world update isn't going to gain you much unless you are running custom configs
wolfden
Sharecropper
 
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA


Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron