com_err and e2fsprogs block eveything [Solved]

Anything that pertains to Portage

Moderator: Moderators

com_err and e2fsprogs block eveything [Solved]

Postby admsimat » Tue Sep 23, 2008 16:54

I have just installed SL 3.5. When I tried to emerge fetchmail, I got the error that com_err, ss and e2fsprogs block
the installation. Actually, these dependencies block almost every package I want to emerge, for example emacs and many more.
I can't remove them, since they are needed also to launch wget, and I apparently can't upgrade them via emerge.
Is there any safe solution to remove these blocks?

Baby Hen
Posts: 1
Joined: Tue Sep 23, 2008 16:51

Re: com_err and e2fsprogs block eveything

Postby WarraWarra » Tue Sep 23, 2008 18:33

If you are sure you have enough space on the partitions / disk then you can cheat past them.

One way I used to get past something similar :
# emerge e2fsprogs --nodeps
if that is the correct name and possibly adding extra options from emerge
# emerge --help
# emerge -s e2fsprogs

You should be able to ONLY update the specific program excluding the needed dependancy's that should be updated.


Simple once you get past this lock then you would be able to remove older one and update the dependancy's.

Sometimes doing a world update also helps , not sure after some posts and the 22 sept about update of spritz I think it is ??

Double check on this , someone with correct info will post or check the wiki's
Sagely Hen
Posts: 1989
Joined: Wed Jan 03, 2007 21:01
Location: 31.324270, -113.585511

Re: com_err and e2fsprogs block eveything

Postby wolfden » Tue Sep 23, 2008 21:10

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Cannot Update Portage

Postby sabubba » Sat Dec 06, 2008 18:05

I am a new user to Sabayon. I have tried to update portage but keep getting an error message. After I run "emerge --sync", Here is the result:

* An update to portage is available. It is _highly_ recommended
* that you update portage now, before any other packages are updated.

* To update portage, run 'emerge portage' now.

localhost ~ # emerge --update --deep portage
Calculating dependencies... done!
[ebuild U ] sys-apps/portage-2.1.6_rc3 [2.1.6_rc2]
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild U ] app-arch/lzma-utils-4.32.7 [4.32.5] USE="-nocxx%"
[ebuild U ] sys-devel/gnuconfig-20080928 [20080123]
[ebuild U ] dev-libs/expat-2.0.1-r1 [2.0.1]
[ebuild U ] sys-apps/sandbox- []
[ebuild U ] app-misc/pax-utils-0.1.19 [0.1.17]
[ebuild U ] sys-devel/autoconf-wrapper-6 [5]
[ebuild U ] dev-db/sqlite- [3.5.9]
[ebuild U ] app-admin/python-updater-0.6-r1 [0.5]
[ebuild U ] sys-apps/debianutils-2.30 [2.28.2]
[ebuild U ] sys-devel/m4-1.4.12 [1.4.10-r1]
[ebuild U ] sys-apps/findutils-4.5.2 [4.3.11]
[ebuild U ] sys-devel/binutils-2.19 [2.18-r1]
[ebuild U ] sys-apps/file-4.26 [4.25]
[ebuild U ] sys-apps/man-1.6f-r2 [1.6f]
[ebuild U ] sys-apps/man-pages-3.14 [3.05] LINGUAS="-cs* -da* -de* -es* -fr* -it* -ja* -nl* -pl* -ro* -ru* -zh_CN*"
[ebuild N ] sys-libs/e2fsprogs-libs-1.41.3 USE="nls"
[ebuild U ] sys-libs/gdbm-1.8.3-r4 [1.8.3-r3]
[ebuild U ] sys-devel/libperl-5.8.8-r2 [5.8.8-r1]
[ebuild U ] dev-lang/perl-5.8.8-r5 [5.8.8-r4]
[ebuild U ] perl-core/Test-Harness-3.14 [3.13]
[ebuild U ] sys-devel/autoconf-2.63 [2.62-r1]
[ebuild U ] sys-devel/automake-1.10.2 [1.10.1]
[ebuild U ] sys-devel/libtool-2.2.6a [1.5.26]
[ebuild U ] x11-misc/util-macros-1.2.0 [1.1.5]
[ebuild NS ] sys-libs/db-4.6.21_p3-r1 [1.85-r3, 3.2.9-r11, 4.2.52_p4-r2, 4.3.29-r2, 4.5.20_p2] USE="-bootstrap -doc -java -nocxx -tcl -test"
[ebuild U ] sys-apps/attr-2.4.43 [2.4.39]
[ebuild U ] sys-libs/db-4.5.20_p2-r1 [4.5.20_p2]
[ebuild U ] dev-lang/tcl-8.4.19 [8.4.16]
[ebuild U ] dev-libs/libgcrypt-1.4.3-r1 [1.4.1]
[ebuild U ] app-crypt/mit-krb5-1.6.3-r4 [1.6.3-r1] USE="-krb4*"
[ebuild U ] sys-apps/acl-2.2.47 [2.2.45]
[ebuild U ] x11-libs/xtrans-1.2.2 [1.0.4]
[ebuild U ] x11-proto/inputproto-1.5.0 [1.4.3-r1]
[ebuild U ] x11-libs/libXau-1.0.4 [1.0.3]
[ebuild U ] net-misc/rsync-3.0.4 [3.0.2] USE="iconv%*"
[ebuild U ] x11-libs/libSM-1.1.0 [1.0.3]
[ebuild U ] dev-libs/openssl-0.9.8i [0.9.8h]
[ebuild U ] sys-libs/ncurses-5.7 [5.6-r2] USE="-ada%"
[ebuild U ] sys-apps/coreutils-6.12-r2 [6.12]
[ebuild U ] sys-apps/texinfo-4.13 [4.11-r1]
[ebuild U ] app-shells/bash-3.2_p48 [3.2_p33] USE="-examples%"
[ebuild U ] sys-libs/gpm-1.20.5 [1.20.1-r6]
[ebuild U ] sys-libs/readline-5.2_p13 [5.2_p12-r1]
[ebuild U ] app-misc/ca-certificates-20080809 [20070303-r1]
[ebuild U ] sys-apps/groff-1.19.2-r3 [1.19.2-r2]
[ebuild U ] dev-libs/libxml2-2.7.2-r1 [2.6.31]
[ebuild U ] dev-libs/libxslt-1.1.24-r1 [1.1.24]
[ebuild U ] x11-libs/libxcb- [1.1-r1] USE="(-selinux)"
[ebuild U ] x11-libs/libX11-1.1.5 [1.1.4]
[ebuild U ] dev-lang/tk-8.4.19-r1 [8.4.16]
[blocks B ] sys-libs/com_err ("sys-libs/com_err" is blocking sys-libs/e2fsprogs-libs-1.41.3)
[blocks B ] sys-libs/ss ("sys-libs/ss" is blocking sys-libs/e2fsprogs-libs-1.41.3)
[blocks B ] <sys-fs/e2fsprogs-1.41 ("<sys-fs/e2fsprogs-1.41" is blocking sys-libs/e2fsprogs-libs-1.41.3)

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant): ... =1#blocked

I would appreciate any help. Thanks in advance.
Baby Hen
Posts: 2
Joined: Sat Dec 06, 2008 17:58

Re: Cannot Update Portage

Postby wolfden » Sat Dec 06, 2008 18:19

Please search forum

Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

blocked B but unmerge conficting pkgs breaks emerge

Postby joe3 » Wed Feb 25, 2009 1:13

I've receintly become a fan of enlightenment. And I really want e17 on Sabayon 3.5 I was having problems with the script so I thought I'd try a learning experience. ( I had an extra Sabayon 3.5 installation just sitting there on another partition ever since I tried to update "world" with equo... It booted. And if I typed startx, it gave me a working kde desktop. But I'd never bothered to tweak all my personal preference settings. And hadn't yet done the work of setting up my real user account...) It was a perfect test installation.

I did an emerge --sync && layman -S
emerged portage ( updating some config files etc...)
then I added the enlightenment overlay
layman -a enlightenment
layman -s enlightenment
and started a tedious process of
emerge -Dvp enlightenment entrance
unmerge something that was blocking something else.
emerge -Dvp enlightenment entrance

Until I had it down to three blocking packages that were all blocking the same lib... I didn't like the sound of their names. But this install was already useless if I didn't get e17 working so I unmerged these last three. Finally it looked like I'd be able to... but when I tried to emerge anything emerge kept crashing while downloading...

OK this was almost expected. I took my Sabayon 3.5 x86 installation dvd and reinstalled a "core" system in an effort get enlightenment in before anything was installed that conflicted with it... I updated emerge again, added the enlightenment overlay and tried

again... only now it doesn't find the entrance package... Since I think that's just e's answer to kdm (and I'm a startx user) I simply went with:

emerge -D enlightenment
and then just:
emerge enlightenment

It's listing the same three blocks:

[blocks B ] sys-libs/com_err ("sys-libs/com_err" is blocking sys-libs/e2fsprogs-libs-1.41.4)
[blocks B ] sys-libs/ss ("sys-libs/ss" is blocking sys-libs/e2fsprogs-libs-1.41.4)
[blocks B ] <sys-fs/e2fsprogs-1.41 ("<sys-fs/e2fsprogs-1.41" is blocking sys-libs/e2fsprogs-libs-1.41.4)

What can I do to emerge enlightenment???

Advanced Hen
Posts: 200
Joined: Sun May 06, 2007 21:28

Re: com_err and e2fsprogs block eveything [Solved]

Postby wolfden » Wed Feb 25, 2009 6:41

merged topics

Please use search function
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Return to Portage|Emerge Package Managers

Who is online

Users browsing this forum: No registered users and 1 guest