Can´t problems with emerge eclipse-sdk

Discussions Regarding Software

Moderator: Moderators

Can´t problems with emerge eclipse-sdk

Postby Tarko » Tue Sep 09, 2008 19:13

Hi, I can not emerge eclipse-sdk. I've got next message:

Omicron-001 ~ # emerge eclipse-sdk
Calculating dependencies... done!

>>> Verifying ebuild manifests

>>> Starting parallel fetch

>>> Emerging (1 of 3) dev-java/eclipse-ecj-3.4-r2
* ecjsrc-3.4.zip RMD160 SHA1 SHA256 size ... [ ok ]
* checking ebuild checksums ... [ ok ]
* checking auxfile checksums ... [ ok ]
* checking miscfile checksums ... [ ok ]
>>> Unpacking source...
>>> Unpacking ecjsrc-3.4.zip to /var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/work ...
* bootstrapping ecj with /usr/i586-pc-linux-gnu/gcc-bin/4.3.1/gcj -C ...
/usr/libexec/gcc/i586-pc-linux-gnu/4.3.1/ecj1: error while loading shared libraries: libgcj.so.9: cannot open shared object file: No such file or directory
*
* ERROR: dev-java/eclipse-ecj-3.4-r2 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3776: Called die
* The specific snippet of code:
* ${javac} ${javac_opts} $(find org/ -name '*.java') || die;
* The die message:
* (no error message)
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/lib/entropy/logs/dev-java:eclipse-ecj-3.4-r2:20080906-222631.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/temp/environment'.
*
!!! When you file a bug report, please include the following information:
GENTOO_VM= CLASSPATH="." JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info


I did emerge -pv eclipse-sdk and Eclipse has 16 packages, the other 13 were emerged. Thanks
La Inteligencia es la Gloria de Dios.
Tarko
Simple Hen
 
Posts: 77
Joined: Fri Jan 19, 2007 4:18
Location: Lima-Perú

Re: Can´t problems with emerge eclipse-sdk

Postby gux » Wed Sep 10, 2008 9:35

Hi Tarko, if you trust me then you can install eclipse-sdk (only if you have installed Sabayon 3.5).
I had the same bad problem with Eclispe and no one was able to solve it, especially with updating the whole enviroment with plugins.
But anyway keep on installing it.

Do not use shell with:
Code: Select all
# emerge eclipse-sdk


{**}but you have to use portato ({*}only if you have upgraded it first: because if you have the only one with the clean installation you are not able to make nothing) and then, after install, open Eclipse with root shell:
Code: Select all
# eclipse.....               (do not write dot point but use tab key :lol: )


and upgrade the whole enviroment if you prefer.

{*}If you have not done this, do this( as root user):
1)
Code: Select all
#emerge --sync


2)
Code: Select all
#etc-update


Code: Select all
 -3 or -5 for upgrade
-7 or -9 to discard updates
-1to exit without changing anything

choose -5

3)
Code: Select all
layman -S


and after make {**}.


Not assure you nothing but I have done so, just try it and good luck!
gux
Baby Hen
 
Posts: 15
Joined: Wed Jul 30, 2008 12:19


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest