k9copy creates 0 B files converting to .avi or .mp4

Discussions Regarding Software

Moderator: Moderators

k9copy creates 0 B files converting to .avi or .mp4

Postby PhantomRyu » Tue Aug 19, 2008 22:02

Greetings. First let me alert everyone to my Linux n00bness... now that that's out of the way: the subject says it all. I can load up k9copy just fine... I specify the file size that I want for my movies (around 1 GB; I'm a quality snob), and k9copy will go through the motions and appear to go through both passes correctly. However, when I go to the directory that the movies located, I see a 0 B AVI file... Anyone have any ideas about what I'm doing wrong here? This problem persisted through a re-install of the system (I had the computer set up in a dual-boot with Windoze, but I've since removed Windows and put on a clean installation of Sabayon).
For reference, I'm running on an ASUS G1S (Intel Core2 Duo, 2GB RAM, nvidia 8600m GT 256MB...)

Any help would be appreciated.
PhantomRyu
Baby Hen
 
Posts: 4
Joined: Tue Aug 19, 2008 21:36
Location: Iraq

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby wolfden » Wed Aug 20, 2008 2:56

please note we can not support "illegal activities" for all sorts of reasons. If this post is for legit "movies" it will remain, otherwise it will have to be closed.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby PhantomRyu » Wed Aug 20, 2008 7:26

I'm using it to make legal backups of movies that I own... I'm deployed to Iraq and I'm going to send the physical media back to my wife so they don't get messed up out here in the sandbox... as far as I know, that's a legal procedure under my (U.S.) copyright lawy
PhantomRyu
Baby Hen
 
Posts: 4
Joined: Tue Aug 19, 2008 21:36
Location: Iraq

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby wolfden » Wed Aug 20, 2008 8:56

You need to convert it to .avi or mp4?

I use k9copy and love it, but never tried to use it for converting to .avi or .mp4. I usually do a DVD9 to DVD5 into .iso format, than I can just mount the .iso file and watch the movie, course this takes more space.

Which version of k9copy are you using? 1.2.3-r2 is the latest version. From what I understand k9copy does it all, so it's not like it's missing a needed program. I haven't heard of anyone having problems and a quick scan on gentoo forums doesn't show anything either.

You are on sabayon linux 3.5?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby PhantomRyu » Wed Aug 20, 2008 10:27

I'm running Sabayon 3.5 with the 2.6.26 kernel. Just did a fresh re-install the other day and used Spritz to install the latest available version of k9copy from repository number 584. I haven't tried the .iso option at all; it's not really what I want to do. I searched for a while on the 'net myself and apparently I'm the only guy having this issue :eye: Again, I'm sure I'm probably making some dumb n00b mistake, but I'm just trying to learn Linux. Everything else I want to do with Linux works great (I do have a little problem with volume output being really, really, low, but that's secondary to this problem atm.)
PhantomRyu
Baby Hen
 
Posts: 4
Joined: Tue Aug 19, 2008 21:36
Location: Iraq

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby PhantomRyu » Thu Aug 21, 2008 10:02

Greetings, all...

I may have isolated the issue. After experimenting with different audio and video codecs, I was actually able to create a file last night by using H263+ video and AAC audio; however, the audio had severe issues. On SMplayer, it was out of synch, but wouldn't play at all with the latest version of VLC. I'm going to try a few more times to see if there's a combination of A/V codecs that will actually work.

What's weird about this situation is that the H263+ encoding takes almost three times as long as the MPEG-4 encoding (but hey, at least it creates a file). I know it's not a problem with not having the libraries; I can play MP4 files just fine with VLC (I tend not to use other video players). Does this cast any light on what the problem could be for anyone?
PhantomRyu
Baby Hen
 
Posts: 4
Joined: Tue Aug 19, 2008 21:36
Location: Iraq

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby sjieke » Thu Aug 21, 2008 10:42

As far as my knowledge goes does VLC inlcude the decoding libraries itself. So being able to play MPEG-4 files with VLC doesn't nescessary mean K9Copy can use them.

I haven't used K9Copy myself, but maybe you can configure it somewhere to point to the encoding libraries...

You can also use VLC to transcode videos from one format to another...
sjieke
Technological Hen
 
Posts: 321
Joined: Thu Mar 01, 2007 10:46
Location: Maldegem, Belgium

Re: k9copy creates 0 B files converting to .avi or .mp4

Postby Fitzcarraldo » Thu Aug 21, 2008 11:53

Don't know why you're having so much trouble, PhantomRyu, because I use k9copy under SL and PCLinuxOS and can create .avi and .mp4 files from DVDs. Occasionally the audio is out of sync but you can re-synchronise it in SMPlayer by using the + and - keys (and in MPlayer too, if I recall correctly). SMPlayer then stores the offset in an ASCII file in the hidden directory .smplayer in your home directory, and you don't have to repeat the process next time you play the video on the same PC.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron