Google Earth gives Error code 29 [Solved]

Discussions Regarding Software

Moderator: Moderators

Google Earth gives Error code 29 [Solved]

Postby Fitzcarraldo » Sun Aug 17, 2008 23:51

I've just merged the latest version of Google Earth from Portage (googleearth-4.3.7284.3916) and it gives the following error message in a pop-up window when I launch it:

Google Earth detected an error while trying to authenticate. Please check the following:
- your network connection (can you get to http://www.google.com?)
- your firewall settings
(are you blocking /opt/googleearth/googleearth-bin?)

Error code: 29
For more information, visit:

(There is no URL given under the "For more information, visit:")

Now, searching the Web, this appears to be the same problem as seen by AMD64/x86_64 users in Ubuntu, and they solve it by installing a missing library lib32nss-mdns. See the following thread, for example: http://ubuntuforums.org/showthread.php?t=770046

Trouble is, there is no such library in Portage to install. I've tried re-merging the package nss-mdns-0.10 on the off chance that it would install the missing library, but that had no effect.

Any ideas?
Last edited by Fitzcarraldo on Mon Aug 18, 2008 1:17, edited 1 time in total.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth gives Error code 29

Postby dunsurfin » Mon Aug 18, 2008 0:14

Fitzcarraldo; I also updated to 4.3.7264.3916 (using spritz) and, apart from being a bit slow in starting, it works well. I'm also on AMD64 and use 3.5 x86-64 (fully updated) and I don't have lib32nss-mdns installed. That would suggest the error is something else.
Edit; Just reread everything and see that I have a different version unless there's a typo somewhere.
Edit again. It was my eyesight - I do have 4.3.7284.3916 :oops:
Last edited by dunsurfin on Mon Aug 18, 2008 0:19, edited 1 time in total.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Google Earth gives Error code 29

Postby Fitzcarraldo » Mon Aug 18, 2008 0:18

Thanks for the reply.

Code: Select all
$ eix googleearth
[I] x11-misc/googleearth
     Available versions:  4.2.205.5730!m (~)4.3.7284.3916!m
     Installed versions:  4.3.7284.3916!m(22:35:47 17/08/08)
     Homepage:            http://earth.google.com/
     Description:         A 3D interface to the planet


If you don't have lib32nss-mdns installed either, I wonder what it can be?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth gives Error code 29

Postby dunsurfin » Mon Aug 18, 2008 0:23

Have you tried opening it from a terminal as root? The Ubuntu thread seems to suggest that works for some.
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Google Earth gives Error code 29

Postby Fitzcarraldo » Mon Aug 18, 2008 0:31

Not yet -- that's going to be my last course of action if all else fails.

Can you do me a favour, please? What are the contents of the files /etc/mdns.allow and /etc/nsswitch.conf on you PC?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth gives Error code 29

Postby dunsurfin » Mon Aug 18, 2008 0:42

Here they are:

/etc/mdns.allow

# mdns.allow:
.local.
.local

/etc/nsswitch.conf

# /etc/nsswitch.conf:
# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/nsswitch.conf,v 1.1 2005/05/17 00:52:41 vapier Exp $

passwd: compat
shadow: compat
group: compat

# passwd: db files nis
# shadow: db files nis
# group: db files nis

hosts: files mdns4_minimal dns mdns4
networks: files dns

services: db files
protocols: db files
rpc: db files
ethers: db files
netmasks: files
netgroup: files
bootparams: files

automount: files
aliases: files

I'm afraid that any more will have to wait until tomorrow - I'm off to bed now :)
Self-righteousness is a loud din raised to drown the voice of guilt within us - Eric Hoffer

Don't believe what it says on the right - I am anything but sagely; More oniony!
dunsurfin
Sagely Hen
 
Posts: 1333
Joined: Sun Jan 07, 2007 21:38
Location: Newcastle upon Tyne UK

Re: Google Earth gives Error code 29

Postby Fitzcarraldo » Mon Aug 18, 2008 1:02

Here are mine:

Code: Select all
# mdns.allow:
.local.
.local


Code: Select all
# /etc/nsswitch.conf:
# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/nsswitch.conf,v 1.1 2005/05/17 00:52:41 vapier Exp $

passwd:      compat
shadow:      compat
group:       compat

# passwd:    db files nis
# shadow:    db files nis
# group:     db files nis

hosts:       files mdns4_minimal [NOTFOUND=return] dns mdns4
networks:    files dns

services:    db files
protocols:   db files
rpc:         db files
ethers:      db files
netmasks:    files
netgroup:    files
bootparams:  files

automount:   files
aliases:     files

Interesting: the hosts line in my /etc/nsswitch.conf has "[NOTFOUND=return]" in it, whereas yours doesn't. When I re-emerged nss-mdns-0.10 it displayed the following message at the end of the (successful) build process (notice that it mentions the "[NOTFOUND=return]":
Code: Select all
>>> Original instance of package unmerged safely.
 *
 * You must modify your name service switch look up file to enable
 * multicast DNS lookups.  If you wish to resolve only IPv6 addresses
 * use mdns6.  For IPv4 addresses only, use mdns4.  To resolve both
 * use mdns.  Keep in mind that mdns will be slower if there are no
 * IPv6 addresses published via mDNS on the network.  There are also
 * minimal (mdns?_minimal) libraries which only lookup .local hosts
 * and 169.254.x.x addresses.
 *
 * Add the appropriate mdns into the hosts line in /etc/nsswitch.conf
 * An example line looks like:
 * hosts:       files mdns4_minimal [NOTFOUND=return] dns mdns4
 *
 * If you want to perform mDNS lookups for domains other than the ones
 * ending in .local, add them to /etc/mdns.allow
 *
>>> Regenerating /etc/ld.so.cache...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Messages for package sys-auth/nss-mdns-0.10:

 *
 * You must modify your name service switch look up file to enable
 * multicast DNS lookups.  If you wish to resolve only IPv6 addresses
 * use mdns6.  For IPv4 addresses only, use mdns4.  To resolve both
 * use mdns.  Keep in mind that mdns will be slower if there are no
 * IPv6 addresses published via mDNS on the network.  There are also
 * minimal (mdns?_minimal) libraries which only lookup .local hosts
 * and 169.254.x.x addresses.
 *
 * Add the appropriate mdns into the hosts line in /etc/nsswitch.conf
 * An example line looks like:
 *
 * If you want to perform mDNS lookups for domains other than the ones
 * ending in .local, add them to /etc/mdns.allow
 *

 * GNU info directory index is up-to-date.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth gives Error code 29

Postby Fitzcarraldo » Mon Aug 18, 2008 1:16

Fascinating. I removed the "[NOTFOUND=return]" from /etc/nsswitch.conf and Google Earth 4.3 now works.

The question is: Why does my PC have "[NOTFOUND=return]" in the file /etc/nsswitch.conf (which was created by merging nss-mdns-0.10 from Portage) whereas your PC does not? I certainly did not add the "[NOTFOUND=return]" to the hosts line. And it's strange that, when I re-emerged nss-mdns-0.10, the build process recommends a hosts line that includes "[NOTFOUND=return]". Very odd. I take it you also have the package nss-mdns-0.10 installed on your PC?
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: Google Earth gives Error code 29 [Solved]

Postby wolfden » Mon Aug 18, 2008 2:13

Maybe this will be of some interests as to why that is there

http://bugs.gentoo.org/show_bug.cgi?id=201948
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Google Earth gives Error code 29 [Solved]

Postby Fitzcarraldo » Mon Aug 18, 2008 3:22

Yes, the problem reported by Paweł Hajdan jr (ph) in the Gentoo Bugzilla Bug no. 201948 is exactly what I saw. The source of the problem is not clear from the explanations given by Jakub Moc (who, incidentally, comes across as rather haughty in his replies). I, for example, experience the complete opposite of what Moc stated happens on his PC. I get:

Code: Select all
# grep hosts /etc/nsswitch.conf
hosts:       files mdns4_minimal dns mdns4
# ping www.gentoo.org
PING www.gentoo.org (209.177.148.229) 56(84) bytes of data.
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=1 ttl=48 time=190 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=2 ttl=48 time=186 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=3 ttl=48 time=185 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=4 ttl=48 time=184 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=5 ttl=48 time=185 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=6 ttl=48 time=185 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=7 ttl=48 time=186 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=8 ttl=48 time=185 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=9 ttl=48 time=185 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=10 ttl=48 time=186 ms
64 bytes from loon.gentoo.org (209.177.148.229): icmp_seq=11 ttl=48 time=186 ms
^C
--- www.gentoo.org ping statistics ---
11 packets transmitted, 11 received, 0% packet loss, time 10008ms
rtt min/avg/max/mdev = 184.369/186.179/190.564/1.586 ms

Did lxnay remove "[NOTFOUND=return]" from /etc/nsswitch.conf before creating the ISO for the SL 3.5 DVD, as it's not in the /etc/nsswitch.conf on dunsurfin's 3.5 installation? Or is it not there because the 3.5 ISO has an earlier version of nss-mdns (and avahi)? I have nss-mdns-0.10 and avahi-0.6.23 installed on my PC, which are currently the latest versions in Portage.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7977
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 5 guests