Another Thunderbird issue [Solved]

Discussions Regarding Software

Moderator: Moderators

Post Reply
william4
Young Hen
Posts: 25
Joined: Wed Aug 13, 2008 2:08

Another Thunderbird issue [Solved]

Post by william4 » Sat Aug 16, 2008 23:31

I have another little issue with Thunderbird when used in Sabayon 3.5. Thunderbird allows you to save an email message as message.eml, which you can later open again with Thunderbird. If you double click on such an eml file in Thunderbird/Sabayon, it opens Thunderbird, but not the email message. If you use kmail in Sabayon, the message opens directly. In several other distros the eml also opens directly in Thunderbird, which is a very handy feature. Of course, I can open Thunderbird first and then open a saved message, but it is more convenient to double-click on the eml and open it if you are checking several old saved messages. Does anybody know how to change some setting in Thunderbird or Sabayon so that I can that accomplished?

william4
Last edited by william4 on Sun Aug 17, 2008 16:23, edited 1 time in total.

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8113
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Another Thunderbird issue

Post by Fitzcarraldo » Sun Aug 17, 2008 0:42

It's not Thunderbird that you need to configure, it's the operating system's file associations. You'll need to do something along the following lines:

a) select K Menu > Control Centre > KDE Components > File Associations

b) click on the "+" next to "message" to expand it

c) select rfc822

d) On the General tab, under Filename Patterns click on Add and add *.eml to the box

e) On the General tab, under Application Preference Order click on Add and add Mozilla Thunderbird (click on the "+" next to "Office" in the pop-up window and scroll down to "Mozilla Thunderbird")

f) Click on Move Up to move Mozilla Thunderbird to the top of the list above KMail

g) Click on Apply

william4
Young Hen
Posts: 25
Joined: Wed Aug 13, 2008 2:08

Re: Another Thunderbird issue

Post by william4 » Sun Aug 17, 2008 4:08

Fitzcarraldo, where is the file association feature in GNOME? The change I made in KDE does not show up in GNOME, which is what I typically use.

william4
======

User avatar
Fitzcarraldo
Sagely Hen
Posts: 8113
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom
Contact:

Re: Another Thunderbird issue

Post by Fitzcarraldo » Sun Aug 17, 2008 4:19

Haven't used GNOME recently, but it's presumably the same method as described in the following post:

http://linuxfud.wordpress.com/2006/09/0 ... ociations/

william4
Young Hen
Posts: 25
Joined: Wed Aug 13, 2008 2:08

Re: Another Thunderbird issue

Post by william4 » Sun Aug 17, 2008 16:03

It does not seem to be so simple. It is easy to change the preferred program for opening the *.eml file (click on properties of the *.eml file and then on "open with". You can then add and delete whatever program or editor you want). I looked at my settings in Ubuntu for opening a saved email message *.eml. It has two thunderbird entries. One is "thunderbird %u", the other one is /usr/bin/thunderbird". When I use the first one, it opens the Thunderbird program, but not the message. When I use the other one, it opens Thunderbird and also opens the message, which is what I want. I then used the same settings in Sabayon 3.5 and found that both settings open Thunderbird, but neither opens the actual message!I am at a loss here. Any suggestions?

william4
Young Hen
Posts: 25
Joined: Wed Aug 13, 2008 2:08

Re: Another Thunderbird issue

Post by william4 » Sun Aug 17, 2008 16:22

I just found a solution. If you define the Thunderbird application for opening a saved *.eml file as /usr/lib/mozilla-thunderbird/thunderbird it will open thunderbird AND the message when you double-click on the saved message. I have no idea why, but it works.

william4

Post Reply