Java issue with OpenOffice & Firefox

Discussions Regarding Software

Moderator: Moderators

Java issue with OpenOffice & Firefox

Postby masterLoki » Fri Jul 11, 2008 8:39

Hi there.

I'm using Sabayon 3.5 Final and everything is nice and great, but now I have a problem with Java and OpenOffice
Neither OpenOffice nor Firefox is detecting java. When I try to set the JRE for OOo, I got no JRE to choose from.
Already ran the following commands:

Code: Select all
java -version
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) Client VM (build 10.0-b22, mixed mode)


Code: Select all
java-config -L
The following VMs are available for generation-2:
*)      Sun JDK 1.6.0.06 [sun-jdk-1.6]
2)      Sun JRE 1.6.0.04 [sun-jre-bin-1.6]


java-check-enviroment says

java-check-environment
* === Java Environment Checker ===
* The purpose of this script is to check the sanity of your Java Environment.
* We have significantly changed and improved the way Java is handled in many
* respects.
* Please refer to our upgrade guide for details:
* \thttp://www.gentoo.org/proj/en/java/java-upgrade.xml

* Checking fastjar ... [ ok ]

* Checking vm_environment_files ... [ ok ]

* Checking user_settings ... [ ok ]

* Checking generation_1_system_vm ...
* No Generation-1 System VM is set! (no /etc/env.d/20java)
* It doesn't look like java-config-1 sees any installed VMs.
* It is most likely because you don't have a 1.4 JDK installed
* This is required for generation-1 to work properly.
* You will want to emerge =virtual/jdk-1.4* [ !! ]

* Some problems were found. Please follow the instructions above, and rerun java-check-environment


The java package is on /opt/sun-jdk-1.6.0.06/bin/*. In this place are all the java exec (java, javac, javadoc, etc.).
Permissions are:
Code: Select all
ls -l java
-rwxr-xr-x 1 root root 47116 mar 25 09:01 java


Any ideas??

Thanks in advance

P.D.
Running OOo from console throws this error when trying to config java:

Code: Select all
[Java framework] Invalid value for bootstrap variable: UNO_JAVA_JFW_VENDOR_SETTINGS
masterLoki
Baby Hen
 
Posts: 3
Joined: Tue Jul 08, 2008 23:56

Re: Java issue with OpenOffice & Firefox

Postby masterLoki » Mon Jul 14, 2008 1:04

Java is working with Firefox, tested in games.yahoo.com.
The OOo is still there, getting the error

Code: Select all
[Java framework] Invalid value for bootstrap variable: UNO_JAVA_JFW_VENDOR_SETTINGS   


Still looking for a solution
masterLoki
Baby Hen
 
Posts: 3
Joined: Tue Jul 08, 2008 23:56


Return to Software in General

Who is online

Users browsing this forum: No registered users and 5 guests