h.264 decoding

Discussions Regarding Software

Moderator: Moderators

h.264 decoding

Postby fenris » Fri May 30, 2008 21:16

Is there really no h.264 hardware decoding support for linux? Is it the display- drivers that's the problem here, or..
fenris
Young Hen
 
Posts: 37
Joined: Wed Mar 12, 2008 20:21

Re: h.264 decoding

Postby pedrodh » Mon Jun 16, 2008 11:37

Hi! I can't tell if there is native support for h264 decoding by the graphic card on Linux or not, but one thing I know. When you play a video file encoded in h264 in mplayer, you can choose to render it with opengl, witch is done by the graphic card. I notice a great drop in the CPU usage when it is done by opengl. So, what I mean is, even is the drivers are not using the decoding feature of your graphic card, there is indeed use of the graphic card in the decoding process, trough opengl rendering.
pedrodh
Young Hen
 
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Re: h.264 decoding

Postby fenris » Mon Jun 23, 2008 18:37

Thanks. I installed an opengl gstream plugin, and that seems to work. It won't handle hd video all that well, but it works for everything else. :)

The xine engine won't start, for some reason, reporting something about..
"libx264.so.59: cannot open shared object file". Any ideas?
fenris
Young Hen
 
Posts: 37
Joined: Wed Mar 12, 2008 20:21

Re: h.264 decoding

Postby yuguang » Wed Jun 25, 2008 4:15

I get the same message trying to play some mp4 files in mplayer, but this might help
http://www.mplayerhq.hu/DOCS/HTML/en/vi ... 264-whatis
yuguang
Simple Hen
 
Posts: 73
Joined: Sun Jun 22, 2008 23:13

Re: h.264 decoding

Postby fenris » Sun Jul 13, 2008 6:34

..seems I can run the high def video without any trouble after all with the xine engine (it's about 30% load, used to be 100%). Hm. No idea if I did anything specific to make it work, though..
fenris
Young Hen
 
Posts: 37
Joined: Wed Mar 12, 2008 20:21


Return to Software in General

Who is online

Users browsing this forum: No registered users and 3 guests

cron