Java wont work

Discussions Regarding Software

Moderator: Moderators

Java wont work

Postby tman7510 » Sun Apr 13, 2008 23:48

I've already tried this link viewtopic.php?f=54&t=10166&p=59438&hilit=java+runtime#p59438

but it does nothing for me I still get this error when I type java

* Home for VM 'sun-jdk-1.6' does not exist: /usr/lib/jvm//sun-jdk-1.6
* Invalid System VM: sun-jdk-1.6

I' actually trying to have two versions running jre 1.5 and 1.4

I need the plugins fro diff applications

java-check-environment gives me this error

* Checking fastjar ...
gcc-config error: /usr/bin/fastjar wrapper: Unable to determine executable.
CTARGET=i586-pc-linux-gnu
exec=fastjar

gcc-config error: /usr/bin/fastjar wrapper: Unable to determine executable.
CTARGET=i586-pc-linux-gnu
exec=fastjar

grep: test.txt: No such file or directory
* Your /usr/bin/fastjar was not able to create a jar file.
* See https://bugs.gentoo.org/show_bug.cgi?id=135688
* for details. If you have had eselect-compiler installed
* just delete /usr/bin/fastjar. Otherwise report this to
* http://bugs.gentoo.org. [ !! ]

* Some problems were found. Please follow the instructions above, and rerun java-check-environment

Anybody figured this out yet?
tman7510
Simple Hen
 
Posts: 92
Joined: Sun Mar 16, 2008 5:51

Re: Java wont work

Postby xlnagla » Mon Apr 14, 2008 1:55

check to see if java's in /opt - if it is, then create a simlink to it - ran into the same problem myself after recompiling X.
lrwxrwxrwx 1 root root 25 2008-03-15 12:29 /usr/lib/jvm/sun-jre-bin-1.6 -> /opt/sun-jre-bin-1.6.0.04/
Also had to do this:
viewtopic.php?f=57&t=12955&hilit=+java

You may need to recompile some other applications after this depending on the last time you installed libX11 and libxcb - only if the versions you currently have aren't in portage anymore.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: Java wont work

Postby DontPanic » Tue Apr 15, 2008 20:50

This is somewhat similar to a problem I had a while back (Here's my comment in the Gentoo Forum's trouble with dev-java/antlr-2.7.7)

The problem was alittle different, but, in the process, I discovered that java doesn't seem to need fastjar to run. Basically, my problem was fixed by removing fastjar altogether, or moving it to a slightly new name "mv /usr/bin/fastjar /usr/bin/fastjar.depricate" (in case I needed to undo this fix later).

I haven't run across this problem in a while, though, so let us know if this works.
Gigabyte GA-P35-DS3L - Intel(R) Core(TM)2 Duo CPU E6750@ 2.66GHz
nVidia GeForce 7600 GS
2 GB RAM
DontPanic
Old Dear Hen
 
Posts: 742
Joined: Mon Jul 09, 2007 20:29
Location: Mobile, AL, USA


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest