Kooldock launch at startup [Solved]

Discussions Regarding Software

Moderator: Moderators

Kooldock launch at startup [Solved]

Postby aopisa » Thu Mar 13, 2008 0:11

Can someone please tell me how to get Kooldock to launch at startup? Many thanks.
aopisa
Baby Hen
 
Posts: 8
Joined: Sat Nov 03, 2007 2:26

Re: Kooldock launch at startup

Postby wolfden » Thu Mar 13, 2008 0:21

what desktop are you using?

KDE session should remember it and auto start it - otherwise add it to ~/.kde/Autostart
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Kooldock launch at startup

Postby aopisa » Thu Mar 13, 2008 2:29

I am using KDE, but it does not "remember" to launch it. I've been using Kooldock for a few months and finally decided that it's time to address the issue. I had it pinpointed to .kde/Autostart but, I'm not sure what the syntax is. There are 2 files in that folder, .directory and winkey.desktop. This isn't an area that I've worked in yet. Sorry for my ignorance.
aopisa
Baby Hen
 
Posts: 8
Joined: Sat Nov 03, 2007 2:26

Re: Kooldock launch at startup

Postby aopisa » Thu Mar 13, 2008 2:30

I am using KDE, but it does not "remember" to launch it. I've been using Kooldock for a few months and finally decided that it's time to address the issue. I had it pinpointed to .kde/Autostart but, I'm not sure what the syntax is. There are 2 files in that folder, .directory and winkey.desktop. This isn't an area that I've worked in yet. Sorry for my ignorance.
aopisa
Baby Hen
 
Posts: 8
Joined: Sat Nov 03, 2007 2:26

Re: Kooldock launch at startup

Postby Bam » Thu Mar 13, 2008 4:11

If I remember right, KDE defaults to booting to the previous session which doesn't remember kooldock. I could never get kooldock to work in the autostart folder although I have other things I put in there that work fine. How I got kooldock to start on boot was:

Launch kcontrol go to KDE Components/Session Manager & set the On Login option to "Restore manually saved session"

Exit out of the compiz fusion icon on your system tray. This is important otherwise it will start twice when you boot into KDE next time.

Set your desktop up to how you want it to look/function on KDE startup (kooldock running & whatever else). Then click your kicker menu & choose "save session". This option should have showed up after you changed the session manager option in kcontrol.

Log out and back in to KDE and kooldock should start automatically.
Bam
Young Hen
 
Posts: 31
Joined: Sun May 27, 2007 22:30

Re: Kooldock launch at startup

Postby aopisa » Thu Mar 13, 2008 4:26

Actually KDE defaulted back to "start with empty session", but I hadn't noticed. All I had to do was select "restore previous session" which seems to remember Kooldock on my system. Thanks for pointing me in the right direction. :D

Sorry about the duplicate reply above.
aopisa
Baby Hen
 
Posts: 8
Joined: Sat Nov 03, 2007 2:26

Re: Kooldock launch at startup

Postby Bam » Thu Mar 13, 2008 4:35

Glad you got it sorted out.
Bam
Young Hen
 
Posts: 31
Joined: Sun May 27, 2007 22:30


Return to Software in General

Who is online

Users browsing this forum: No registered users and 4 guests

cron