[EMERGE WORLD] package.mask

Conversations générales au sujet de Sabayon Linux

Moderator: Moderators

[EMERGE WORLD] package.mask

Postby legabier » Wed Feb 27, 2008 6:40

Je viens d'installer Sabayon.
Après l'installation, j'ai fait "emerge -O portage && emerge portage" et maintenant j'essais un "emerge -av world" et j'ai ce résultat:
Code: Select all
# emerge -av world

These are the packages that would be merged, in order:

Calculating world dependencies /
!!! All ebuilds that could satisfy ">=sys-apps/groff-1.19.2-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- sys-apps/groff-1.19.2-r2 (masked by: package.mask)
- sys-apps/groff-1.19.2-r1 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "sys-apps/man-1.6f-r1" [ebuild])



!!! Problem resolving dependencies for sys-apps/man-pages
!!! Depgraph creation failed.

Je viens par le fait même de me rendre compte que le fichier /etc/portage/package.mask est beaucoup utilisé par Sabayon. Entre autres, tout ce qui est suppérieur ou égale à la 1.19 de groff est masqué.
Comment je dois faire pour tout mettre à jour avec tout ces masquages?
legabier
Baby Hen
 
Posts: 4
Joined: Wed Feb 27, 2008 3:04

Re: [EMERGE WORLD] package.mask

Postby gaffu » Wed Feb 27, 2008 9:49

Simplement enlève la ligne concernant groff de package.mask.
gaffu
Growing Hen
 
Posts: 110
Joined: Tue Jan 23, 2007 16:16

Re: [EMERGE WORLD] package.mask

Postby legabier » Wed Feb 27, 2008 13:02

Il y en a d'autres...
Je n'ai jamais touché à ce fichier et c'est une installation de Sabayon toute neuve que j'ai faite hier.
Mais est-ce qu'il y a une raison pour laquelle ces paquets sont masqués par défaut?

Sous Gentoo, je ne me souviens pas que ce fichier ait déjà été modifié par un processus automatisé.
legabier
Baby Hen
 
Posts: 4
Joined: Wed Feb 27, 2008 3:04

Re: [EMERGE WORLD] package.mask

Postby gaffu » Wed Feb 27, 2008 13:46

Probablement il y avait une raison quand le fichier à été crée (soit quand la version de sabayon que t'as installée est sortie). Pour certains il y a encore une raison, pour d'autres probablement pas. Si t'as déjà utilisé Gentoo tu n'auras pas de problèmes à t'en sortir...

A ma connaissance aucun programme ne modifie ce fichier automatiquement.

Dans le forum il y a un "How To" pour le world update (en anglais, il y a une traduction en italien mais je ne sais pas en français). Essaye de suivre ça.
Si tu utilises Sabayon 3.4 il y aura beaucoup de bloquages à résoudre avant de pouvoir faire un update.
gaffu
Growing Hen
 
Posts: 110
Joined: Tue Jan 23, 2007 16:16


Return to French

Who is online

Users browsing this forum: No registered users and 2 guests