spellchecking problem

Discussions Regarding Software

Moderator: Moderators

spellchecking problem

Postby pedrodh » Tue Feb 19, 2008 16:42

I've installed Sabayon in english language but my main language is portuguese ( because i understand pretty well english, and i often don't like the translations ). Well, the problem is i've been using pidgin to talk to others and it does spellchecking in english, but most people i talk is speaks portuguese, so for that application i mainly use portuguese. This and open office. How do i change them to portuguese?

Here some things i've tried already : In Open Office i've gone to "tools"»"options"»"Language Settings"»"open office hunspell spellchecker"»"edit" ... but portuguese is not displayed on the drop-down list.
pedrodh
Young Hen
 
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Re: spellchecking problem

Postby Fitzcarraldo » Tue Feb 19, 2008 17:20

Não é muito difícil, Pedro.

I take it you have already emerged myspell-pt? If not, you need to do it. For spell checking, check if you have installed the package eselect-oodict and try:

# eselect oodict list

to show what language codes are installed, and then e.g.:

# eselect oodict set myspell-pt

Here is what it looks like on my PC:

Code: Select all
localhost fitzcarraldo # eselect oodict list
Installed dictionary sources that can be set:
  [1]   myspell
    Installed language codes:
      en es fr pt
localhost fitzcarraldo # eselect oodict set myspell-pt
localhost fitzcarraldo #


I also recommend that you study the Gentoo localization guide (you can add a Portuguese locale and still keep the English one too):
http://www.gentoo.org/doc/en/guide-localization.xml

Then, add the "nls" (native language support) global USE flag to your /etc/make.conf if you don't have it there already. Not all applications provide native language support, but several do (if they are compiled with the nls USE flag).

By the way, if you look in /etc/portage/package.use you can add the Portuguese language local USE flag for OpenOffice if you want to change the GUI to Portuguese. Here's what the entry in my /etc/portage/package.use looks like:

Code: Select all
app-office/openoffice -linguas_af -linguas_ar -linguas_bg -linguas_bn -linguas_bs -linguas_ca -linguas_cs -linguas_cy -linguas_da -linguas_el -linguas_et -linguas_fa -linguas_fi -linguas_gu_IN -linguas_he -linguas_hr -linguas_hu -linguas_ja -linguas_km -linguas_ko -linguas_lt -linguas_lv -linguas_mk -linguas_nb -linguas_nn -linguas_pl -linguas_pt -linguas_pt_BR -linguas_rw -linguas_sk -linguas_sl -linguas_sv -linguas_tg -linguas_tr -linguas_vi -linguas_zh_TW sound


So you could change "-linguas_pt" to "linguas_pt" if you wanted to, and recompile openoffice (which takes 6+ hours!) or, alternatively, emerge openoffice-bin which is much faster (but then you'd need to have e.g. app-office/openoffice-bin linguas_pt instead).
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: spellchecking problem

Postby pedrodh » Tue Feb 19, 2008 19:12

No, i didn't have done emerge myspell-pt. Now i've and it is successfully installed.

About eselect oodict list i seem to have a bunch of dictionaries

Code: Select all
Installed language codes:
      de en eo es fr ga it nl pt ru


the "pt" wasn't there before i've emerged it. Can i safely unmerge the ones i don't need now ? ( like russian and italian ).

The location settings I've managed to get it right only from KDE settings ( at "Country/Region & Language" panel ), I've selected my country as Portugal and selected US English as primary language, and it done pretty well the job.
Firefox was very easy to set up too. The open office "trick" worked fine. My sister can now stop boring me about wanting back MS Office, :P .

Thank you :).
pedrodh
Young Hen
 
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Re: spellchecking problem

Postby Fitzcarraldo » Tue Feb 19, 2008 19:40

Yes, you can safely unmerge the languages you don't need.

You should also do the following:

# eselect oodict --help

and it will tell you all the options you can use with eselect oodict. For example:

# eselect oodict unset myspell-ru

would un-configure the Russian dictionary from use with OpenOffice.

SL 'out-of-the-box' has many locales configured, and you can select them from the KDE Control Centre, as you discovered. I mentioned the Gentoo Localization Guide just in case you did not have the various locales available, as I have found in the past that they can all disappear except for en_US after I have emerged something, in which case I just refer to the Gentoo Localization Guide and set up again only the two or three locales I want to use. So keep it in mind in case you need it in future.
User avatar
Fitzcarraldo
Sagely Hen
 
Posts: 7998
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom


Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest