matroska playback problems [Solved]

Discussions Regarding Software

Moderator: Moderators

matroska playback problems [Solved]

Postby pedrodh » Wed Feb 13, 2008 12:48

Hi there everyone!
I started using Sabayon yesterday and Im enjoying it a lot. It have lots of features i was looking for :) . However i have some .mkv ( matroska ) files on my hard drive, that don't play on the SMplayer. They open in SMplayer by default, but nothing happens once the application is started, even if i click the play button. I've openned ( kind a stupid idea :X ) the file on Amarok and it played the sound of the movie, but of course no image ( since it's a music player LOL ). Does anyone knows how i solve this ?

PS : My version is Sabayon 3.4 ( Mini Ed. )
Last edited by pedrodh on Thu Feb 14, 2008 13:24, edited 1 time in total.
Young Hen
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Re: matroska playback problems

Postby Fitzcarraldo » Wed Feb 13, 2008 12:52

Have you tried any of the other media players, such as Kaffeine, Totem, VLC etc.? I'm not on a PC running SL at the moment, but if I recall correctly at least one of those supports .mkv files.
User avatar
Sagely Hen
Posts: 8090
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: matroska playback problems

Postby pedrodh » Wed Feb 13, 2008 14:06

Gonna try VLC once i get home and see what happens. Thks
Young Hen
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Re: matroska playback problems

Postby Fitzcarraldo » Thu Feb 14, 2008 0:41

I have done some googling, as matroska is a file format with which I was not familiar. The Wikipedia article on the Matroska format lists the media players that can play .mkv files:

Kaffeine is not included in the Wikipedia list but I have played .mkv files using that too.

There are two sample .mkv files on the following Web page:

The first .mkv file wraps a RealVideo 9-encoded video. The second .mkv file wraps an XviD-encoded video.

I tried both the videos with MPlayer, SMPlayer, KMPlayer, Totem, Kaffeine and VLC on my laptop running 64-bit SL (originally installed from the 3.4f LiveDVD but with the vast majority of packages rebuilt since installation). Totem could not play the first .mkv file (neither audio nor video) but it could play the second. VLC could only play audio for the first .mkv file, and displayed the error message "No suitable decoder module: VLC does not support the audio or video format "undf". Unfortunately there is no way for you to fix this." But VLC could play the second file fine. Apart from these two exceptions, all the above-mentioned media players could play both videos. And I think if I played around with the settings/preferences I could probably get those two exceptions working too, but with so much choice already I can't be bothered.

I also tried the two .mkv files with Kaffeine, MPlayer and VLC on a PC running 32-bit PCLinuxOS. In this case the first .mkv file (the RealVideo 9-encoded video) would not play but the XviD-encoded .mkv file played fine.

Note that I have the following global USE flags set in my /etc/make.conf file, and some time ago I rebuilt all the above-mentioned media players:

Code: Select all
USE="mp3 divx4linux dvb dvd dvdread live mpeg jpeg truetype v4l v4l2 xv xvid \
multilib gnutls arts cups ppds foomatic-db alsa gimpprint freetype gnome X gtk2 \
unicode moznocompose moznoirc moznomail kde qt livecd samba xinerama xine theora \
kdeenablefinal wifi hal ieee1394 oggvorbis lm_sensors logitech-mouse \
zeroconf artswrappersuid jack nptl nptlonly rdesktop dvdr css gphoto2 openexr pcmcia \
speex jpeg2k povray scanner musicbrainz accessibility audiofile \
exif xscreensaver ffmpeg vcd sndfile musepack asterisk mbrola pam_chroot pam_timestamp \
pwdb gnokii sms bluetooth irda kig-scripting speedo browserplugin nsplugin ldap \
kerberos firefox dga aac dts xvmc dbus hal dvi on-the-fly-crypt dri xprint acpi \
symlink ada ruby perforce cjk fat hfs jfs ntfs reiser4 xfs reiserfs \
joystick skins cdda real shout stream a52 wxwindows vlm lirc libcaca remote \
stats lcd unichrome 7zip commercial mozsvg canvas xml2 glut java gcj glitz \
svg avahi ogg vorbis aalib flac gdbm mikmod timidity kdgraphics dlloader exscalibar ipod visualization \
mono cdr nntp cairo djvu nautilus evo pdf xml ladspa soundtouch \
bzip2 udev mad fuse rtsp tiff kdehiddenvisibility usb kipi aiglx 3dfx pulseaudio \
x264 dv lame mp3rtp udev cdr beagle djvu libnotify bzip2 aalib startup-notification jingle \
gsm dbox2 \
opengl qt4 qt3 qt3support gtk sdl png gif nls win32codecs bonobo kickoff"

and here are the local USE flags in my /etc/portage/package.use file:

Code: Select all
sys-data/sabayon-version x86_64
net-misc/openssh -ldap
www-client/mozilla -java
net-wireless/wpa_supplicant madwifi gsm
x11-wm/enlightenment xrandr
www-client/epiphany -dbus
media-gfx/inkscape effects inkjar jabber
kde-base/kdelibs acl -pertty jpeg2k
sys-kernel/sabayon-sources symlink
media-plugins/alsa-plugins libsamplerate pulseaudio
net-dialup/ppp atm dhcp radius
net-print/hplip snmp
x11-base/xorg-x11 intel
app-text/evince -dvi
media-gfx/splashutils mng
media-gfx/gimp mng wmf
media-gfx/digikam -linguas_bn -linguas_eu -linguas_km
dev-libs/boost threads
media-sound/rosegarden -arts
x11-base/xorg-server -ipv6
net-fs/samba acl oav
dev-lang/python tk
media-sound/amarok ifp njb mtp musicbrainz
net-misc/vnc server
kde-base/kopete addbookmarks alias autoreplace connectionstatus contactnotes gadu groupwise highlight history jingle netmeeting nowlistening sametime texteffect translator webpresence winpopup irc yahoo statistics -kdeenablefinal slp
x11-drivers/ati-drivers distribution
<x11-libs/qt-4 -pertty
net-misc/nxnode prebuilt vnc
net-misc/nxclient prebuilt
net-wireless/btsco ao skype
dev-util/subversion -java -apache2
www-client/mozilla-firefox xforms mozbranding filepicker linguas_en_GB -linguas_es_AR -linguas_es_ES -linguas_fy -linguas_fy_NL -linguas_ga -linguas_ga_IE -linguas_gu_IN -linguas_ka -linguas_ku -linguas_nb -linguas_nb_NO -linguas_nn -linguas_nn_NO -pa_IN -linguas_pl -linguas_pt -linguas_pt_BR -linguas_pt_PT -linguas_sv_SE -linguas_zh_CN -linguas_zh_TW
www-client/seamonkey linguas_en_GB -linguas_es_AR -linguas_es_ES -linguas_fy -linguas_fy_NL -linguas_ga -linguas_ga_IE -linguas_gu_IN -linguas_ka -linguas_ku -linguas_nb -linguas_nb_NO -linguas_nn -linguas_nn_NO -pa_IN -linguas_pl -linguas_pt -linguas_pt_BR -linguas_pt_PT -linguas_sv_SE -linguas_zh_CN -linguas_zh_TW
mail-client/mozilla-thunderbird linguas_en_GB -linguas_es_AR -linguas_es_ES -linguas_fy -linguas_fy_NL -linguas_ga -linguas_ga_IE -linguas_gu_IN -linguas_ka -linguas_ku -linguas_nb -linguas_nb_NO -linguas_nn -linguas_nn_NO -pa_IN -linguas_pl -linguas_pt -linguas_pt_BR -linguas_pt_PT -linguas_sv_SE -linguas_zh_CN -linguas_zh_TW
media-video/mplayer x264 dvdnav mp2 openal mmxext radio rtc rar tga tivo zoran cpudetection cddb cdparanoia 3dnow 3dnowext sse sse2 vidix amr bl ftp lirc md5sum pnm
kde-base/kicker -kdehiddenvisibility
net-www/mplayerplug-in gtk quicktime divx gmedia realmedia wmp nls
x11-themes/sabayonlinux-artwork symlink
>=media-sound/soundkonverter-0.2.90-r1 kdeenablefinal lame
app-misc/ddccontrol -gtk -gnome
dev-java/swt cairo
net-p2p/azureus source
kde-base/kdesktop pertty
x11-wm/aquamarine -kdeenablefinal
xfce-base/xfdesktop thunar-vfs
xfce-base/thunar thumbnail
media-tv/mythtv -xvmc
app-office/openoffice -linguas_af -linguas_ar -linguas_bg -linguas_bn -linguas_bs -linguas_ca -linguas_cs -linguas_cy -linguas_da -linguas_el -linguas_et -linguas_fa -linguas_fi -linguas_gu_IN -linguas_he -linguas_hr -linguas_hu -linguas_ja -linguas_km -linguas_ko -linguas_lt -linguas_lv -linguas_mk -linguas_nb -linguas_nn -linguas_pl -linguas_pt -linguas_pt_BR -linguas_rw -linguas_sk -linguas_sl -linguas_sv -linguas_tg -linguas_tr -linguas_vi -linguas_zh_TW sound
net-p2p/ktorrent -linguas_eu -linguas_km -linguas_mk -linguas_nb
net-wireless/wpa_supplicant madwifi
media-video/dvdrip subtitles mplayer fping
sys-fs/ntfs3g suid
dev-scheme/guile deprecated regex
>=x11-libs/qt-4.0 qt3support
net-im/pidgin bonjour console gadu groupwise meanwhile msn prediction qq sasl
net-dns/avahi howl-compat mdnsresponder-compat dbus gdbm gtk mono python qt3 qt4
media-gfx/gimp smp
net-libs/libgadu -ssl
sys-apps/hwdata-gentoo binary-drivers
x11-wm/beryl emerald
app-misc/sabayon-version x86_64_release
games-fps/warsow irc openal
media-libs/openexr -video_cards_nvidia
app-cdr/cdrdao -gnome
app-mobilephone/gnokii -X
app-laptop/pommed -gtk
sys-apps/hal disk-partition dell
sys-apps/pciutils -zlib
app-emulation/virtualbox-bin additions
app-portage/portato etcproposal
x11-apps/fusion-icon qt4
media-gfx/hugin enblend sift
media-video/transcode mjpeg

I am showing you these only for guidance on the global and local USE flags I have used to re-compile the media players. You should definitely not just cut and paste the above into your /etc/make.conf and /etc/portage/package.use. Use them as guidance for the specific media-related USE flags that you may need to add if they are not already present in your files. Notice, for example, that I have the "real" global USE flag.
User avatar
Sagely Hen
Posts: 8090
Joined: Sat Mar 10, 2007 5:40
Location: United Kingdom

Re: matroska playback problems

Postby pedrodh » Thu Feb 14, 2008 13:22

WOW, you're great! Thank you verry much. You done the "homework" for me :P lol. Im now using VLC, its working ok, execpt from some parts in the movie sometimes turns green, like a green area appearing for 3 seconds on the movie, i don't know why that is, but since im going to install 3.4 final and erase the currently 3.4 mini ediction, im comming back to report if it was a bug caused by something missing from mini edition that i needed to have in order to play .mkv correctly. Once again, thank you
Young Hen
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Re: matroska playback problems [Solved]

Postby pedrodh » Tue Feb 19, 2008 13:41

I confirme that with the complete ediction all plays well :) .
Young Hen
Posts: 35
Joined: Tue Feb 12, 2008 17:49
Location: Portugal

Return to Software in General

Who is online

Users browsing this forum: No registered users and 2 guests