Xine VTS Error

Discussions Regarding Software

Moderator: Moderators

Xine VTS Error

Postby nomad » Mon Jan 21, 2008 14:24

Have a problem never seen before on any Linux install, Sabayon or others. So far every DVD successfully played with xine. Recently tried Shoot'em Up and once all the previews successfully played, there is a message about source not available, and so on...Then: 'error opening vtsN=3 domain=2.' Then xine just stop, not quit/exit, just stop. Ogle does the same thing, the previews for other movies will play with no problem, but I guess upon reaching the point where the main feature is next, Ogle just stop, not quit/exit, just stop, but with no messages at all. Did emerge the latest lib-xine, win32codecs and libdvdnav but no joy. Put in another movie and watched it with no problems. Tried Shoot'em Up again but still no good. My machine has a PX-800A and an HP Lightscribe. Both players does the same -- successfully play all the previews, then stop with that vtsN error message.

Anyone has same or similar problems?
nomad
Simple Hen
 
Posts: 86
Joined: Thu Mar 01, 2007 21:42

Re: XINE VTS ERROR

Postby xlnagla » Tue Jan 22, 2008 1:05

Quite curious, that - can you verify that you can play the DVD in another Linux OS? I've seen similar errors to this, but it always was the result of an old or bad codec... see if it works under other Linux OSes.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: XINE VTS ERROR

Postby nomad » Tue Jan 22, 2008 3:06

My mistake...When I said other linux distros, I meant that I had never seen this problem before on my usage of other distros in the past. I could not verify if this DVD/movie will play on other distros or not as I have no other linux machines.
* media-libs/xine-lib
Latest version available: 1.1.9.1-r1
Latest version installed: 1.1.9.1-r1
Size of files: 7,218 kB
Homepage: http://xine.sourceforge.net
Description: Core libraries for Xine movie player
License: GPL-2

* media-libs/libdvdnav
Latest version available: 0.1.10
Latest version installed: 0.1.10
Size of files: 527 kB
Homepage: http://sourceforge.net/projects/dvd/
Description: Library for DVD navigation tools
License: GPL-2

* media-libs/libdvdcss
Latest version available: 1.2.9-r1
Latest version installed: 1.2.9-r1
Size of files: 276 kB
Homepage: http://www.videolan.org/developers/libdvdcss.html
Description: A portable abstraction library for DVD decryption
License: GPL-2

Not sure what else to check.
nomad
Simple Hen
 
Posts: 86
Joined: Thu Mar 01, 2007 21:42

Re: XINE VTS ERROR

Postby xlnagla » Tue Jan 22, 2008 3:49

yeah, that's everything that should matter... if it works on windows, try it there, maybe use a decoder and re-burn the DVD when it's decrypted? (I'm thinking DVDshrink). How new/old is this disk?

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44

Re: XINE VTS ERROR

Postby nomad » Tue Jan 22, 2008 5:52

xlnagla wrote:yeah, that's everything that should matter... if it works on windows, try it there, maybe use a decoder and re-burn the DVD when it's decrypted? (I'm thinking DVDshrink). How new/old is this disk?

~xlnagla
Two days old, basically brand new. I am willing to guess that my XP box will play it just fine. I am just curious about the vts and domain error.
nomad
Simple Hen
 
Posts: 86
Joined: Thu Mar 01, 2007 21:42

Re: Xine VTS Error

Postby wolfden » Tue Jan 22, 2008 7:24

the latest releases have new encryption, not sure how this effects linux or not, but Mr.Woodcock and Saw 4 are all giving the DVD world a headache. When I put in Saw 4, mplayer popped up like normal, but wouldn't play it. I assume there will be an update to something coming along.
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Xine VTS Error

Postby nomad » Tue Jan 22, 2008 8:55

Awrighty...At least I don't feel so bad about this.
nomad
Simple Hen
 
Posts: 86
Joined: Thu Mar 01, 2007 21:42

Re: Xine VTS Error

Postby nomad » Mon Jan 28, 2008 9:55

Another DVD -- 3:10 to Yuma -- that will not play. And neither will ogle. Although this time there is no error message with xine, only that the main viewing window is jerky and images are distorted with colored bars, as if I am viewing a corrupted jpg file. Put in 300 and that play just fine. Looks like the new DVD encryption is working and libdvdcss is not.

:(
nomad
Simple Hen
 
Posts: 86
Joined: Thu Mar 01, 2007 21:42

Re: Xine VTS Error

Postby hexxamillion » Mon Apr 21, 2008 5:09

Does anyone have any update regarding this. I am getting this same error for movie Rendition. It plays flawless during previews then "BAM!" there goes the cool pop up. At first I thought it had to do with my permissions or the mounting.
hexxamillion
Baby Hen
 
Posts: 13
Joined: Fri Apr 11, 2008 6:42

Re: Xine VTS Error

Postby xlnagla » Mon Apr 21, 2008 5:19

so far, the industry's been impenetrable. But give it time, it will come.

~xlnagla
xlnagla
Sagely Hen
 
Posts: 1078
Joined: Mon May 28, 2007 2:44


Return to Software in General

Who is online

Users browsing this forum: No registered users and 4 guests