Problèmes après update xorg-server(1.4.0.90)

Conversations générales au sujet de Sabayon Linux

Moderator: Moderators

Problèmes après update xorg-server(1.4.0.90)

Postby velk » Sun Dec 16, 2007 11:16

Salut,

je poste ici car j ai exposé mon probleme sur le forum anglophone mais aucune réponse a ce jour.
J'ai mis a jour il y a deux jours xorg-server et xorg-x11

apres l update , j ' ai des gros problemes avec mon systeme , sous gnome, le systeme est inutilisable car ne réponds pas au clicks.

Sous kde

- j ai pas assez au bouton droit de la souris sur le bureau ( le menu contextuel apparait puis disparait de suite)
- bug lors d un click sur la barre de titre d un fenetre : elle passe direct en plein ecran
- le simple click a l effet d un double click , quand je clique qq part tout s ouvre en double
- je ne peux pas acceder au bouton droit ou au menu du haut dans firefox

une idée pour me sortir de la ? ca fait deux jours que je tourne en rond a coup de modif de fichier de conf, emerge / unmerge , dans l
etat mon systeme est presque inutilisable et je voudrais si possible eviter la methode hard , c est a dire la reinstall pure et simple.

Merci d avance.
velk
Simple Hen
 
Posts: 73
Joined: Mon Jul 30, 2007 21:28
Location: montpellier - france

Re: Problèmes après update xorg-server(1.4.0.90)

Postby turquoise » Mon Dec 17, 2007 1:37

Je n'ai pas la toute dernière version de xorg-server, mais il me semble que le driver de la souris ne se trouve plus dans le même répertoire dans /dev.

Sinon, quels genre de trucs as-tu essayés?
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!

Re: Problèmes après update xorg-server(1.4.0.90)

Postby velk » Mon Dec 17, 2007 8:31

salut turquoise,

en fait mon probleme de souris est reglé, au départ elle ne fonctionnait plus, puis en reinstallant qq drivers et en modifiant xorg.conf c est ok

le probleme n est pas la souris car elle fonctionne mais la visibilité des menus

on dirait un bug (de linkage?) entre les executables utilisant xorg

j ai donc pensé a un revdep-rebuild mais il ne me donne rien de concluant.

j ai aussi reemerger qt, gtk+ , kdelilbs, kdesktop,konqueror.. compiz ... mais tjrs le meme probleme
velk
Simple Hen
 
Posts: 73
Joined: Mon Jul 30, 2007 21:28
Location: montpellier - france

Re: Problèmes après update xorg-server(1.4.0.90)

Postby turquoise » Wed Dec 19, 2007 1:15

Je ne peux malheureusement pas vérifier chez-moi (mon pc avec Sabayon est toujours à la casse), mais ça me fait penser à certains problèmes rencontrés sous BSD où il y avait des problèmes avec les nouvelles versions de xorg-server et nvidia. J'ai aussi lu des trucs similaires sur le forum de Gentoo concernant certaines versions du kernel. Jamais tout à fait comme le problème que tu décris toutefois. S'il n'y a pas d'autre solution trouvée entre-temps, tu peux essayer de désinstaller le driver nvidia et le remplacer par une version plus ancienne, genre 9631 ou 9742 pour voir si ce ne serait pas lié au dernier driver nvidia. Sous BSD, fallait désinstaller le driver aussi et ensuite recompiler xorg-server avant de réinstaller le driver nvidia. Je doute un peu de la pertinence de cette solution, mais comme Gentoo a quand même des liens de parenté avec BSD...
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!

Re: Problèmes après update xorg-server(1.4.0.90)

Postby velk » Wed Dec 19, 2007 18:59

j ai essayé de re emerge les drivers nvidia mais toujours pareil

les vieilles versions, je risque d avoir des problemes avec compiz, mais si j ai tjrs pas trouvé entre temps j essayerais ..

quand meme bien blazé de ce probleme car je sens de plus en plus que je vais droit vers la reinstall vu le peu de pistes que
j ai en ce moment :cry:

edit : apres un test sans compiz et avec le driver "nv" le probleme est grosso modo le meme.
velk
Simple Hen
 
Posts: 73
Joined: Mon Jul 30, 2007 21:28
Location: montpellier - france

Re: Problèmes après update xorg-server(1.4.0.90)

Postby velk » Sat Dec 29, 2007 11:31

toujours pas trouvé de solution.

J ai eu un peu plus d aide sur le forum de gentoo mais j ai toujours pas trouvé la cause du probleme.

dommage planter son systeme durable suite a une update a priori safe c est toujours une grosse galère.

esperons que la communauté sabayon grossisse un peu plus car c est toujours frustant aussi de ne pas pouvoir
obtenir de support (meme payant )
velk
Simple Hen
 
Posts: 73
Joined: Mon Jul 30, 2007 21:28
Location: montpellier - france


Return to French

Who is online

Users browsing this forum: No registered users and 2 guests

cron