Ma la mia gentoo ha la glibc nptl-enabled?!?!?

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

Ma la mia gentoo ha la glibc nptl-enabled?!?!?

Postby piccolotux » Wed Sep 06, 2006 15:58

Mi rivolgo direttamente a lnxnay..domanda tecnica.
Premetto che ho la RR4 3.0b con un bel pò di aggiornamenti.
La risposta al quesito in oggetto sembrava scontata usando
Code: Select all
equery uses glibc
che riporta appunto:
Code: Select all
[ Searching for packages matching glibc... ]
[ Colour Code : set unset ]
[ Legend        : Left column  (U) - USE flags from make.conf  ]
[                  : Right column (I) - USE flags packages was installed with ]
[ Found these USE variables for sys-libs/glibc-2.3.6-r99 ]
 U I
 - - build            : !!internal use only!! DO NOT SET THIS FLAG YOURSELF!, used for creating build images and the first half of bootstrapping.
 - - erandom          : Enable erandom/frandom support in glibc for ssp
 - - glibc-compat20   : Enable the glibc-compat addon.
 - - glibc-omitfp     : Configure glibc with --enable-omitfp which lets the build system determine when it is safe to use -fomit-frame-pointer
 - - hardened         : activate default security enhancements for toolchain (gcc, glibc, binutils)
 - - linuxthreads-tls : Configure the linuxthreads glibc with --with-__thread if supported by your system.  --with-tls is always enabled if supported and is NOT controlled by this switch.  So the glibc built will always support TLS binaries.  This toggle chooses whether or not glibc itself uses TLS.  If you're concerned about backwards compatibility with old binaries, leave this off.
 - - multilib         : On 64bit systems, if you want to be able to compile 32bit and 64bit binaries
 + + nls              : Adds Native Language Support (using gettext - GNU locale utilities)
 - - nomalloccheck    : default to not performing some sanity checks that prevent and detect data corruption. this removes the small overhead introduced by the check.
 + + nptl             : Enable support for Native POSIX Threads Library, the new threading module (requires linux-2.6 or better usually)
 + + nptlonly         : Disables building the linuxthreads fallback in glibc ebuilds that support building both linuxthreads and nptl.
 - - pic              : Build Position Independent Code.  Do not utilize this flag unless you know what you're doing.
 - - profile          : Adds profile support to builds of packages (will likely vary from ebuild to ebuild in support)
 - - selinux          : !!internal use only!! Security Enhanced Linux support, this must be set by the selinux profile or breakage will occur
 - - userlocales      : build only the locales specified in /etc/

Ma se batto: /lib/
questo è quanto ottengo:
Code: Select all
GNU C Library stable release version 2.3.6, by Roland McGrath et al.
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
Compiled by GNU CC version 3.4.4 (Gentoo 3.4.4-r1, ssp-3.4.4-1.0, pie-8.7.8).
Compiled on a Linux 2.6.11 system on 2006-01-03.
Available extensions:
        GNU libio by Per Bothner
        crypt add-on version 2.1 by Michael Glad and others
        linuxthreads-0.10 by Xavier Leroy
        The C stubs add-on version 2.1.2.
        GNU Libidn by Simon Josefsson
        libthread_db work sponsored by Alpha Processor Inc
        NIS(YP)/NIS+ NSS modules 0.19 by Thorsten Kukuk
For bug reporting instructions, please see:

Insomma nessuna traccia di NPTL...
Young Hen
Posts: 34
Joined: Thu Mar 23, 2006 21:42
Location: Italy

Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 4 guests