[RISOLTO] RR4 3.0b e Xgl...ma non è ancora finita

Tutto ciò che è pertinente a Sabayon Linux, indipendentemente dall'architettura e dall'ambiente grafico

Moderator: Moderators

[RISOLTO] RR4 3.0b e Xgl...ma non è ancora finita

Postby piccolotux » Mon Sep 04, 2006 14:07

Ciao a tutti mesi fa ho avuto occasione di installare la summenzionata distro. Veramente fantastica anche se non riuscivo a far partire Xgl.
La più recente versione in modalità live mi da' la possibilità di utilizzare Xgl e non mi raccapezzo perché io non ci sia mai riuscito. Al momento ho installato sul mio portatile con ati 9600 gli ultimissimi pacchetti di Xgl e compiz presi dall'overlay portage-xgl. Nonostante Xgl mi parta bene compiz fa parecchio i capricci.
In particolare questo è l'errore che mi assilla:
LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ DISPLAY=:1 compiz gconf
compiz: error while loading shared libraries: libGL.so.1: cannot handle TLS data
Ho letto howto e forum vari, ricompilato tanto etc ma al momento non ne vengo a capo.
Idee?
Lorenzo


Ho risolto anche se sono andato molto per tentativi
In buona sostanza tutto dipendeva dalle USE FLAGS di compilazione di mesa. Ho dovuto compilarlo con la USE "-nptl".
Cosa strana. Ora tutti i pacchetti ( compiz , cgwd etc ) linkano correttamente a mesa e funzionano egregiamente.
Fra l'altro non ho neanche bisogno di premettere alcun "LD_LIBRARY_PATH" davanti a compiz per farlo funzionare!
Ora sto cercando di avviarlo con gdm ho questo problema:
Code: Select all
GDM: Xserver not found: Xgl :1 :1 -ac -accel glx:pbuffer -accel xv:pbuffer -fp /usr/share/fonts/misc,/usr/share/fonts/Type1,/usr/share/fonts/TTF,/usr/share/fonts/75dpi,/usr/share/fonts/100dpi,/usr/share/fonts/corefonts,/usr/share/fonts/freefonts,/usr/share/fonts/ttf-bitstream-vera,/usr/local/share/fonts -auth /var/gdm/:1.Xauth -nolisten tcp vt8
Error: Command could not be executed!
Please install the X server or correct GDM configuration and restart GDM.

Lumi?
Last edited by piccolotux on Thu Sep 07, 2006 13:14, edited 1 time in total.
piccolotux
Young Hen
 
Posts: 34
Joined: Thu Mar 23, 2006 21:42
Location: Italy

Postby lxnay » Mon Sep 04, 2006 16:53

ciao piccolotux, puoi provare a bootare la live con:
Code: Select all
gentoo xgl xdriver=radeon opengl=xorg-x11

e farmi sapere se ti funziona? :)
Image
Join us on IRC (chat.freenode.net #sabayon or WebChat)
Submit bugs to our Bug Tracker
Follow me on Twitter
Add me on Facebook
Add me on Google+
lxnay
Land Owner
 
Posts: 3595
Joined: Thu Oct 13, 2005 23:16
Location: Italy

Postby piccolotux » Tue Sep 05, 2006 8:52

Ieri sera ho provato a dare i comandi di boot che mi hai indicato utilizzando la RC1 ( la RC2 la devo ancora scaricare ) ma il server grafico non si avvia...
Quale ordine hai utilizzato er compilare Xgl e compiz?
Ciao e grazie ancora
piccolotux
Young Hen
 
Posts: 34
Joined: Thu Mar 23, 2006 21:42
Location: Italy

Re: RR4 3.0b e Xgl

Postby Dark_MaGe » Tue Sep 05, 2006 9:52

piccolotux wrote:Ciao a tutti mesi fa ho avuto occasione di installare la summenzionata distro. Veramente fantastica anche se non riuscivo a far partire Xgl.
La più recente versione in modalità live mi da' la possibilità di utilizzare Xgl e non mi raccapezzo perché io non ci sia mai riuscito. Al momento ho installato sul mio portatile con ati 9600 gli ultimissimi pacchetti di Xgl e compiz presi dall'overlay portage-xgl. Nonostante Xgl mi parta bene compiz fa parecchio i capricci.
In particolare questo è l'errore che mi assilla:
LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ DISPLAY=:1 compiz gconf
compiz: error while loading shared libraries: libGL.so.1: cannot handle TLS data
Ho letto howto e forum vari, ricompilato tanto etc ma al momento non ne vengo a capo.
Idee?
Lorenzo


Hai provato ad aggiornare le librerie MESA?
Dark_MaGe
Your Farmer
 
Posts: 1699
Joined: Thu Jun 29, 2006 8:19
Location: Catania Italy

Re: RR4 3.0b e Xgl

Postby piccolotux » Tue Sep 05, 2006 10:19

Hai provato ad aggiornare le librerie MESA?

Beh si certamente...ho fatto molte ricerche. Mesa è compilata con la USE nptl...glibc è nptl...
Bah non so!
piccolotux
Young Hen
 
Posts: 34
Joined: Thu Mar 23, 2006 21:42
Location: Italy

Postby Dark_MaGe » Tue Sep 05, 2006 16:21

visto che stai usando la rc1 prova
Code: Select all
gentoo xgl opengl=ati
Dark_MaGe
Your Farmer
 
Posts: 1699
Joined: Thu Jun 29, 2006 8:19
Location: Catania Italy

Postby piccolotux » Tue Sep 05, 2006 16:33

Dopo lunghe ricerche sono arrivato a qualcosa di meglio...
Code: Select all
LD_ASSUME_KERNEL=2.4.1 LD_LIBRARY_PATH=/usr/lib/opengl/xorg-x11/lib/ DISPLAY=:1 compiz

Che però mi da come risultato:
Code: Select all
compiz: GLX_EXT_texture_from_pixmap is missing
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :1

Sono un pò più avanti...
piccolotux
Young Hen
 
Posts: 34
Joined: Thu Mar 23, 2006 21:42
Location: Italy


Return to Sabayon Linux Discussioni Generali

Who is online

Users browsing this forum: No registered users and 0 guests