mouse&synaptic touchpad don't works after install ATIdrivers

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Post Reply
stetti8x
Baby Hen
Posts: 8
Joined: Wed Mar 14, 2007 16:12

mouse&synaptic touchpad don't works after install ATIdrivers

Post by stetti8x » Fri Nov 09, 2007 2:06

come da titolo:
dopo aver installato (con successo) gli ultimi driver ati seguendo quanto scritto qui
http://wiki.sabayonlinux.org/index.php? ... TI_Drivers
non sono più in grado di muovere il puntatore attraverso il mouse e/o touchpad.(la tastiera funziona)
Ho fatto la mia copia di backup di xorg.conf ma anche ripristinando l'ultima funzionante ho lo stesso problema. Cosa può essere? Grazie per l'aiuto
ps:ho sabayon3.4mini

after i've succesfully installed latest ati drivers according to http://wiki.sabayonlinux.org/index.php? ... TI_Drivers my synaptic touchpad and usb mouse don't works anymore. i can only use keyboard. I've done a backup of xorg.conf but even restore a past-working-one the problem still remaining....who can help me?thanks a lot

stetti8x
Baby Hen
Posts: 8
Joined: Wed Mar 14, 2007 16:12

Re: mouse&synaptic touchpad don't works after install ATIdrivers

Post by stetti8x » Wed Nov 14, 2007 14:40

up

stetti8x
Baby Hen
Posts: 8
Joined: Wed Mar 14, 2007 16:12

Re: mouse&synaptic touchpad don't works after install ATIdrivers

Post by stetti8x » Mon Nov 19, 2007 19:51

here my last working xorg.conf

Code: Select all

Section "Files"
    FontPath	"/usr/share/fonts/misc/"
    FontPath	"/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath	"/usr/share/fonts/75dpi/"
    FontPath	"/usr/share/fonts/100dpi/"
    FontPath 	"/usr/share/fonts/corefonts"
EndSection
Section "Module"
    Load	"dbe"
    Load	"i2c"
    Load	"glx"
    Load	"ddc"
    Load	"type1"
    Load	"freetype"
    Load	"extmod"
    Load	"synaptics"
    Load	"vbe"
   Load        "dri"
EndSection
Section "ServerFlags"
     Option 	"AllowMouseOpenFail" "true"
EndSection
Section "InputDevice"
    Identifier		"Synaptics1"
    Driver		"synaptics"
    Option		"SendCoreEvents"	"true"
    Option		"Device"		"/dev/psaux"
    Option		"Protocol"		"auto-dev"
    Option		"HorizScrollDelta"	"0"
    Option		"SHMConfig"		"on"
EndSection
Section "InputDevice"
    Identifier	"Keyboard1"
    Driver	"kbd"
    Option	"AutoRepeat"	"500 5"
    Option      "XkbModel"	"pc105"
    Option	"XkbLayout"	"it"
    Option      "XkbRules"      "xorg"
EndSection
Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom1"
  Option        "Device"        "/dev/wacom"          # Change to 
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection
Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom2"
  Option        "Device"        "/dev/wacom"          # Change to 
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection
Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom3"
  Option        "Device"        "/dev/wacom"          # Change to 
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection
Section "InputDevice"
    Identifier	"Mouse1"
    Driver	"mouse"
    Option	"Device"	"/dev/psaux"
    Option	"Protocol"	"ImPS/2"
    Option	"ZAxisMapping"	"4 5"
EndSection
Section "InputDevice"
    Identifier	"Mouse2"
    Driver	"mouse"
    Option	"Protocol"	"ImPS/2"
    Option	"Device"	"/dev/input/mice"
    Option 	"ZAxisMapping" "4 5"
EndSection
Section "Monitor"
    Identifier	"Generic Monitor"
    VertRefresh 43 - 60
    HorizSync	28 - 80
EndSection
Section "Device"
    Identifier  "VESA"
    Driver      "fglrx" # do not remove vesa
EndSection
Section "Screen"
    Identifier	"Screen 1"
    Device	"VESA"
    Monitor	"Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
        Depth		8
        ViewPort	0 0
    EndSubsection
    SubSection "Display"
        Depth           16
        ViewPort        0 0
    EndSubsection
    SubSection "Display"
        Depth           24
        ViewPort        0 0
    EndSubsection
EndSection
Section "ServerLayout"
    Identifier	"Main Layout"
    Screen 0 	"Screen 1"
    InputDevice	"Mouse1" "CorePointer"
    InputDevice	"Mouse2" "SendCoreEvents"
    InputDevice "Synaptics1" "SendCoreEvents"
    InputDevice "Keyboard1" "CoreKeyboard"
EndSection
Section "DRI"
    Mode 0666
EndSection
Section "Extensions"
EndSection

stetti8x
Baby Hen
Posts: 8
Joined: Wed Mar 14, 2007 16:12

Re: mouse&synaptic touchpad don't works after install ATIdrivers

Post by stetti8x » Wed Nov 21, 2007 23:11

i'm going UP UP UP...

Post Reply