Compiz-Fusion settings won't run

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Re: Compiz-Fusion settings won't run

Postby Mr.Woo » Sun Nov 18, 2007 23:55

I see now. I umerged just musicbrainz
Code: Select all
emerge -C musicbrainz


What I needed to do was
Code: Select all
emerge -C python-musicbrainz2


So now that's not a problem. but when i type python-updater -i I get this now
Code: Select all
These are the packages that would be merged, in order:

Calculating dependencies \
emerge: there are no ebuilds to satisfy "dev-python/gst-python:0"


do I really want to umerge gst-python? and what's that :0 thing doing on the end there?
Mr.Woo
Baby Hen
 
Posts: 11
Joined: Sat Jan 06, 2007 21:18

Re: Compiz-Fusion settings won't run

Postby freeallbadgers » Mon Nov 19, 2007 0:03

    dev-python/gst-python
    Available versions: (0.10) (~)0.10.8 (~)0.10.8-r1
    {doc}
    Installed versions: 0.10.6(0.10)(06:48:55 PM 09/05/2007)(-doc)
    Homepage: http://gstreamer.freedesktop.org
    Description: A Python Interface to GStreamer

Either upgrade to latest version or if you dont want/need it unmerge it.

TIP:

Code: Select all
emerge eix && eix-sync && update-eix


use eix to search for packages you are having trouble with, then decide if they are important, (use google/gentoo/sabayon wiki)

Code: Select all
eix <packagename>


this will report back a whole lot of useful info

eix its a lot faster than using emerge -s
“I just finished compiling glibc and now it says there is a new update available? Arrgh! It never ends!!”
freeallbadgers
Growing Hen
 
Posts: 181
Joined: Sun Mar 11, 2007 8:12
Location: Glasgow, UK.

Re: Compiz-Fusion settings won't run

Postby Mr.Woo » Mon Nov 19, 2007 0:29

sorry to keep going back and forth like this. I'm learning a lot and I really appreciate you teaching me how to fish instead of just giving me the fish. But i don't want to unmerge this package. So how do i unmask it

Code: Select all
Calculating dependencies -
!!! All ebuilds that could satisfy "dev-util/portatosourceview:0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/portatosourceview-2.16.0-r1 (masked by: package.mask)
/usr/portage/profiles/package.mask:
# Markus Ullmann <jokey@gentoo.org> (20 Oct 2007)
# dependency unneeded now, merged upstream

- dev-util/portatosourceview-2.16.1 (masked by: package.mask)
- dev-util/portatosourceview-2.16.1-r1 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.


keep in mind I can't launch portato right now.
Mr.Woo
Baby Hen
 
Posts: 11
Joined: Sat Jan 06, 2007 21:18

Re: Compiz-Fusion settings won't run

Postby freeallbadgers » Mon Nov 19, 2007 0:43

afaik, the latest portato doesnt use that package anymore, so just unmerge it and get the latest portato after you've cleared the python updater

All the info you need to resolve these issues is in the guide i posted last night

http://wiki.sabayonlinux.org/index.php?title=HOWTO:_The_Complete_Portage_Guide

The gentoo handbook is also an invaluable resource
http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2, it may take some time to get through all this(dont be too daunted), you will learn a lot about the portage system. Pay close attention to the errors, it usually tells you exactly what to do, just read it and refer back to the handbook.

e.g. your latest error was about a masked package, so go to the appropriate section of the handbook and it will tell you exactly7 how to resolve the issue. If you are completely stuck you are always welcome to come to the sabayon irc room (chat link on the main site), there are a lot of very knowledgeable and helpful people in there. Just gotta be patient in waiting for a response, depending on the time of day.

Good Luck

EDIT: in fact just emerge the latest version of portato and that should clear that dependency issue you're currently having, then re-run python-updater
“I just finished compiling glibc and now it says there is a new update available? Arrgh! It never ends!!”
freeallbadgers
Growing Hen
 
Posts: 181
Joined: Sun Mar 11, 2007 8:12
Location: Glasgow, UK.

Re: Compiz-Fusion settings won't run

Postby Mr.Woo » Mon Nov 19, 2007 1:23

So I unmerged it. now when i run python-updater -i I get this
Code: Select all
[ebuild  N    ] media-libs/ilmbase-1.0.1  453 kB
[blocks B     ] x11-drivers/xf86-video-via (is blocking x11-drivers/xf86-video-o
penchrome-9999)
[blocks B     ] <sys-fs/udev-114 (is blocking media-libs/libgphoto2-2.4.0-r1, me
dia-gfx/sane-backends-1.0.18-r5)
[blocks B     ] <sys-fs/udev-115-r1 (is blocking sys-fs/device-mapper-1.02.22-r5
)
[blocks B     ] x11-misc/xkbdata (is blocking x11-misc/xkeyboard-config-1.1)
[blocks B     ] >=sys-apps/util-linux-2.13_pre (is blocking sys-process/scheduti
ls-1.5.0)
[blocks B     ] kde-base/ksync (is blocking kde-base/kdelibs-3.5.8-r1)
[blocks B     ] <media-libs/openexr-1.5.0 (is blocking media-libs/ilmbase-1.0.1)
[blocks B     ] <sys-fs/device-mapper-1.02.19-r1 (is blocking sys-fs/udev-117)
[blocks B     ] <dev-libs/boost-1.34.0 (is blocking dev-util/boost-build-1.34.1)
[blocks B     ] sys-apps/setarch (is blocking sys-apps/util-linux-2.13-r2)
[blocks B     ] x11-misc/xkeyboard-config (is blocking x11-misc/xkbdata-1.0.1)
[blocks B     ] x11-drivers/ati-drivers (is blocking x11-base/xorg-server-1.4-r2                                                    )
[blocks B     ] <sys-apps/baselayout-2.0.0_rc (is blocking sys-apps/makedev-3.23                                                    .1)
[blocks B     ] sys-process/schedutils (is blocking sys-apps/util-linux-2.13-r2)


Do I really wanna unmerge all of those? Is it common to need to go through all this unmerging?
Mr.Woo
Baby Hen
 
Posts: 11
Joined: Sat Jan 06, 2007 21:18

Re: Compiz-Fusion settings won't run

Postby freeallbadgers » Mon Nov 19, 2007 1:32

no, you dont wanna unmerge them all. have you read what i've posted before?

eg

[blocks B ] x11-drivers/xf86-video-via (is blocking x11-drivers/xf86-video-o
penchrome-9999)

do you have an openchrome or via video card?, if not unmerge them

[blocks B ] <sys-fs/udev-114 (is blocking media-libs/libgphoto2-2.4.0-r1, me
dia-gfx/sane-backends-1.0.18-r5) , that version of udev is old, upgrade.

ksync is kde's pda syncing program, do you need it etc etc
“I just finished compiling glibc and now it says there is a new update available? Arrgh! It never ends!!”
freeallbadgers
Growing Hen
 
Posts: 181
Joined: Sun Mar 11, 2007 8:12
Location: Glasgow, UK.

Previous

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 1 guest

cron