compiz-fusion problem

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

compiz-fusion problem

Postby zman » Mon Oct 29, 2007 19:46

I had compiz-fusion run just fine until i installed and upgraded some packages on my system. Now compiz-fusion would not start at all. I tried few things that i found on the forums but it's not working for me. When i run "/usr/bin/compiz" it tells me "/usr/bin/compiz (core) - Fatal: No composite extension"
I made sure that i have the right settings under xorg.conf. One thing is when i run Acceleration Manager i don't see and option for Desktop Acceleration i used to be able to select AIGLX or XGL. Olso when i run compiz-start it shows that there is a conflict in "/usr/kde/3.5/lib/plugins/styles/" Plugin uses incompatible Qt library and then there is more like "/usr/kde/3.5/lib/plugins/styles/" Plugin uses incompatible Qt library and etc.. I did try emerge qt with opengl flag and that did not do anything.

Sorry if i did not give you enugh information let me know if you need anything else
I'm new to linux and i'm trying to learn all this.

Thank you
Baby Hen
Posts: 13
Joined: Mon Sep 24, 2007 18:06

Re: compiz-fusion problem

Postby wolfden » Mon Oct 29, 2007 22:36

I imagine you update python, you have to rebuild packages now

python-updater -i
Posts: 9051
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: compiz-fusion problem

Postby zman » Mon Oct 29, 2007 23:07

Thanks for the reply

i did run python-updater -i and what i get when i run this is one of the packages have been masked.
I did look on gentoo website and found a command to fix this but its not working here is the command that i ran
echo "=dev-util/portatosourceview-2.16.1" >> /etc/portage/package.keywords
How do i unmask this?

Here is the exact message after running python-updater -i

These are the packages that would be merged, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy "dev-util/portatosourceview:0" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-util/portatosourceview-2.16.1 (masked by: package.mask)
# Markus Ullmann <[email protected]> (20 Oct 2007)
# dependency unneeded now, merged upstream

- dev-util/portatosourceview-2.16.0-r1 (masked by: package.mask)
- dev-util/portatosourceview-2.16.1-r1 (masked by: package.mask)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
Baby Hen
Posts: 13
Joined: Mon Sep 24, 2007 18:06

Re: compiz-fusion problem

Postby absolofdoom » Tue Oct 30, 2007 1:20

Apparently, this is a common problem. I had it too. I reinstalled, so I cannot vouch for it, but I think people have had success manually upgrading the packages that are listed by the python-upgrader program. I think this might help. >>>>>>>>>>>>>
Somebody once said: "If you've got it you've got it, if you don't you don't." That statement was terribly flawed.
Simple Hen
Posts: 40
Joined: Thu Aug 16, 2007 3:20

package.mask file

Postby linuxdevil » Tue Oct 30, 2007 1:26

Try editing your /usr/portage/profiles/package.mask file, and removing the line with that atom. You can also do this:
Code: Select all
emerge --sync

and it might help (but it will take a while).
Baby Hen
Posts: 14
Joined: Mon Sep 03, 2007 19:36
Location: Planet Ruby!!!

Re: compiz-fusion problem

Postby zman » Tue Oct 30, 2007 1:27

Thanks for that input i think I'm at that point where i'm thinking about re-installing
Baby Hen
Posts: 13
Joined: Mon Sep 24, 2007 18:06

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 3 guests