CD Rom drive ignored during boot-up

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

CD Rom drive ignored during boot-up

Postby Klevi » Sun Oct 28, 2007 15:53

Hello, new to the forum, but i've been using Sabayon for awhile. I have an IBM Thinkpad R30, and when I try to boot Sabayon Mini Edition 3.3 or 3.4 I get an error that relates to my cd drive (I cant remember exactly what it says right now) but in a nutshell the error that comes up "says" that my cd drive isnt responding then, IRQ 15 gets disabled, after my cd drive is marked unreadable. Then Sabayon tries to find a bootable medium and it cannot. "/dev/sr0 doesnt exsist" Is there perhaps a way of booting from another location from the live CD or is there a way of getting my CD drive to work correctly?
Last edited by Klevi on Mon Oct 29, 2007 21:34, edited 1 time in total.
Klevi
Baby Hen
 
Posts: 2
Joined: Sun Oct 28, 2007 15:47

Re: CD Rom drive ignored during boot-up

Postby Klevi » Mon Oct 29, 2007 18:04

Yes, Ive previously used Kubuntu 6 and 7 before, both booted successfully. Someone suggested i try booting from an external CD drive, and I have the error offhand now from the boot verbose if it helps and I apologze for not using Pastebin.

<boot string>

[ibm_acpi] ec object not found
irq 15: nobody cared try booting with the irqpoll option
handlers:
[<c056c45f>]
Disabling IRQ #15
ata2.00: Exception emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00 cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
ata2.00: Exception emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00 cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
ata2.00: Exception emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00 cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in
ata2.00: Exception emask 0x0 SAct 0x0 SErr 0x0 action 0x2 frozen
ata2.00 cmd a0/00:00:00:00:20/00:00:00:00:00/a0 tag 0 cdb 0x12 data 36 in

(((Then the system attempts to boot as it normally would)))

>>Activating Mdev
>>Loading union fs modules
>>Mounting ramdisk to /memory for unionfs support...
>>Attempting to mount media:- /dev/sda
>>Attempting to mount media:- /dev/sda1
>>Attempting to mount media:- /dev/sda2
>>Attempting to mount media:- /dev/sda5
>> No bootable medium found. Waiting for new devices
>>Attempting to mount media:- /dev/sda
>>Attempting to mount media:- /dev/sda1
>>Attempting to mount media:- /dev/sda2
>>Attempting to mount media:- /dev/sda5
umount: Couldn't umount /newroot: Invalid Arguement
Could not find CD to boot something else needed
>>Determining Root device...
The root block device is unspecified or not detected.

<end boot string>

What can I do here? If anything, Help is appreciated. =)
Klevi
Baby Hen
 
Posts: 2
Joined: Sun Oct 28, 2007 15:47


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests