Borderless Windows when running Compiz

Compiz, KDE, Gnome, Fluxbox, etc...

Moderator: Moderators

Borderless Windows when running Compiz

Postby Lamo » Sat Oct 27, 2007 4:34

So I believe I have a driver issue of some kind. When I run compiz-start i get this error:

Code: Select all
XGL detected
Using KDE decorator
Starting Compiz with: --replace ccp --sm-disable
compiz (core) - Fatal: No GLXFBConfig for default depth, this isn't going to work.
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0


and when i run glxinfo | grep -i direct I get:

Code: Select all
[direct rendering: No
OpenGL renderer string: Mesa GLX Indirect


I have a Dell Inspiron 6400 with a Nvidia GeForce Go 7300. The nvidia drivers I have installed are 100.14.23-r10
and my xorg looks like this:

Code: Select all
Section "Files"


    #FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath    "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/corefonts"

EndSection

# **********************************************************************
# Module section -- this is an optional section which is used to specify
# which run-time loadable modules to load when the X server starts up.
# **********************************************************************

Section "Module"

    Load   "dbe"
    Load   "i2c"
    Load   "glx"
    Load   "ddc"
    Load   "type1"
    Load   "freetype"
    Load   "extmod"
    Load   "synaptics"
    Load   "vbe"
#   Load        "dri"

EndSection


# **********************************************************************
# Server flags section.  This contains various server-wide Options.
# **********************************************************************

Section "ServerFlags"

     Option    "AllowMouseOpenFail" "true"

EndSection

# **********************************************************************
# Input devices
# **********************************************************************

# **********************************************************************
# Core keyboard's InputDevice section
# **********************************************************************

Section "InputDevice"
    Identifier      "Synaptics1"
    Driver      "synaptics"
    Option      "SendCoreEvents"   "true"
    Option      "Device"      "/dev/psaux"
    Option      "Protocol"      "auto-dev"
    Option      "HorizScrollDelta"   "0"
    Option      "SHMConfig"      "on"
    # For ALPS/MacBook TouchPads
    #Option      "MaxSpeed"      "0.7"
    #Option      "MinSpeed"      "0.18"
    #Option      "AccelFactor"      "0.08"
    #Option      "TopEdge"      "120"
    #Option      "LeftEdge"      "120"
    #Option      "BottomEdge"      "830"
    #Option      "RightEdge"      "650"
    #Option      "FingerLow"      "25"
    #Option      "FingerHigh"      "30"
    # MacBook touchpad
    #Option      "MaxTapTime"      "180"
    #Option      "MaxTapMove"      "220"
    #Option      "MaxDoubleTapTime"   "180"
    #Option      "VertScrollDelta"   "20"
    #Option      "HorizScrollDelta"   "50"
    #Option      "TapButton2"      "3"
    #Option      "TapButton3"      "2"
    #Option      "VertTwoFingerScroll"   "1"

    # Do you keep moving the mouse while typing? Try this trick.
    #synclient TouchpadOff=1 disable your synaptics touchpad
    #synclient TouchpadOff=0 enable your synaptics touchpad
EndSection


Section "InputDevice"

    Identifier   "Keyboard1"
    Driver   "kbd"
   
    Option   "AutoRepeat"   "500 5"
    Option      "XkbModel"   "pc105"
    Option   "XkbLayout"   "us"
    Option      "XkbRules"      "xorg"
    # Macintosh keyboard
    #Option   "XkbOptions"   "lv3:rwin_switch"

EndSection


Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom1"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "stylus"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom2"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "eraser"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver        "wacom"
  Identifier    "wacom3"
  Option        "Device"        "/dev/wacom"          # Change to
                                                      # /dev/input/event
                                                      # for USB
  Option        "Type"          "cursor"
  Option        "ForceDevice"   "ISDV4"               # Tablet PC ONLY
EndSection


# **********************************************************************
# Core Pointer's InputDevice section
# **********************************************************************

Section "InputDevice"

# Identifier and driver

    Identifier   "Mouse1"
    Driver   "mouse"

    Option   "Device"   "/dev/psaux"
    Option   "Protocol"   "ImPS/2"
    Option   "ZAxisMapping"   "4 5"
     
EndSection

Section "InputDevice"
    Identifier   "Mouse2"
    Driver   "mouse"
    Option   "Protocol"   "ImPS/2"
    Option   "Device"   "/dev/input/mice"
    Option    "ZAxisMapping" "4 5"
EndSection


# **********************************************************************
# Monitor section
# **********************************************************************

# Any number of monitor sections may be present

Section "Monitor"

    Identifier   "Generic Monitor"
    #Option      "DPMS"

    VertRefresh 43 - 60
    HorizSync   28 - 80
   
EndSection

# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present

Section "Device"
    Identifier  "VESA"
    Driver      "nvidia" # do not remove vesa
    #Option "RenderAccel" "on"
    #Option "XAANoOffscreenPixmaps"
    #Option "BusType" "PCI"
    #Option "ColorTiling" "on"
    #Option "EnablePageFlip" "on"
EndSection


# **********************************************************************
# Screen sections.
# **********************************************************************

Section "Screen"

# The Identifier, Device and Monitor lines must be present

    Identifier   "Screen 1"
    Device   "VESA"
    Monitor   "Generic Monitor"
    Option "AddARGBGLXVisuals" "true"

# The favoured Depth and/or Bpp may be specified here

    DefaultDepth 24

    SubSection "Display"
        Depth      8
        ViewPort   0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           16
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection

    SubSection "Display"
        Depth           24
        ViewPort        0 0
        #Modes      "1024x768" "800x600" "640x480"
    EndSubsection


EndSection


Section "ServerLayout"
# The Identifier line must be present

    Identifier   "Main Layout"
    Screen 0    "Screen 1"
    InputDevice   "Mouse1" "CorePointer"
    InputDevice   "Mouse2" "SendCoreEvents"
    InputDevice "Synaptics1" "SendCoreEvents"
    #InputDevice "wacom1" "SendCoreEvents"
    #InputDevice "wacom2" "SendCoreEvents"
    #InputDevice "wacom3" "SendCoreEvents"
    InputDevice "Keyboard1" "CoreKeyboard"

EndSection

Section "DRI"
    Mode 0666
EndSection

Section "Extensions"
   Option "Composite" "Enable"
EndSection



Thanks
Lamo
Young Hen
 
Posts: 29
Joined: Thu Aug 09, 2007 4:17

Re: Borderless Windows when running Compiz

Postby wolfden » Sat Oct 27, 2007 5:04

have you run the accel-manager and select AIGLX than restarted X ????
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Borderless Windows when running Compiz

Postby Lamo » Sat Oct 27, 2007 5:49

There is no option for it. There is only Standard Desktop Experience.
Dell Inspiron 6400
Intel Core 2 Duo 1.86
1 gig ram
nVidia GeForce Go 7300 256MB
Lamo
Young Hen
 
Posts: 29
Joined: Thu Aug 09, 2007 4:17

Re: Borderless Windows when running Compiz

Postby wolfden » Sat Oct 27, 2007 6:16

your xorg looks ok

according to
http://gentoo-wiki.com/HARDWARE_Video_C ... _Under_XGL

nVidia Quadro NVS 110M / GeForce Go 7300 (with nvidia-drivers-1.0.8762-r1, rather slow due to excessive cpu usage on most operations like scrolling, moving windows, etc)
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Borderless Windows when running Compiz

Postby Lamo » Sat Oct 27, 2007 6:30

Well I had it working and running fine for two months until I updated python. Maybe I should upgrade using the 3.4f dvd? I'm running 3.4e.
Dell Inspiron 6400
Intel Core 2 Duo 1.86
1 gig ram
nVidia GeForce Go 7300 256MB
Lamo
Young Hen
 
Posts: 29
Joined: Thu Aug 09, 2007 4:17

Re: Borderless Windows when running Compiz

Postby wolfden » Sat Oct 27, 2007 7:12

did you run

Code: Select all
python-updater - i


you have to do that after you update python
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Borderless Windows when running Compiz

Postby joost » Sat Oct 27, 2007 21:27

direct rendering: No


Do you see Nvidia logo when you start up your system?
Because i dont think the nvidia kernel module is loaded at all. (or perhaps because you are using XGL)

Code: Select all
emerge --sync && layman -S

Then
Code: Select all
emerge nvidia-drivers


Nvidia driver doesnt need AIGLX/XGL at all to run compiz-fusion.
In your /etc/X11/xorg.conf at the bottom just enable extention composite. (only after you are SURE you are using latest nvidia-drivers)

Code: Select all
Section "Extensions"
   Option "Composite" "Enable"
EndSection
joost
Sagely Hen
 
Posts: 2566
Joined: Fri Nov 17, 2006 12:11
Location: The Netherlands

Re: Borderless Windows when running Compiz

Postby Lamo » Sat Oct 27, 2007 22:48

Yeah i get the nvidia logo on boot so my drivers are loading. I went ahead and ran upgrade with the 3.4f DVD to see if that would fix my problem but it didn't. Now my accel-manager and fusion-icon won't even open. So I ran
Code: Select all
emerge --sync
then
Code: Select all
emerge portage
Code: Select all
emerge layman
Code: Select all
layman -S
After that i emerged nvidia-drivers. Then I remerged accel-manager and fusion-icon which is now updating compiz to 0.6.2. After this is finished I'll restart X and see what happens and post back. Thanks for the help so far!
Last edited by Lamo on Sun Oct 28, 2007 0:17, edited 1 time in total.
Dell Inspiron 6400
Intel Core 2 Duo 1.86
1 gig ram
nVidia GeForce Go 7300 256MB
Lamo
Young Hen
 
Posts: 29
Joined: Thu Aug 09, 2007 4:17

Re: Borderless Windows when running Compiz

Postby Lamo » Sat Oct 27, 2007 23:24

Now accel-manager will open but still no options for xgl or aixgl??? When I run fusion-icon I get:
Code: Select all
$ fusion-icon
 * Detected Session: kde
 * Searching for installed applications...
 * Using the GTK Interface
 * No module named gtk
 ... Trying another interface
 * Using the Qt4 Interface
 * No module named PyQt4
 ... Trying another interface
 * Using the Qt3 Interface
 * Interface not installed
 *** Error: All interfaces failed, aborting!


WTF!?!?!? Is going here? I don't understand at all. I've tried everything short of reinstalling which I don't want to do because I'd have to back up tons of BS! Why the hell is my python/pyqt install jacked and why can't anything fix it!!!!!!!!!! It's been three weeks since this problem started.
Dell Inspiron 6400
Intel Core 2 Duo 1.86
1 gig ram
nVidia GeForce Go 7300 256MB
Lamo
Young Hen
 
Posts: 29
Joined: Thu Aug 09, 2007 4:17

Re: Borderless Windows when running Compiz

Postby wolfden » Sun Oct 28, 2007 3:19

looks like you have missing use flags

viewtopic.php?f=57&t=10558
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Next

Return to 3D Desktops and Window Managers

Who is online

Users browsing this forum: No registered users and 2 guests

cron