quake2-icculus

A place where Linux Gamers can share their experience and help each other with Linux Games, native or emulated ;)

Moderator: Moderators

quake2-icculus

Postby cryo_genie » Thu Oct 25, 2007 2:04

Sabayon 3.4f
I've been trying to get one of my old fav's, Quake2 working, but have had no success. It installs fine (although there are a lot of messages regarding missing brackets in the source code), but when I try to run it, it goes to a black screen with a flash of a large cursor and then I get:
==== ShutdownGame ====
recursive shutdown
Error: Hunk_End: Could not remap virtual block (2)

Has anyone else run into this?

BTW I have Quake3 running fine.

My hardware consists to an athlon64 X2 4400+, 2 x nvidia 7800 GT OC cards (running SLI=SFR, AFR gives screen corruption) with the nvidia-drivers installed.

Use flags include opengl, qmax, IPV6, sdl alsa (although I have tried other flag combinations). *.pak files are loaded from the original disks.

On compilation (I tried again) one warning regarding Hunk End keeps cropping up:

src/linux/q_shlinux.c: In function ‘Hunk_End’:
src/linux/q_shlinux.c:101: warning: implicit declaration of function ‘mremap’


Any ideas?
cryo_genie
Baby Hen
 
Posts: 4
Joined: Mon Feb 12, 2007 22:40

Return to The Gamers Shed

Who is online

Users browsing this forum: No registered users and 0 guests

cron