3.4e + Intel PRO/Wireless 3945ABG problem

Issues Related to Networking (Wired and Wireless)

Moderator: Moderators

3.4e + Intel PRO/Wireless 3945ABG problem

Postby jm1 » Thu Sep 06, 2007 3:41

This seems to be nearly working on my Inspiron9400. Sabayon finds networks, but cannot connect to them. Hangs on obtaining IP address, and then fails to connect. WiFi icon strobes, never stays lit. Conflict perhaps? Any ideas? I did search the forums and the wiki, but eveything I found pointed to pre 3.4e fixes. Help would be greatly appreciated.
:D
jm1
Baby Hen
 
Posts: 13
Joined: Thu Mar 22, 2007 5:23

Re: 3.4e + Intel PRO/Wireless 3945ABG problem

Postby Element » Thu Sep 06, 2007 4:26

Try resetting the router. If that doesn't work then do
Code: Select all
/etc/init.d/ipw3945d restart
as root or
Code: Select all
/etc/init.d/net.<interface probably eth1 or wlan0> restart
. That should fix it. I assume you're using KDE or Gnome and the network manager has a minor problem with IP addresses. Usually resetting either card or router does the trick. I have the same problem and it is rather annoying.

--Element
Image
On Sabayon @ Freenode: <ColdFlo> im not asking for support <ColdFlo> im asking for help
Element
Growing Hen
 
Posts: 144
Joined: Mon Dec 11, 2006 0:55
Location: 127.0.0.2

Re: 3.4e + Intel PRO/Wireless 3945ABG problem

Postby jm1 » Thu Sep 06, 2007 20:33

Thanks for the response. Unfortunately It did not work :(
Here's what I got the first time around...
Code: Select all
localhost etc # /etc/init.d/ipw3945d restart
 * Stopping ipw3945d ...                                                  [ ok ]
 * Starting ipw3945d ...                                                  [ ok ]
localhost etc # /etc/init.d/net.eth1 restart
 * Starting eth1
 *     /etc/conf.d/wireless is deprecated
 *     Please put all settings in /etc/conf.d/net
 *     /etc/conf.d/wireless is deprecated
 *     Please put all settings in /etc/conf.d/net
 *   Configuring wireless network for eth1
 *   WEP key is not set for "BILL" - not connecting
 *   WEP key is not set for "garnet" - not connecting
 *   Couldn't associate with any access points on eth1
 *   Failed to configure wireless for eth1                                [ !! ]


At this point, I try to reconnect with KNetworkManager. Troubles persist. So I run through the above again and get something slightly different:

Code: Select all
localhost etc # /etc/init.d/ipw3945d restart
 * Stopping ipw3945d ...                                                  [ ok ]
 * Starting ipw3945d ...                                                  [ ok ]
localhost etc # /etc/init.d/net.eth1 restart
 * Starting eth1
 *     /etc/conf.d/wireless is deprecated
 *     Please put all settings in /etc/conf.d/net
 *     /etc/conf.d/wireless is deprecated
 *     Please put all settings in /etc/conf.d/net
 *   Wireless radio has been killed for interface eth1                    [ !! ]


Now no networks show up.

Any other ideas?
jm1
Baby Hen
 
Posts: 13
Joined: Thu Mar 22, 2007 5:23

Re: 3.4e + Intel PRO/Wireless 3945ABG problem

Postby mbmalone » Sun Sep 09, 2007 0:10

I am also having trouble with 3.4e + Intel PRO/Wireless 3945ABG. I can see my network, but not connect to it.
I am using the 64-bit version with the adapter found on eth1 and using WPA2 encryption.

any help would be appreciated.
Michael
mbmalone
Baby Hen
 
Posts: 6
Joined: Sat Aug 25, 2007 16:59

Re: 3.4e + Intel PRO/Wireless 3945ABG problem

Postby pajamabama » Fri Sep 28, 2007 16:27

I use the same wifi chipset and have no problems with it. Just chekcing, you've got the following in lsmod?
Code: Select all
# lsmod
...
ipw3945               118176  1
ieee80211              35784  1 ipw3945
ieee80211_crypt         8192  1 ieee80211
...
HP dv6000t
SabayonLinux 5.5 - x86_64

www.pedorro.com
pajamabama
Growing Hen
 
Posts: 161
Joined: Sun Jan 07, 2007 22:05
Location: In another time's forgotten space.

Re: 3.4e + Intel PRO/Wireless 3945ABG problem

Postby ibendiben » Wed Oct 03, 2007 13:14

Try this:

quit knetworkmanager and choose not to automatically start it again at boot.
now run the following command as root:

net-setup

Go trough this wizard, it asks you to choose your device, it asks if it is a wireless device and so on, then fill in you ssid and encryption key when needed.
If your done type:

rc-update add net.eth1 default <------------just change the above line in net.wlan0 or whatever your wireless device is.

After restart of your computer... start your browser and see... hope your on. This worked for me. Success!
ibendiben
Baby Hen
 
Posts: 8
Joined: Mon Oct 01, 2007 10:34

Re: 3.4e + Intel PRO/Wireless 3945ABG problem

Postby Skeptical » Mon Oct 22, 2007 18:06

Thanks for the magic recipe! it worked exactly as stated for my Dell M90 with Intel PRO/Wireless 3945ABG
Skeptical
Baby Hen
 
Posts: 1
Joined: Mon Oct 22, 2007 17:57


Return to Networking and Wireless

Who is online

Users browsing this forum: No registered users and 1 guest

cron