USB mouse doesn't work in xwindows after update

Issues Related to Hardware (Sound, Video, Printers, Scanners, Webcams, Touchpads, Keyboards, Sensors, Drives, GRUB, etc.)

Moderator: Moderators

USB mouse doesn't work in xwindows after update

Postby drewnix » Mon Oct 15, 2007 18:53

For some reason my USB mouse no longer works in Xwindows (I'm running Gnome and using nvidia driver) however it worked fine before. I'm not totally sure when it broke but I believe it could be due to the following:

1) I upgraded my kernel with genkernel to 2.6.23 and rebuilt all of the modules
2) I did a full world update and may have accidently okayed a config file update using etc-update when i should have denied it

I started off with a fresh install of Sabayon 3.4F.

My mouse still works from the console (ie when xwindows isn't running). I suspect i am not loading a module i'm supposed to but I'm not sure why it works fine in the console and not in X, do they use seperate modules? Also the keyboard works fine its just the mouse; the cursor sits in the middle of screen and doesn't move with mouse input.

Also i've cat'd /dev/input/mouse and /dev/psaux and moved the mouse to verify both are getting input from the mouse.

Any ideas?
Thanks!
drewnix
Baby Hen
 
Posts: 3
Joined: Mon Oct 15, 2007 18:44

Re: USB mouse doesn't work in xwindows after update

Postby wolfden » Tue Oct 16, 2007 1:33

moved to correct forum

if you updated xorg you need to reinstall your mouse drivers
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: USB mouse doesn't work in xwindows after update

Postby drewnix » Tue Oct 16, 2007 5:35

Well I upgraded the mouse driver and that fixed it. However now the mouse is behaving differently then I expected i.e. when I click on title bars it is maximizing (like as if I was double clicking) and I can't launch buttons I've put on my panel. Any idea whats going wrong now?

Thanks for help
drewnix
Baby Hen
 
Posts: 3
Joined: Mon Oct 15, 2007 18:44

Re: USB mouse doesn't work in xwindows after update

Postby wolfden » Tue Oct 16, 2007 6:39

check your mouse settings?

reinstall buggy stuff?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: USB mouse doesn't work in xwindows after update

Postby drewnix » Tue Oct 16, 2007 17:05

I guess the question is what buggy stuff and what mouse settings?

I've reinstalled xf6-input-mouse even tried going back several versions, still has the same problem.

I've tried altering both the gnome-control-center mouse settings and the kcontrol ones... nothing. I've reboot, restarted X etc still nothing.
drewnix
Baby Hen
 
Posts: 3
Joined: Mon Oct 15, 2007 18:44

Re: USB mouse doesn't work in xwindows after update

Postby j7uy5 » Thu Oct 18, 2007 21:46

The unwanted double click action is likely to be due to a problem in the /etc/X11/xorg.conf file. This happened to me in similar circumstances and it drove me nuts for hours.

If you look at xorg.conf, I expect you will find that you now have two mouse driver sections. Simply delete the second one, restart X, and you should be fine.
j7uy5
Simple Hen
 
Posts: 85
Joined: Tue Nov 07, 2006 4:03
Location: Las Cruces, New Mexico, USA


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests