Problem resolving dependencies

Conversations générales au sujet de Sabayon Linux

Moderator: Moderators

Problem resolving dependencies

Postby horsjeu » Sat Oct 13, 2007 18:48

Bonjour à tous, je me présente, Jannick, routier de profession ayant acquit mon premier pc , un ami m'a installé le fabuleux Sabayon avec lequel je rencontre un problème lors de la synchronisation de portage:


La vérification des mises à jour de paquets a démarré...
Analyse terminée pour les paquets masqués dans /usr/portage/profiles/package.mask.
Analyse terminée pour les paquets masqués par l'utilisateur dans /etc/portage/package.mask.
*** Deprecated use of '--nocolor', use '--color=n' instead.
These are the packages that would be merged, in order:
Analyse terminée pour les paquets démasqués dans /etc/portage/package.unmask.
Analyse terminée pour les mot-clefs de paquet dans /etc/portage/package.keywords.
Analyse terminée pour les use flags de paquet de l'utilisateur dans /etc/portage/package.use.
Calculating world dependencies ..... ..... ..... ....
!!! Problem resolving dependencies for x11-wm/metisse
!!! All ebuilds that could satisfy ">=dev-libs/glib-2.13.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/glib-2.14.1 (masked by: package.mask)
# Rémi Cardona <[email protected]> (21 Sep 2007)
# gtk+-2.12 and relevant deps
For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-libs/gtk+-2.12.0" [ebuild])
!!! Depgraph creation failed.

La synchronisation de l'arbre Portage a démarré...
*** Deprecated use of '--nocolor', use '--color=n' instead.
Emerge démarré à: Oct 13, 2007 18:49:33
emerge --quiet --color --nospinner sync
sync
Synchronisation de Portage...
Synchronisation terminée.
q: Updating ebuild cache ...
q: Finished 24210 entries in 0.171331 seconds
* IMPORTANT: 1 config files in '/etc' need updating.
* Type emerge --help config to learn how to update config files.
Ajoutez le paquet à "package.unmask".
Effectué.

La vérification des mises à jour de paquets a démarré...
Analyse terminée pour les paquets masqués dans /usr/portage/profiles/package.mask.
Analyse terminée pour les paquets masqués par l'utilisateur dans /etc/portage/package.mask.
Analyse terminée pour les paquets démasqués dans /etc/portage/package.unmask.
*** Deprecated use of '--nocolor', use '--color=n' instead.
These are the packages that would be merged, in order:
Analyse terminée pour les mot-clefs de paquet dans /etc/portage/package.keywords.
Analyse terminée pour les use flags de paquet de l'utilisateur dans /etc/portage/package.use.
Enregistrement terminé pour les paquets démasqués par l'utilisateur dans /etc/portage/package.unmask.
Calculating world dependencies ..... ..... ..... ..... ..... ....
!!! Problem resolving dependencies for gnome-base/gnome
!!! All ebuilds that could satisfy ">=app-text/rarian-0.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/rarian-0.6.0 (masked by: package.mask)
# Daniel Gryniewicz <[email protected]> (25 Sep 2007)
# The Great GNOME 2.20 mask
For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "gnome-extra/yelp-2.20.0" [ebuild])
!!! Depgraph creation failed.

La vérification des mises à jour de paquets a démarré...
Analyse terminée pour les paquets masqués dans /usr/portage/profiles/package.mask.
Analyse terminée pour les paquets masqués par l'utilisateur dans /etc/portage/package.mask.
*** Deprecated use of '--nocolor', use '--color=n' instead.
These are the packages that would be merged, in order:
Analyse terminée pour les paquets démasqués dans /etc/portage/package.unmask.
Analyse terminée pour les mot-clefs de paquet dans /etc/portage/package.keywords.
Analyse terminée pour les use flags de paquet de l'utilisateur dans /etc/portage/package.use.
Calculating world dependencies ..... ..... ..... ..... ..... ....
!!! Problem resolving dependencies for gnome-base/gnome
!!! All ebuilds that could satisfy ">=app-text/rarian-0.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/rarian-0.6.0 (masked by: package.mask)
# Daniel Gryniewicz <[email protected]> (25 Sep 2007)
# The Great GNOME 2.20 mask
For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "gnome-extra/yelp-2.20.0" [ebuild])
!!! Depgraph creation failed.

La vérification des mises à jour de paquets a démarré...
*** Deprecated use of '--nocolor', use '--color=n' instead.
These are the packages that would be merged, in order:
Calculating world dependencies ..... ..... ..... ..... ..... ....
!!! Problem resolving dependencies for gnome-base/gnome
!!! All ebuilds that could satisfy ">=app-text/rarian-0.5" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/rarian-0.6.0 (masked by: package.mask)
# Daniel Gryniewicz <[email protected]> (25 Sep 2007)
# The Great GNOME 2.20 mask
For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "gnome-extra/yelp-2.20.0" [ebuild])
!!! Depgraph creation failed

merci d'avance pour vos réponses, cordialement jannick.
horsjeu
Baby Hen
 
Posts: 5
Joined: Sat Oct 13, 2007 18:08

Re: Problem resolving dependencies

Postby turquoise » Mon Oct 15, 2007 18:28

Pour glib, je n'en ai aucune idée, parce que je ne semble pas avoir le problème en 32 bits. Je ne sais pas trop pourquoi ces packages sont masqués, mais ça semble lié à Gnome 2.20 et cela arrive parfois que lorsque quelque chose de gros comme une nouvelle version de KDE ou Gnome fait son entrée dans portage. C'est une question d'attendre que tout soit dans portage et fonctionnel je crois. Pour ces packages, il faudra probablement masquer le truc qui fait bloquer le processus en attendant que la situation change. Il est possible de faire le contraire, soit les démasquer, mais ce n'est pas très prudent de le faire. Ceci dit, cela ne devrait pas prendre trop de temps avant que les packages en question ne soient démasqués, donc une autre option serait d'attendre un peu. Les packages fournis avec Sabayon sont généralement assez récents donc les mises à jour ne sont pas nécéssairement obligatoires. Si tu tiens mordicus aux mises à jour pour des raisons de sécurité, il y a moyen de le faire avec glsa-check, mais comme avec toutes les mises à jour, il ne faut pas oublier le revdep-rebuild une fois le processus terminé. ;)

emerge --sync && layman -S
glsa-check -f all
revdep-rebuild
Ma philosophie d'apprentissage : essayer, et si ça casse, essayer de réparer.
My learning philosophy: try it, and if it breaks, try to fix it.
Image
turquoise
Old Dear Hen
 
Posts: 719
Joined: Wed Nov 15, 2006 1:14
Location: Abitibi-Témiscamingue!

Re: Problem resolving dependencies

Postby fiorello » Thu Oct 18, 2007 19:35

Suit les conseille de turquoise et ne le démasque surtout pas,moi je l ai fait est sa ma causé beaucoup de problemes avec Kdelib et les Qt , j'ais passé deux heures pour remetre tout en place . :cyclops:
ASRock Fatal1ty Z68 Professional Gen3 _ Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz _ Nvidia GeForce GTX 560 TI _ AR5416 Wireless Network Adapter [AR5008802.11(a)bgn] _ Mémoire totale 8 Gio _ * linux4.4.0_Sabayon KDE
Image
User avatar
fiorello
Sagely Hen
 
Posts: 1083
Joined: Mon Aug 13, 2007 14:06
Location: Bourg En Bresse - France


Return to French

Who is online

Users browsing this forum: No registered users and 1 guest