Video not playing

Discussions Regarding Software

Moderator: Moderators

Video not playing

Postby Sicarri » Fri Aug 31, 2007 0:15

Whenever i play a video (avi, mpeg, dvd, web stream...) i get the audio but no video. I have the win32codecs. Help me, please.
Sicarri
Baby Hen
 
Posts: 2
Joined: Thu Aug 30, 2007 23:06

Re: Video not playing

Postby wolfden » Fri Aug 31, 2007 5:54

is this browser only or no matter what?
wolfden
Sharecropper
 
Posts: 9050
Joined: Sat Jan 14, 2006 0:55
Location: Midwest USA

Re: Video not playing

Postby Sicarri » Fri Aug 31, 2007 6:30

No matter what! I have tried all the media players that came installed (kaffiene, mplayer, etc...).
Sicarri
Baby Hen
 
Posts: 2
Joined: Thu Aug 30, 2007 23:06

Re: Video not playing

Postby clifford » Sun Sep 23, 2007 22:26

I'm having a similiar problem. I have great sound & video when I play a dvd using Kaffeine/Mplayer. However, when I play a mpg/wmv video file from my hard drive I have great sound but no video, only a blue screen. I have windows codecs installed and ffmpeg. I do have an Intel video chipset which has given me problems to configure but have worked thru configuring native wide-screen resolution (915resolution) at 1280x768 with the i810 driver.
clifford
Baby Hen
 
Posts: 1
Joined: Sun Sep 23, 2007 22:13

Re: Video not playing

Postby kwarki » Sat Oct 13, 2007 9:58

Is anyone here who can help to solve this problem?

No display in any media player. MPlayer switching off after 2 sec.

(Bill G. can)
kwarki
Baby Hen
 
Posts: 4
Joined: Sat Oct 13, 2007 1:15

Re: Video not playing

Postby atila » Sat Oct 13, 2007 13:19

Try with KMplayer.
If you have not KMpkayer installed, do that in a konsole as root:
emerge --sync && layman -S
emerge kmplayer
atila
Simple Hen
 
Posts: 40
Joined: Mon Mar 05, 2007 17:05
Location: Málaga, Spain

Re: Video not playing

Postby kwarki » Sat Oct 13, 2007 23:05

same with kmplayer... only sound and black screen... is this a codecs problem? what codecs you are using? how to install it?
kwarki
Baby Hen
 
Posts: 4
Joined: Sat Oct 13, 2007 1:15

Re: Video not playing

Postby atila » Sun Oct 14, 2007 9:09

Try disabling desktop acceleration: Preferences > Acceleration Manager > give your root password > choose no acceleration (and click Configure Acceleration Manager), and then end session (ctrl+alt+backspace) and start a new one.
Now try a video. If you can play it, you likely have some kind of problem with compiz-fusion and your video card.
Best regards,
atila
Simple Hen
 
Posts: 40
Joined: Mon Mar 05, 2007 17:05
Location: Málaga, Spain

Re: Video not playing

Postby kwarki » Mon Oct 15, 2007 23:06

I've done emerge mplayer and it works. No need to disable 3D. But...

Video is playing in small window only, when I turn on full screen mode then screen is black and video is in the same small size.
Do you know how to do full screen mode? My screen resolution is 1280 x 800 computer HP 510 laptop. video card is Intel 915GM.

Need your help!
kwarki
Baby Hen
 
Posts: 4
Joined: Sat Oct 13, 2007 1:15

Re: Video not playing

Postby martytin » Fri Oct 26, 2007 13:54

Sicarri wrote:Whenever i play a video (avi, mpeg, dvd, web stream...) i get the audio but no video. I have the win32codecs. Help me, please.


Changing the "output-modules" helped me (http://www.sabayonlinux.org/forum/viewtopic.php?f=56&t=10924!

You just installed your 3D Linux desktop and you are really enthusiastic about it. But when you try to play some videos, you get a strange black output. What’s going on?
The common software video players that come with the Linux desktop are able to display the video stream to several types of output devices. This includes several types of output for the graphical interface, and also obscure output devices such as text mode, using ASCII characters.
The default output device is XVideo (or Xv) for players such as those based on GStreamer (totem) and VLC.
As you guessed, there is a bug with XVideo when using Beryl/Compiz. Therefore, to fix, you need to switch to another output device that works.
For GStreamer players (such as totem, the default movie player in GNOME, Ubuntu and so on), you need to run from the command line the command
gstreamer-properties
(with older distributions such as Ubuntu 6.06 there is an option in System/Preferences for this).
and pick
Video, then for Default Video Plugin choose X Window System (No Xv). Click on test to verify that it actually works. Click Close and you are set.
VLC is not installed by default in Ubuntu 6.10. You need to install manually using the Synaptic Package Manager (under System/Administration), once you have activated the Universe repository in Repositories.
Start VLC and click on Settings, then Preferences. Expand Video and then expand Output modules. You will notice several options for output device. How do we actually choose which one should be the active output device? Well, it appears it’s a bit tricky. Select the item Output modules, and notice the checkbox at the bottom right that says Advanced options. Check the box, and now you have the option to select a different output device. Pick X11 video output, click on Save and you are set!


The "no-full-screen-bug" in mplayer I have got too but have not tried to fix it yet.

martytin
martytin
Young Hen
 
Posts: 25
Joined: Wed Jan 10, 2007 17:25

Next

Return to Software in General

Who is online

Users browsing this forum: No registered users and 1 guest

cron